Manjaro does not show up as a boot entry. Disappearing boot entries?

I’m attempting to install Manjaro on my second hard drive. And the installation was successful, but when I rebooted my device, the Manjaro boot entry was nowhere to be seen. But this isn’t the strangest part. After this I wiped my hard disk clean and tried again, but instead of rebooting right away, I checked the boot entries using efibootmgr and Manjaro was right there at the top. But once I rebooted my device, that boot entry disappeared. And when I booted in to my live USB again and checked efibootmgr, this Manjaro entry was nowhere to be seen just like before. I attempted to manually add this entry back with both efibootmgr and EasyUEFI on Windows (which is installed on my first hard drive) on two separate occasions. And the same thing happened. Once I rebooted my device, this boot entry vanished. I have no clue why the entry wont persist after a reboot. I’ve spend hours searching for a solution, but sadly I have found none. Thank you all. I hope one of you can help me fix this :slight_smile:

I`ve seen some UEFIs “loose” (remove) invalid boot entries.
Some UEFIs are just buggy like the one here: [SOLVED] Efi boot entry disappears after reboot. MSI BIOS E7B05IMS.1A0 / Installation / Arch Linux Forums

Oh wow. I’m attempting to install this from an MSI laptop so I assume I have an MSI motherboard as well. Although my BIOS is made by Phoenix instead of MSI for some reason. I’ll look in to that. I guess the solution would be to disguise Manjaro’s entry by making it look like Windows’ entry? I’m a little nervous because I really don’t want to rescue my Windows install if I mess up. I also don’t exactly know what I’m doing so I probably will.

You can try using the default/fallback location for manjaro grub:

$ sudo mkdir -p /boot/efi/EFI/BOOT/
$ sudo mv /boot/efi/EFI/BOOT/BOOTX64.EFI /boot/efi/EFI/BOOT/BOOTX64.EFI.bak
$ sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/EFI/BOOT/BOOTX64.EFI

Hmm. I typed in those commands while chrooted into my Manjaro install but nothing new seemed to happen. Am I supposed to add a new entry with efibootmgr as well? Sorry I’m not too good at this. I’m still very new to the Linux experience.

Those commands should have placed the manjaro grub efi file in the default location.
No extra entry should be necessary - with some luck this default is used on next boot.
See:
https://wiki.archlinux.org/title/GRUB#Default/fallback_boot_path

Ah I see. Sadly it didn’t work though. Maybe it’s the fact that Manjaro is installed to my sdb drive? Because my boot manager detects Windows on my sda drive just fine. I really don’t know what I’m talking about though :confused:

You did select a boot option where UEFI is just trying to boot from that drive which contains the EFI partition mounted at /boot/efi in your manjaro installation?
That should use the default/fallback copied earlier.

I don’t exactly know what that is. I changed my boot mode in the bios from UEFI to UEFI with CSM to LEGACY and only in LEGACY did my drive show up. Although I’m assuming that’s not UEFI because I couldn’t boot in to my drive or even Windows on LEGACY. But there is no option to boot in to my drive anywhere I can find.

Up until now I assumed you where using UEFI boot with an UEFI installation as your OP indicates.
If you do not see your drive as a boot option in UEFI mode, then the partitioning seems to not be gpt but dos?
That could also be a reason why your UEFI might classify the “vanishing” boot entry as invalid and removes it.
Please post output of

$ gdisk -l /dev/$drive-you-are-trying-to-boot-from

Here you go:

GPT fdisk (gdisk) version 1.0.7

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sdb: 2000409264 sectors, 953.9 GiB
Model: Samsung SSD 850 
Sector size (logical/physical): 512/512 bytes
Disk identifier (GUID): C4DE7CAB-25E0-DF45-B9B7-74C50A296393
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 2048, last usable sector is 2000409230
Partitions will be aligned on 2048-sector boundaries
Total free space is 13544 sectors (6.6 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            4096          618495   300.0 MiB   EF00  
   2          618496      2000397734   953.6 GiB   8300

Weird, that shows a gpt partitioned disk with a proper efi parition.
I don’t know why your machines UEFI won’t show it as a boot option.