Manjaro does not show Apple Magic Trackpad Settings [Workaround]

There seems to be a bug in manjaro’s Display Manager when you want to use a secondary touchpad (in my case Apple Magic Trackpad), the device gets connected via Bluetooth and works fine however I was not able to change the settings using System Manager>Touchpad as it was showing me the primary touchpad settings only (the laptop’s touchpad) and the list field was greyed out for some reason so I was not able to select the target device.

I’m now able to change the Magic Trackpad settings after restating the Display Manager by running

sudo systemctl restart display-manager

you just have to pair the device before running the above command and then you can see the Apple Inc, Magic Trackpad 2 options in Touchpad Settings.

surprisingly the problem presist even if you have your Magic Trackpad connected via USB and will not resolve until you execute the restart command.


I never realized my trackpad was not in the settings. So I checked and you are right, it only shows the built-in touchpad.

Now I can use my trackpad without problems but I am curious what settings there are. One thing I miss is to see the battery level.

So I tried the command you suggest but I still only see the Touchpad of the laptop and not the trackpad after restarting the display manager.

I do agree, there seems to be something broken.

Hi @rolandd
One thing that I tried before restarting Desktop Manager was performing a Reset Factory on my Magic Trackpad using macOS, Im not sure if that makes any difference. here’s how you can do it:

1- pair the Magic Trackpad with your laptop inside macOS ( I use OS X 10.11 but any other version should be okay)
2- Hold ALT+SHIFT and click on the bluetooth icon on the macOS toolbar
3- from the Debug sub-menu select Reset Factory All Connected Devices (Im not sure about the exact menu Item name you get the Idea!)
4- You can go an extra mile and Reset Bluetooth Module using the same menu
5- Do not touch the Un-Paired trackpad anymore since it may cause it to Re-Pair

now inside manjaro clear the old bluetooth paired devices and pair your Trackpad again then restart Desktop Manager. I hope this do the tick and you have your settings back.

regarding the options manjaro gives you for the Magic Trackpad, no battery status and no fancy multi touch unfortunately, almost the same option as you have in built-in trackpad.

Hello @hematinik
Thank you for your suggestion, I know it has been a while :slight_smile: Today I finally found some time to try this. Unfortunately it did not work for me, perhaps in the future we will get better Trackpad support.