Manjaro Desktop Environment Malfunction Causing Screenshot and Zoom Glitches

Hello.

My system specs are as follows:

I’ve recently run into some difficulties I believe are from my desktop environment.

The problem initially lay with my attempts to perform a screenshot using Spectacle. Often I find that after pressing the print screen button on a page like the one below:

The Spectacle popup would instead generate a screenshot of some other, possibly already closed page. For example, after pressing print screen while running Dolphin (as above), the screen shot generated (under the capture area of “Full Page”) would actually be this:

Which is really an application that I had closed earlier during the day. Initially I thought it was a minor bug I could work around by changing the area selected under Capture Mode in Spectacle (a highly imperfect fix), but I tried another Screenshot app and the results were the same. Furthermore, I’ve recently found that this glitch has made screen sharing in Zoom impossible.

This is a link to two very short videos of what my screensharing looks like to others over zoom. I recorded my shared screen to generate it.

As you can see the desktop environment is chaotic (notice the tray icons on the bottom right giving popups despite my mouse not being over them) with the desktop background and page partially overlaid against a PowerPoint presentation I was trying to make. However, from my perspective everything is perfectly fine. From my perspective, I’m giving a PowerPoint presentation and moving from slide to slide (you can actually see this in the holes through the overlaid desktop background). It isn’t always the desktop background being overlaid, however. Sometimes it’s some other application page (like Chrome).

I find that restarting the computer seems to “clear” the backlog of pages that pop up (asides from the desktop background), and this is what makes me think it’s a desktop environment issue.

I’m not very sure what’s going on exactly. I hope you guys can help me out here, because this laptop is critical and doesn’t have access to Windows at the moment. Zoom sharing is a vital feature.

Any thoughts? I’d be happy to answer any questions that can help clarify this situation to the best of my ability.

1 Like

I got the same problem here, it’s really confusing. I’ve tried several other screenshot apps and they all went the same way. I guess this might be a KDE problem, not sure. Hope this will be fix soon.

I found an unstable way that could temporarily solve this problem, in system settings find “graphic card and monitor” tab(sorry I’m not sure if the English version is like this, I’m using Chinese version). Then try to change the render mode to any other 2 selections(better to select between OpenGL). This will fix the problem for a few minutes or longer, and the effect will not remain after reboot. If the problem appears again, do that again. I don’t know why but it works, not a good method but it’s the only way I found currently.

I have the same problem. I am running KDE too. I believe the issue has something to do with running multiple virtual desktops. If I keep a single virtual desktop, the problem seems to go away.

Other symptoms i have experienced:

  • sharing screens during an online meeting (Google meet, Zoom, etc) is a problem…shared view flickers between desktop image, a browser window, or another application that was open on another virtual desktop
  • taking screenshots, irrespective of application being used (I have tried Flameshot and Spectacle), is also not possible - the screen or application shown is usually of an application on another virtual desktop or a previous screen capture

Any ideas on potential fixes would be appreciated.