[Manjaro Deepin] Secondary monitor outputs black after monitor suspend

Hi, I am on Manjaro Deepin, using Linux Kernel 5.2 rc6

I have a RX570, using video-linux according mhwd
For whatever reason when my monitors suspend, only my primary monitor wakes up. My secondary monitor wakes up but it outputs black. If I press ctrl + alt + f2 I get the terminal prompt on it. When I go back to the desktop on ctrl + alt + f1 it still outputs black.

I tried going into the dde-control-center and setting the displays to mirrored and then to extend again, but it still outputs black. I also tried xrandr to change the resolution and then back, but it does not help. What does work is unplugging the monitor input and switching it to a different input. Replugging it into the same input does not work.

Anyone else have this issue?

you could see if something as simple as xrandr --auto after waking from suspend turns the monitor back on. xorg-xrandr package needs to be installed. if --auto doesnt work you can read xrandr man page fur more specific commands. man xrandr

xrandr --auto does not work for me, I tried to set different screen resolutions with

xrandr --output DisplayPort-1 --mode 1280x720 --rate 60 and then back to 1920x1080 with no dice

I turned display suspend off today, and then turned off my monitors physically. When I woke up, I turned the montiors back on and the left monitor is still displaying black. However, I can drag windows and my mouse is visible on it. When I try to change the wallpaper, that monitor does display the wallpaper preview. But as soon as I apply it, it's back to outputting black.

this sounds less of a xorg/display issue and more of a desktop environment issue with the layout. see if there is a way to reset the monitor layout or create a new monitor layout profile. this may be one of the many deepin bugs. what do you use to set the monitor layout?

I'm using dde-control-center to arrange the displays.
EDIT: Interesting, re-arranging the display does fix it. Thanks

Although, if I have the monitor sleep and wake up, this doesn't work, I only get a black output(monitor isn't sleeping). I can live with this, I can just turn the display off manually.

you can do some searching "deepin monitor layout" and the like and see how others fix the issue (if they ever did). adding a monitors configuration to /etc/X11/xorg.conf.d/ might help, you can check out the arch wiki for xorg, gentoo also has a pretty good wiki. gentoo is not arch obviously but xorg is xorg so the gentoo wiki on xorg applies all the same.

in the end though it's probably one of deepin's little quirks.
https://wiki.archlinux.org/index.php/Xorg
https://wiki.gentoo.org/wiki/Xorg.conf
extensive:
https://www.x.org/releases/X11R7.7/doc/man/man5/xorg.conf.5.xhtml#heading12

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by