Manjaro Deepin OpenVPN Config file

deepin
vpn

#1

Does anyone know a way to import openvpn config files into Deepin network settings?

i’ve tried using
sudo nmcli connection import type openvpn file "my file.ovpn"
this does import it, but when i try to connect, it fails obviously due to no credentials
I can enter username, but it doesn’t ask for a password
I’m not sure if it’s a Deepin bug, or i’m doing something wrong.

the same config file works using
sudo openvpn [file name]


#2

I’m not sure if Deepin’s builtin network tool can do it. In doubt you can always use nm-applet additionally, which has an option to import VPN config files.


#3

In the Control Center you will find a lot of options:

It’s maybe not very intuitive, but when you click on any of those groups of three dots, it will open file dialogs for you where you can select cert, key and CA files.


#4

i fight with deepin vpn long time and i notice that when i import openvpn file with “nmcli” i must change in settings that oberon post settings “ask for pwd” to remember but after restart computer deepin vpn connection fail so i use openvpn to connect at start

sudo cp yourconfig.openvpn /etc/openvpn/client/config.conf
after you copy your .openvpn file to new location with .conf extension you can edit this file
sudo nano /etc/openvpn/client/config.conf
and change “auth-user-pass” to auth-user-pass password.txt
now you must create this password.txt file so
sudo nano /etc/openvpn/client/password.txt
and enter in this file:
username
password
The contents of this file (password.txt) should simply be only two lines
you can also change permission to this file for security
sudo chmod 600 /etc/openvpn/client/password.txt

and now you can start using with systemctl your connection so:
sudo systemctl start openvpn-client@config
sudo systemctl enable openvpn-client@config
ps:after openvpn-client@ you put your config name

and if you want some notification at start that you use vpn (sometimes server can be down) you can use VPN status in conky

${if_up tun0}VPN Connect${else}VPN Down$endif

check only your interface with ifconfig i have tun0


#5

I have had a play around in there, but it doesn’t ask me for my password.
a red box does flag up my certs when i enter the username, so there is obviously some issue

strangely, they work fine using openvpn via terminal

I could just use that method, but an on/off switch is a lot easier for my requirements, as I switch between VPNs a lot

Edit
I have cleared the certs issue, but it stilll doesn’t ask me for a password
When i try and connect, it says "Disconnected, necessary password for the VPN was not provided"
I have it set to always ask


#6

Deepin VPN setup
look at pdf below
see if that helps
I made somewhat a tutorial for PIA VPN
and it works for me