Manjaro Deepin de resize lags

Easy, we’d have to throw most of our World to black hole than))
They make everything this days :joy:

Use KDE then, I use deepin only for playaround to lazy to delete :wink: and changed to i3.

Deepin is the door opener from Ubuntu/Mint to Manjaro. I like it but work is better with other Manjarooooooos :slight_smile:

Sorry if i didn’t mention, i use Manjaro Deepin obviously)

And i kinda really love it, so hopefully fix will arise…
Since again, only have this weirdness in this machine, rest are fine and smooth

1 Like

You may want to try some reset/restart the window manager or clear deepin cached data (which I don’t know how/if…)

A nice interesting (@tbg) unit maybe this, if you find it usefull (the included commands…?).

1 Like

have you tried the different compositing/style modes (whatchamacallit), i cant remember exactly what it called, maybe blur/non-blur? i just remember one causing issues on my kids laptop for the week or 2 he used it until i got sick of fixing random deepin issues and swapped them out for kde issues :exploding_head:

edit: the compositor deepin uses is “deepin-mutter” (makes sense). maybe backup/play with its configuration?

1 Like

Check above, tried and it kinda work, but still i’d like blur)

So i suppose looking at the link & this https://github.com/linuxdeepin/deepin-mutter

I should try
deepin-wm --replace
deepin-mutter --replace

and then try to play with configuration (can’t see where it is)

Correct?

1 Like

Restarting wm & mutter worked but haven’t affected this behaviour.

configs / cache i was unable to find on my own, so can’t say nothing on that behalf…

that’s 3 years old, i was thinking maybe in ~/.config there would be a mutter folder.
also, cant you edit most of that stuff with gsettings? does deepin use their own version of gsettings?
possibly a man deepin-mutter ?

this may all be nothing more than switching backend/vsync methods, i’ve been playing with compton configs since i mentioned compositor a little while ago, liking the new look, and performs better with glx backend and opengl vsync.
i also had the window sizing issue, not as bad but similar and its gone now (not to rub it in or anything :smirk:)

if its not in ~/.config , search root/home for it’s config location

this is what i could find, from the sound of it, not very configurable:

  1. If for some other reason you really want mutter, the grand total of settings you can adjust is 5, managed through the GConf infrastructure (soon migrated to DConf) and declared in a XML schema located at /usr/share/gconf/schemas/mutter.schemas . To edit them, fire gconf-editor and go to /apps/mutter/ .

thats related directly to gnome but possibly in the same/similar place?

And there is always the upstream project.
You may report a bug with the deepin bug reporter.

Q2: What should I do when I have problems?

A2: First, search in Wiki (https://wiki.deepin.org/ ) and the community (https://bbs.deepin.org/). If there was no answer, execute

sudo deepin-feedback-cli

Copy the Code

to generate a log file (tar.gz) in home directory (please do it right after the problem occurs), and attach it to deepin feedback (http://feedback.deepin.org/).

4 Likes

I don’t see it there, seems that deepin-mutter doesn’t use same locations as mutter, wonder who maintains Manjaro Deepin?)
Probably he would know more…

man deepin-mutter not much here:

MUTTER(1)                                            General Commands Manual                                            MUTTER(1)

NAME
       MUTTER - Clutter based compositing GTK2 Window Manager

SYNOPSIS
       mutter [--display=DISPLAY] [--replace] [--sm-client-id=ID] [--sm-disable] [--sm-save-file=FILENAME] [--version] [--help]

DESCRIPTION
       This manual page documents briefly mutter.

       mutter is a minimal X window manager aimed at nontechnical users and is designed to integrate well with the GNOME desktop.
       mutter lacks some features that may be expected by traditional UNIX or other technical users;  these  users  may  want  to
       investigate other available window managers for use with GNOME or standalone.

OPTIONS
       --display=DISPLAY
              Connect to X display DISPLAY.

       --replace
              a  window  manager which is running is replaced by mutter.  Users are encouraged to change the GNOME window manager
              by running the new WM with the --replace or -replace option, and subsequently saving the session.

       --sm-client-id=ID
              Specify a session management ID.

       --sm-disable
              Disable the session management.

       --sm-save-file=FILENAME
              Load a session from FILENAME.

       --version
              Print the version number.

       -?, --help
              Show summary of options.

CONFIGURATION
       mutter configuration can be found under  Preferences->Windows  and  Preferences->Keyboard  Shortcuts  on  the  menu-panel.
       Advanced configuration can be achieved directly through gsettings.

SEE ALSO
       mutter-message(1)

AUTHOR
       The  original manual page was written by Thom May <thom@debian.org>.  It was updated by Akira TAGOH <tagoh@debian.org> for
       the Debian GNU/Linux system (with permission to use by others), and then updated by Luke Morton  and  Philip  O'Brien  for
       inclusion in mutter.

                                                         11 February 2006                                               MUTTER(1)

Here’s what i found in dconf:


Just as default mutter it doesn’t seem to have nothing like glx / vsync

As far as i know it works only on Deepin itself, not on Manjaro Deepin, i mean their deepin-feedback-cli is not available on Manjaro Deepin, and yeah i haven’t seen this exact sympthoms of a problem on their wiki / forums

have you checked in gsettings? is using an alternative window manager compositor a possibility with deepin?

also, in relation to your previous issues with gpu/cpu , does this behave differently while plugged in than it does on battery?

something else im not sure of, does deepin also use extensions the same way gnome does? first steps in gnome to resolve any undesired activity would be to disable all extension, if that fixes the issue then turn each extension on 1 at a time to see which one causes the issue.

I believe this man just quotes original mutter, and since deepin-mutter seem to use some different paths and stuff, not sure it’s doable…
But i really don’t know anything about it, since basically yesterday i understood that de != compositor :confused:

How would i do this gsettings?
gsettings is Gnome settings right?
There’s also some deepin-desktop-schemas which ain’t packed by default:

Hard to say, since BAT for me is a no go, as you know it’s really laggy so impossible to tell difference in such delicate matter between lag & lag, but if you ask me on BAT absolutely everything graphically related lags worse.

But AC is another story, everything is more than fine except this weird stuff, i accidently noticed it, since most of times i resize windows by bottom-right angle which doesn’t lag like rest of them.

All of the above in this thread is meant to be tested on AC only, since on this system now it’s the only reliable way.

What’s the right way to check it?

google/ddg ? OR you could give up on trying to fix what many others have tried to fix many times over and over and failed.
nvidia+gnome+mutter = stutter. drove me nuts until i dropped gnome.
as far as i know it’s always been an issue with nvidia/mutter.

i guess you could just run a backup and then try some bolder moves like trying to force a different compositor??

you could try the mutter workaround, it’s meant for fixing mutter performance issues when using nvidia. its in the aur
http://aur.archlinux.org/packages/mutter-781835-workaround

that may need some special intervention since gnome-desktop is a dependency, or you could figure out what the difference is and apply it to deepin-mutter ?

I guess it is GTK settings, so since there are deepin schemas, you can use them, but it is the same as using Dconf.
Since I 'm not using Deepin, only you or some other Deepin user can search for any setting, though I believe it is a theme or package issue/bug.

So, to summarise it for those who’ll find this thread:

@dglt was right, it’s nvidia + mutter and Deepin devs kinda confirmed it, there’s upstream issue here:

And most likely if it’s gonna be solved one day, it will be:

There is some ongoing effort to make a new wm based on kwin in the DDE team.
© BLumia

Which is actually pretty good news, since it will also allow us to use Wayland with Manjaro Deepin! :slightly_smiling_face:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.