Manjaro deepin 17.0.5, how to enter "try before install" desktop


Hi, I was eager to try Manjaro on my laptop and chose Manjaro deepin 17.0.5 to install. After some try and error, I managed to boot into Manjaro architecture installer but it seems a bit too advanced for me so I try to find the Calameres installer but no luck. Here is what I do:

Make bootable usb with Rufus, DD mode.
Boot into usb and see a menu to select tz, lang, keytable, …
Select nonfree driver
To line “boot: manjaro deepin”, press “e”, replace “quiet” with "3"
Got into login console where I can use “setup” command to start MA installer.

But that’s it, I have no idea how I can go to “try before install” desktop and open Calameres. Any help ?


Why are you doing this? This takes you into single-user CLI mode instead of the normal desktop and shouldn’t be needed by most people.

Have you tried booting normally?


Because I will get stuck at “started TLP system startup/shutdown” if I dont’t


OK, then you have a different issue. What hardware do you have?


My laptop is Dell Inspiron 7559, intel i7 6700m, nvidia gtx 960m. I always have problem when booting with nouveau driver on other distros if that is related.


Try to follow this few suggestions made in this posts:



Suggest forum searching for this exact phrase, you’ll find many threads with your laptop. Many issues reported with booting ISO and post installation booting with bumblebee.

It just doesn’t play nice with Arch / Manjaro and bumblebee. Have a read.

Best way to get this machine booting is via manjaro-architect and manually selecting the video-intel driver.


Wow I thought my laptop doesn’t play nice with linux but didn’t expect that many issues. Thanks for the help.


Here you go: Dell Inspiron 15 7559 Install media won't boot


Thanks, That worked. I later got black screen issue after login if on battery but solved it by adding ‘nouveau.modeset=0’ to grub.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.