Manjaro-Deepin 17.0.4

community-edition
deepin

#1

Manjaro-Deepin 17.0.4 is ready for download

latest changes:

  • latest Deepin 15.4.1 packages with some more Manjaro specific customization and fixes.
  • Deepin-system-monitor has been added
  • Deepin-image-viewer now fully replaces gthumb.
  • included fix for root-filemanager

#2

Torrents ready for download here (when the SF mirrors sync):
https://sourceforge.net/projects/manjarotorrents/files/community/deepin/17.0.4/


#3

i’ll download later asap :smiley:


#4

Downloaded and seeding. Giving it a spin on my laptop :slightly_smiling_face:


#5

something more about that?if i have installed deepin 17.02 with pacman -Syu i will have this “fix” ? or only if i install new version?


#6

No, for an existing user it won’t be able to update.
You will need to edit your ~/.local/share/applications/root-filemanager.desktop file and change the Exec= line like this:


#7

I was about to post about the file manager not respecting theming, but am glad I searched the forum first. Seems a bit of a fascist perplexing choice from the developers :confused:

Oh well…I’m quite enjoying Deepin otherwise, so I might take your suggestion and install Nautilus for asthetics if nothing else. One thing I didn’t think would take some getting used to was not having the clock always shown.

Thanks for all the hard work!


#8

found a small problem:
if the graphic effects are off the bar and the control center becomes both transparent rather than opaque
I tried to do the same with arch and deepin iso and are not transparent so it is a specific problem of manjaro deepin


#9

I have configured transparency to work also with metacity, because so many people try the ISO in vbox and they will not see how the environment really looks with transparency disabled.
Why is this a problem?
If you really want to turn off transparency you can do that via gsettings:

gsettings set com.deepin.wrap.gnome.metacity compositing-manager=false

#10

it is not a real problem
I just do not like it and I did not know I could change it (noob here) :slight_smile:
thanks for the info anyway :slight_smile:


#11

The developers certainly make odd choices on Deepin. Digging around dcomf will show you all kinds of oddities, like Deepin, Gnome and Pantheon settings, sometimes with the same settings showing up in two or three of those. My favorite odd thing is the date format, I prefer 12 September 2017 which is the standard in most of the world outside of the US. Oddly it uses the US format despite being a Chinese distro.

@oberon what is this fix for root-filemanager? Is it something important that I should edit that file, or just ignore? And yes, this means I’ve updated to 17.04 (boy, my install timing sucked, installed Deepin around one day before the update), and I’m mostly liking it aside from some odd ball nuisances here and there, everything is working fine, its come a long way.


#12

So you have installed the 7.0.3-rc ISO? No big deal at all.
Since then I switched deepin-terminal profile from ‘tango’ back to ‘deepin’ and installed deepin-system-monitor instead of gnome-system-monitor.
All the other changes you have already received via package updates, so you should be just fine :slight_smile:


#13

A post was merged into an existing topic: [Stable Update] 2017-09-08 - Mesa, Kernels, PulseAudio, LibreOffice, KDE Apps, Cinnamon


#14

7.03? Did you mean 17.03? Looking through my ISO collection, looks like I installed 17.01 only a couple days before 17.04 came out.


#15

@oberon, thank you for a wonderful edition of manjaro! Deepin - though younger than most desktop environments - is one of my favorite for its simplicity and elegance. I have picked up a copy of your Manjaro-Deepin 17.0.4 iso and am also seeding the torrent!

Just fyi, I have it cruising right along on an HP Stream 13 laptop this evening, and I will be putting it on my desktop tomorrow.

Thanks and keep up your great work on Manjaro!

-tuxfan1


#16

@oberon Thanks for the nice deepin edition of manjaro. It is simple and elegant deskop. My desktop looks really cool now.

FYI, deepin file manager auto mount not working with encrypted volumes.
The deepin file manager is not worked for me but the root file manager worked! After a hour of digging, I found an password protected encrypted volume and filemanager tries to auto mount that unfortunately the password diaglog did not showed up instead a black box is displayed. Once I disabled auto mount everything working fine


#17

Video preview by “Linux Scoop”:


#18

Man I totally love your work on this distro, this is the best distro how ever I wasnt able to use it at all because the OS only appears on 1 screen and doesn’t on the other, due to some problem with the nvidia graphics drivers (I have nvidia 610 or something, not the latest i guess)

I’m like oh god let this update fix the issue and i can use manjaro for 2 monitors haha =3


#19

Deepin 17.0.5 Network settings issue

No problems with wifi settings, but Ethernet settings _cannot save if i change the DNS.

This is my wifi settings (auto generated by deepin net settings) working good from the 1st time i’ve been making changes

/etc/NetworkManager/system-connections/

[connection]
id=VA *** 5
uuid=551db6c1-0a8f-4bcf-9e5a-f32fa2c2d2fe
type=wifi
permissions=
timestamp=1506492744

[wifi]
mac-address=00:A0:A2:95:CD:2A
mac-address-blacklist=
mode=infrastructure
seen-bssids=12:13:31:15:A2:CD;
ssid=VA *** 5

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=***

[ipv4]
dns=8.8.8.8;8.8.4.4;
dns-search=
ignore-auto-dns=true
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

ON the way to make my dns working with eth cable, i’ve had to change configuration file manually.

wired connection 1

[connection]
id=Connessione cablata 1
uuid=a622c443-2473-49bc-8588-96a6243beeea
type=ethernet
permissions=

[ethernet]
mac-address=00:22:15:95:6A:BF
mac-address-blacklist=

[ipv4]
method=auto
dns=8.8.8.8;8.8.4.4;
ignore-auto-dns=true
#[ipv4]
#dns=8.8.8.88;8.8.4.4;
#dns-search=
#method=auto
#never-default=true

[ipv6]
method=ignore
#[ipv6]
#addr-gen-mode=stable-privacy
#dns-search=
#method=auto

/etc/dhcpcd.conf

added

nohook resolv.conf
static domain_search=your.domain.example.org
static domain_name_servers=8.8.8.8 4.4.4.4

at the end of file

cat /etc/resolv.conf
# Generated by resolvconf
nameserver 8.8.8.8
nameserver 8.8.4.4

cat /etc/resolvconf.conf
# Configuration for resolvconf(8)
# See resolvconf.conf(5) for details

resolv_conf=/etc/resolv.conf
# If you run a local name server, you should uncomment the below line and
# configure your subscribers configuration files below.
#name_servers=127.0.0.1
# Google nameservers
nameserver 8.8.8.8
nameserver 8.8.4.4

#20

Any info about the issue?
Any suggestion about my eth setting? Dou you think i’d better to set ETHERNET IPV4 and IPV6 just like the auto generated settings?

/etc/NetworkManager/system-connections/
auto generated conf for wifi

[ipv4]
dns=8.8.8.8;8.8.4.4;
dns-search=
ignore-auto-dns=true
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

now the wired conf (manually edited)

[ipv4]
method=auto
dns=8.8.8.8;8.8.4.4;
ignore-auto-dns=true
#[ipv4]
#dns=8.8.8.88;8.8.4.4;
#dns-search=
#method=auto
#never-default=true

[ipv6]
method=ignore
#[ipv6]
#addr-gen-mode=stable-privacy
#dns-search=
#method=auto