Manjaro completely freezes when resuming from standby and the external monitor is not turned on

Manjaro completely freezes when resuming from standby and the external monitor is not turned on.
If I turn on the monitor beforehand it works just fine.

The monitor is connected via USB-C / Displayport on a Thunderbolt 4 Port.

I can’t use the LTS Kernel, because on this one the brightness adjustment doesn’t work

System:
  Kernel: 5.17.15-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=97c37ae5-35c0-4fd3-80a4-a7ecaf3fad24 rw quiet
    cryptdevice=UUID=83b3ecb5-0465-4d91-8c3a-f240695eb071:luks-83b3ecb5-0465-4d91-8c3a-f240695eb071
    root=/dev/mapper/luks-83b3ecb5-0465-4d91-8c3a-f240695eb071 apparmor=1
    security=apparmor
    resume=/dev/mapper/luks-85d6d627-c623-4bfa-bb6d-a7892a5b4e83
    udev.log_priority=3
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.34 vt: 7 dm: LightDM v: 1.30.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Alienware product: Alienware m15 R7 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Alienware model: 02R5KV v: A00 serial: <superuser required>
    UEFI: Alienware v: 1.4.1 date: 02/25/2022
Battery:
  ID-1: BAT0 charge: 78.6 Wh (100.0%) condition: 78.6/84.3 Wh (93.2%)
    volts: 13.0 min: 11.4 model: BYD DELL M59JH1A type: Li-poly
    serial: <filter> status: full
CPU:
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 built: 2021 process: Intel 7 (10nm ESF)
    family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x41C
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2133 high: 4400 min/max: 400/4679:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3586 2: 910 3: 4380
    4: 2904 5: 2365 6: 4400 7: 1174 8: 1811 9: 702 10: 2170 11: 400 12: 991
    13: 914 14: 1069 15: 575 16: 1065 17: 3300 18: 3316 19: 3348 20: 3299
    bogomips: 107560
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen12.2 process: Intel 10nm built: 2021-22+ ports:
    active: DP-1,eDP-1 empty: DP-2 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2560
    class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 0c45:6a10 class-ID: 0e02
  Device-4: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-1.3:4
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7040x1440 s-dpi: 96 s-size: 1862x381mm (73.31x15.00")
    s-diag: 1901mm (74.83")
  Monitor-1: DP-1 pos: primary,top-right model: Samsung C49RG9x
    serial: <filter> built: 2018 res: 5120x1440 hz: 120 dpi: 109 gamma: 1.2
    size: 1190x340mm (46.85x13.39") diag: 1239mm (48.8") modes:
    max: 5120x1440 min: 720x400
  Monitor-2: eDP-1 pos: bottom-l model: LG Display 0x06e2 built: 2021
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl bus-ID: 3-1.1:5
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 1397:0507 chip-ID: 8086:51c8 class-ID: fe01 class-ID: 0401
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-3: BEHRINGER GmbH UMC202HD 192k type: USB driver: snd-usb-audio
  Device-4: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-1.3:4
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.17.15-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 3c:00.0
    chip-ID: 10ec:3000 class-ID: 0200
  IF: enp60s0 state: up speed: 2500 Mbps duplex: full mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 4-1.4:5 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp0s20f0u1u4 state: down mac: <filter>
  IF-ID-1: br-051ebf383247 state: down mac: <filter>
  IF-ID-2: br-6b4142947dc3 state: down mac: <filter>
  IF-ID-3: br-a26d206a49ad state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-4: br-be203d4f6d7d state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-5: br-ee3533915b30 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-6: docker0 state: down mac: <filter>
  IF-ID-7: veth1361a68 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-8: veth158fc51 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-9: veth287fb8a state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-10: veth46823d4 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-11: veth6366a6a state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-12: veth9d1ffdc state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-13: vethbde403b state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-14: vethd8ada34 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:10 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 1.16 TiB used: 90.4 GiB (7.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: PM9A1 NVMe 1024GB size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 36308229 temp: 44.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 1B2QEXM7 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 919.42 GiB size: 903.92 GiB (98.31%)
    used: 90.38 GiB (10.0%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-83b3ecb5-0465-4d91-8c3a-f240695eb071
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 27.8 MiB (9.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.14 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-85d6d627-c623-4bfa-bb6d-a7892a5b4e83
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 498 Uptime: 26m wakeups: 3 Memory: 31.04 GiB
  used: 6.75 GiB (21.7%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1331
  lib: 320 flatpak: 0 Shell: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.19

Any ideas why this happens?

try with the 5.18 kernel

I tried 5.18 as soon as it was available as I want to utalise Intel’s Thread Director that comes with this version… but Manjaro doesn’t boot on my Laptop with 5.18.

And i tried it recently again with 5.18.5-1… but still can’t boot

probably because of nvidia… the 5.17 is going to be eol anyway… try the 5.19

I couldn’t download the 5.19 Kernel. Than i realized that my packages were out of date. I had to remove /var/lib/pacman/db.lck and now pacman is working again.

I installed and bootet 5.19.rc4-1 but got the same behavior as with 5.18.
The boot process stops at:

input: sof-hda-dsp HDMI/DP,pcm=5 as /device/...../skl_hda_dsp_generic/sound/card3/input33

and after a minute or so the screen turns black with a frozen cli cursor.

Also sometimes i have to restart my network manager after standby, because traffic has a really high latency.

provide also logs:
journalctl -b0 -p4 --no-pager

I disabled this step with snd_hda_intel.dmic_detect=0, but the boot process still stopped a roughly the same time (about 25s). So I guess it must be something else. I made also some pics of the screen but cant upload them here.

Jul 09 21:32:46 alienware kernel:  #13 #14 #15 #16 #17 #18 #19
Jul 09 21:32:46 alienware kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
Jul 09 21:32:46 alienware kernel: pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
Jul 09 21:32:46 alienware kernel: pnp 00:05: disabling [mem 0xc0000000-0xcfffffff] because it overlaps 0000:00:02.0 BAR 9 [mem 0x00000000-0xdfffffff 64bit pref]
Jul 09 21:32:46 alienware kernel: hpet_acpi_add: no address or irqs in _CRS
Jul 09 21:32:46 alienware kernel: SPI driver ili9163 has no spi_device_id for newhaven,1.8-128160EF
Jul 09 21:32:46 alienware kernel: efifb: Ignoring BGRT: unexpected or invalid BMP data
Jul 09 21:32:46 alienware kernel: i8042: Warning: Keylock active
Jul 09 21:32:46 alienware systemd-journald[493]: File /var/log/journal/087fc72db67c441da92603d9d9597ab7/system.journal corrupted or uncleanly shut down, renaming and replacing.
Jul 09 21:32:47 alienware kernel: Userspace governor deprecated: use thermal netlink notification instead
Jul 09 21:32:47 alienware kernel: nvidia: loading out-of-tree module taints kernel.
Jul 09 21:32:47 alienware kernel: nvidia: module license 'NVIDIA' taints kernel.
Jul 09 21:32:47 alienware kernel: Disabling lock debugging due to kernel taint
Jul 09 21:32:47 alienware kernel: 
Jul 09 21:32:47 alienware kernel: wmi_bus wmi_bus-PNP0C14:00: WQ00 data block query control method not found
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: wmi_bus wmi_bus-PNP0C14:03: WQBC data block query control method not found
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:03: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:04: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:05: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:06: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:07: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:08: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: acpi PNP0C14:09: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 21:32:47 alienware kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  515.57  Wed Jun 22 22:44:07 UTC 2022
Jul 09 21:32:48 alienware kernel: resource sanity check: requesting [mem 0xfedc0000-0xfedcffff], which spans more than pnp 00:05 [mem 0xfedc0000-0xfedc7fff]
Jul 09 21:32:48 alienware kernel: caller igen6_probe+0x199/0x7e0 [igen6_edac] mapping multiple BARs
Jul 09 21:32:48 alienware kernel: snd_hda_intel 0000:00:1f.3: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
Jul 09 21:32:48 alienware kernel: snd_hda_intel 0000:01:00.1: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
Jul 09 21:32:48 alienware kernel: nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
Jul 09 21:32:48 alienware kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-69.ucode failed with error -2
Jul 09 21:32:48 alienware kernel: iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
Jul 09 21:32:48 alienware kernel: r8169 0000:3c:00.0: can't disable ASPM; OS doesn't have ASPM control
Jul 09 21:32:48 alienware kernel: thermal thermal_zone9: failed to read out thermal zone (-61)
Jul 09 21:32:48 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 1, ret=-1
Jul 09 21:32:48 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 2, ret=-1
Jul 09 21:32:48 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 3, ret=-1
Jul 09 21:32:49 alienware kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS returned 0 bytes
Jul 09 21:32:51 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 24000
Jul 09 21:32:51 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 32000
Jul 09 21:32:51 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 48000
Jul 09 21:32:52 alienware kernel: dell_smbios: Unable to run on non-Dell system
Jul 09 21:32:52 alienware kernel: dell_wmi_sysman: Unable to run on non-Dell system
Jul 09 21:32:52 alienware kernel: dell_smbios: Unable to run on non-Dell system
Jul 09 21:32:53 alienware kernel: dell_wmi_sysman: Unable to run on non-Dell system
Jul 09 21:32:53 alienware kernel: kauditd_printk_skb: 23 callbacks suppressed
Jul 09 21:32:53 alienware boltd[1422]: [44b08780-6089-domain0                    ] udev: failed to determine if uid is stable: unknown NHI PCI id '0x463e'
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 1, ret=-1
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 2, ret=-1
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 3, ret=-1
Jul 09 21:32:54 alienware kernel: ACPI Warning: \_SB.PC00.PEG1.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20211217/nsarguments-61)
Jul 09 21:32:54 alienware kernel: ACPI Warning: \_SB.NPCF._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20211217/nsarguments-61)
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 1, ret=-1
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 2, ret=-1
Jul 09 21:32:54 alienware kernel: iwlwifi 0000:00:14.3: WRT: Failed to set DRAM buffer for alloc id 3, ret=-1
Jul 09 21:32:54 alienware kernel: ACPI Error: No handler for Region [ECRG] (000000009e6d31e6) [EmbeddedControl] (20211217/evregion-130)
Jul 09 21:32:54 alienware kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20211217/exfldio-261)
Jul 09 21:32:54 alienware kernel: ACPI Error: Aborting method \_SB.PC00.PEG1.PEGP.LCD0.MXDM due to previous error (AE_NOT_EXIST) (20211217/psparse-529)
Jul 09 21:32:56 alienware lightdm[1554]: gkr-pam: no password is available for user
Jul 09 21:32:57 alienware lightdm[1554]: gkr-pam: couldn't unlock the login keyring.
Jul 09 21:32:57 alienware gnome-keyring-daemon[1628]: discover_other_daemon: 1
Jul 09 21:32:57 alienware gnome-keyring-daemon[1629]: discover_other_daemon: 1
Jul 09 21:32:57 alienware gnome-keyring-daemon[1630]: discover_other_daemon: 1
Jul 09 21:32:59 alienware kernel: kauditd_printk_skb: 53 callbacks suppressed
Jul 09 21:32:59 alienware cinnamon-session[1574]: WARNING: t+1,95430s: Detected that screensaver has appeared on the bus
Jul 09 21:32:59 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 48000
Jul 09 21:32:59 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 48000
Jul 09 21:32:59 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 48000
Jul 09 21:33:04 alienware kernel: kauditd_printk_skb: 815 callbacks suppressed
Jul 09 21:33:09 alienware kernel: kauditd_printk_skb: 23 callbacks suppressed
Jul 09 21:33:16 alienware kernel: kauditd_printk_skb: 60 callbacks suppressed
Jul 09 21:33:18 alienware gnome-keyring-daemon[1569]: asked to register item /org/freedesktop/secrets/collection/login/2, but it's already registered
Jul 09 21:33:18 alienware gnome-keyring-d[1569]: asked to register item /org/freedesktop/secrets/collection/login/2, but it's already registered
Jul 09 21:33:23 alienware kernel: kauditd_printk_skb: 130 callbacks suppressed
Jul 09 21:33:49 alienware xdg-desktop-por[6591]: Failed to get application states: GDBus.Error:org.freedesktop.portal.Error.Failed: Could not get window list
Jul 09 21:33:50 alienware cinnamon-session[1574]: WARNING: t+52,94107s: Detected that screensaver has left the bus

there are some wifi issues… and you have two wifis on your pc?
also provide:
find /etc/X11/ -name "*.conf"
mhwd -l && mhwd -li

No, just the onboard wifi card. WiFi works fine.

/etc/X11/mhwd.d/nvidia.conf
/etc/X11/xorg.conf.d/00-keyboard.conf
/etc/X11/xorg.conf.d/90-mhwd.conf
> 0000:01:00.0 (0300:10de:2560) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI


Warning: No installed USB configs!

Another weird issue that i have is that I can’t set the refresh rate of the Laptop display to 165Hz.

according to this you have 2 wifis, one intel, and the other one realtek:

Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169

you have a lot if issues with it, but it could be because its a quite new pc…
how much logs do you have:
journalctl --disk-usage

The first one is the Intel® Wi-Fi 6 AX201 Wifi Adapter and the second one is the Killer E3000 Gigabit Ethernet Controller. Its not the intel killer wifi

Yes, but for my work it’s still way better than windows. Manjaro was the only OS that managed to run my monitor properly without hassle.

Archived and active journals take up 410.4M

so what is this third one:

Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152

you could try booting into latest manjaro iso, but an official one, like KDE, boot with proprietary drivers and test in the live session:
putting your pc into standby and see if you have freezes;
setting the refresh rate to 165hz

also try this go to:
/etc/default/grub
open the grub file and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes “” add this parameter:
pcie_aspm=off
dont remove any other parameters from there, just add it there
then run this command:
sudo updage-grub
reboot and test putting your pc into standby, and also test the wifi, since you mentioned you have also some issues with it

2 Likes

Sorry, totally forgot about that one: That’s the Ethernet Port of my USB hub. I will try a fresh ISO when 5.18/5.19 is stable.

No i do not have any issues with my WiFi - that works just fine. It’s just sometimes after i resume from standby, that network connectivity is laggy, not slow, just laggy.

I added the boot parameter. 5.19 still wont boot but it seems that at least my laptop won’t freeze up when the monitor is not powered on.

Thanks for your Help!

so provide logs from the failed boot:
journalctl -b-1 -p4 --no-pager

also test the network connection if the parameter helped also with it:

Network also seems to work fine. But that lagging only happens occasionally

 ~$ journalctl -b-1 -p4 --no-pager
Jul 09 23:19:48 alienware kernel:  #13 #14 #15 #16 #17 #18 #19
Jul 09 23:19:48 alienware kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
Jul 09 23:19:48 alienware kernel: pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
Jul 09 23:19:48 alienware kernel: pnp 00:05: disabling [mem 0xc0000000-0xcfffffff] because it overlaps 0000:00:02.0 BAR 9 [mem 0x00000000-0xdfffffff 64bit pref]
Jul 09 23:19:48 alienware kernel: hpet_acpi_add: no address or irqs in _CRS
Jul 09 23:19:48 alienware kernel: efifb: Ignoring BGRT: unexpected or invalid BMP data
Jul 09 23:19:48 alienware kernel: i8042: Warning: Keylock active
Jul 09 23:19:48 alienware kernel: nvme nvme1: missing or invalid SUBNQN field.
Jul 09 23:19:48 alienware kernel: nvidia: loading out-of-tree module taints kernel.
Jul 09 23:19:48 alienware kernel: nvidia: module license 'NVIDIA' taints kernel.
Jul 09 23:19:48 alienware kernel: Disabling lock debugging due to kernel taint
Jul 09 23:19:49 alienware kernel: 
Jul 09 23:19:49 alienware kernel: traps: Missing ENDBR: _nv011433rm+0x0/0x10 [nvidia]
Jul 09 23:19:49 alienware kernel: ------------[ cut here ]------------
Jul 09 23:19:49 alienware kernel: kernel BUG at arch/x86/kernel/traps.c:253!
Jul 09 23:19:49 alienware kernel: invalid opcode: 0000 [#1] PREEMPT SMP NOPTI
Jul 09 23:19:49 alienware kernel: CPU: 1 PID: 468 Comm: systemd-modules Tainted: P           OE     5.19.0-1-MANJARO #1 6c32cbe805aaa58bc09ff658c831a0abe429107b
Jul 09 23:19:49 alienware kernel: Hardware name: Alienware Alienware m15 R7/02R5KV, BIOS 1.4.1 02/25/2022
Jul 09 23:19:49 alienware kernel: RIP: 0010:exc_control_protection+0xc2/0xd0
Jul 09 23:19:49 alienware kernel: Code: 8b 93 80 00 00 00 be fa 00 00 00 48 c7 c7 0d 16 49 8e e8 51 82 4a ff e9 72 ff ff ff 48 c7 c7 f4 15 49 8e e8 80 e3 fa ff 0f 0b <0f> 0b 66 66 2e 0f 1f 84 00 00 00 00 00 90 66 0f 1f 00 55 53 48 89
Jul 09 23:19:49 alienware kernel: RSP: 0018:ffffb16cc0cc7b48 EFLAGS: 00010002
Jul 09 23:19:49 alienware kernel: RAX: 0000000000000033 RBX: ffffb16cc0cc7b68 RCX: 0000000000000027
Jul 09 23:19:49 alienware kernel: RDX: 0000000000000000 RSI: 0000000000000001 RDI: ffff9be6ef261660
Jul 09 23:19:49 alienware kernel: RBP: 0000000000000003 R08: 0000000000000000 R09: ffffb16cc0cc79e0
Jul 09 23:19:49 alienware kernel: R10: 0000000000000003 R11: ffff9be70f7ac3e8 R12: 0000000000000000
Jul 09 23:19:49 alienware kernel: R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
Jul 09 23:19:49 alienware kernel: FS:  00007fa8d70ff200(0000) GS:ffff9be6ef240000(0000) knlGS:0000000000000000
Jul 09 23:19:49 alienware kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 09 23:19:49 alienware kernel: CR2: 0000560106376000 CR3: 000000010b96a004 CR4: 0000000000f70ee0
Jul 09 23:19:49 alienware kernel: PKRU: 55555554
Jul 09 23:19:49 alienware kernel: Call Trace:
Jul 09 23:19:49 alienware kernel:  <TASK>
Jul 09 23:19:49 alienware kernel:  asm_exc_control_protection+0x2b/0x30
Jul 09 23:19:49 alienware kernel: RIP: 0010:_nv011433rm+0x0/0x10 [nvidia]
Jul 09 23:19:49 alienware kernel: Code: 66 2e 0f 1f 84 00 00 00 00 00 48 83 ec 08 e8 57 10 1e 00 48 83 c4 08 48 89 c7 e9 bb ff ff ff 66 2e 0f 1f 84 00 00 00 00 00 90 <48> 89 f7 e9 18 08 00 00 0f 1f 84 00 00 00 00 00 48 89 f7 e9 18 08
Jul 09 23:19:49 alienware kernel: RSP: 0018:ffffb16cc0cc7c18 EFLAGS: 00010202
Jul 09 23:19:49 alienware kernel: RAX: ffffffffc1216940 RBX: ffffffffc342b230 RCX: 0000000000000000
Jul 09 23:19:49 alienware kernel: RDX: 00000000000239bd RSI: 0000000000000010 RDI: ffffffffc342b230
Jul 09 23:19:49 alienware kernel: RBP: ffff9bdfa0245fe0 R08: 0000000000000020 R09: ffffffffc342b270
Jul 09 23:19:49 alienware kernel: R10: ffffffffc33e1f70 R11: 0000000000000000 R12: 0000000000000010
Jul 09 23:19:49 alienware kernel: R13: ffff9bdfa0243000 R14: 000055e9fc0e0b90 R15: ffffb16cc0cc7d98
Jul 09 23:19:49 alienware kernel:  ? _nv034913rm+0x20/0x20 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv011431rm+0x24/0xe0 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv034914rm+0xe/0xa0 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv034917rm+0x1d/0x30 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv034919rm+0x2f/0x40 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv015567rm+0x15/0x70 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  _nv000642rm+0x9/0x20 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  ? cdev_add+0x4d/0x60
Jul 09 23:19:49 alienware kernel:  rm_init_rm+0x17/0x60 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  nvidia_init_module+0x242/0x613 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  ? nvidia_init_module+0x613/0x613 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  nvidia_frontend_init_module+0x50/0x91 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  ? nvidia_init_module+0x613/0x613 [nvidia 1431d3e372844c42fe0d2a84342b9c1fabf8fd8f]
Jul 09 23:19:49 alienware kernel:  do_one_initcall+0x5a/0x220
Jul 09 23:19:49 alienware kernel:  do_init_module+0x4a/0x1e0
Jul 09 23:19:49 alienware kernel:  __do_sys_init_module+0x138/0x1b0
Jul 09 23:19:49 alienware kernel:  do_syscall_64+0x5c/0x90
Jul 09 23:19:49 alienware kernel:  ? vfs_read+0x145/0x190
Jul 09 23:19:49 alienware kernel:  ? ksys_read+0x6f/0xf0
Jul 09 23:19:49 alienware kernel:  ? syscall_exit_to_user_mode+0x26/0x50
Jul 09 23:19:49 alienware kernel:  ? do_syscall_64+0x6b/0x90
Jul 09 23:19:49 alienware kernel:  ? do_user_addr_fault+0x1db/0x680
Jul 09 23:19:49 alienware kernel:  ? exc_page_fault+0x74/0x170
Jul 09 23:19:49 alienware kernel:  entry_SYSCALL_64_after_hwframe+0x46/0xb0
Jul 09 23:19:49 alienware kernel: RIP: 0033:0x7fa8d731299e
Jul 09 23:19:49 alienware kernel: Code: 48 8b 0d fd a3 0e 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa 49 89 ca b8 af 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d ca a3 0e 00 f7 d8 64 89 01 48
Jul 09 23:19:49 alienware kernel: RSP: 002b:00007ffe64f31058 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
Jul 09 23:19:49 alienware kernel: RAX: ffffffffffffffda RBX: 000055e9fc0e1150 RCX: 00007fa8d731299e
Jul 09 23:19:49 alienware kernel: RDX: 000055e9fc0e0b90 RSI: 00000000046a0288 RDI: 00007fa8d107a010
Jul 09 23:19:49 alienware kernel: RBP: 00007fa8d107a010 R08: 000055e9fc0e1260 R09: 0000000000000000
Jul 09 23:19:49 alienware kernel: R10: 0000000000000005 R11: 0000000000000246 R12: 000055e9fc0e0b90
Jul 09 23:19:49 alienware kernel: R13: 000055e9fc0e11d0 R14: 0000000000000000 R15: 000055e9fc0e1670
Jul 09 23:19:49 alienware kernel:  </TASK>
Jul 09 23:19:49 alienware kernel: Modules linked in: pcc_cpufreq(-) acpi_cpufreq(-) tpm_crb(+) fjes(-) tpm_tis video tpm_tis_core intel_hid int3400_thermal sparse_keymap acpi_thermal_rel nvidia(POE+) acpi_tad acpi_pad vfat fat fuse crypto_user bpf_preload ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 hid_roccat_koneplus hid_roccat hid_roccat_common usbhid dm_crypt cbc encrypted_keys trusted asn1_encoder tee tpm rng_core dm_mod serio_raw atkbd crct10dif_pclmul libps2 crc32_pclmul crc32c_intel ghash_clmulni_intel vivaldi_fmap nvme aesni_intel crypto_simd xhci_pci cryptd nvme_core i8042 xhci_pci_renesas serio
Jul 09 23:19:49 alienware kernel: ---[ end trace 0000000000000000 ]---
Jul 09 23:19:49 alienware kernel: RIP: 0010:exc_control_protection+0xc2/0xd0
Jul 09 23:19:49 alienware kernel: Code: 8b 93 80 00 00 00 be fa 00 00 00 48 c7 c7 0d 16 49 8e e8 51 82 4a ff e9 72 ff ff ff 48 c7 c7 f4 15 49 8e e8 80 e3 fa ff 0f 0b <0f> 0b 66 66 2e 0f 1f 84 00 00 00 00 00 90 66 0f 1f 00 55 53 48 89
Jul 09 23:19:49 alienware kernel: RSP: 0018:ffffb16cc0cc7b48 EFLAGS: 00010002
Jul 09 23:19:49 alienware kernel: RAX: 0000000000000033 RBX: ffffb16cc0cc7b68 RCX: 0000000000000027
Jul 09 23:19:49 alienware kernel: RDX: 0000000000000000 RSI: 0000000000000001 RDI: ffff9be6ef261660
Jul 09 23:19:49 alienware kernel: RBP: 0000000000000003 R08: 0000000000000000 R09: ffffb16cc0cc79e0
Jul 09 23:19:49 alienware kernel: R10: 0000000000000003 R11: ffff9be70f7ac3e8 R12: 0000000000000000
Jul 09 23:19:49 alienware kernel: R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
Jul 09 23:19:49 alienware kernel: FS:  00007fa8d70ff200(0000) GS:ffff9be6ef240000(0000) knlGS:0000000000000000
Jul 09 23:19:49 alienware kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 09 23:19:49 alienware kernel: CR2: 0000560106376000 CR3: 000000010b96a004 CR4: 0000000000f70ee0
Jul 09 23:19:49 alienware kernel: PKRU: 55555554
Jul 09 23:19:49 alienware kernel: wmi_bus wmi_bus-PNP0C14:00: WQ00 data block query control method not found
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:02: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: wmi_bus wmi_bus-PNP0C14:03: WQBC data block query control method not found
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:03: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:04: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:05: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:06: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:07: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:08: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware kernel: acpi PNP0C14:09: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first instance was on PNP0C14:01)
Jul 09 23:19:49 alienware systemd[1]: systemd-modules-load.service: Main process exited, code=killed, status=11/SEGV
Jul 09 23:19:49 alienware systemd[1]: systemd-modules-load.service: Failed with result 'signal'.
Jul 09 23:19:49 alienware systemd[1]: Failed to start Load Kernel Modules.
Jul 09 23:19:49 alienware kernel: resource sanity check: requesting [mem 0xfedc0000-0xfedcffff], which spans more than pnp 00:05 [mem 0xfedc0000-0xfedc7fff]
Jul 09 23:19:49 alienware kernel: caller igen6_probe+0x19d/0x7d0 [igen6_edac] mapping multiple BARs
Jul 09 23:19:50 alienware kernel: iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-72.ucode failed with error -2
Jul 09 23:19:50 alienware kernel: iwlwifi 0000:00:14.3: api flags index 2 larger than supported by driver
Jul 09 23:19:50 alienware kernel: thermal thermal_zone9: failed to read out thermal zone (-61)
Jul 09 23:19:50 alienware kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS returned 0 bytes
Jul 09 23:19:52 alienware kernel: Bluetooth: hci0: Malformed MSFT vendor event: 0x02
Jul 09 23:19:52 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 24000
Jul 09 23:19:52 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 32000
Jul 09 23:19:52 alienware kernel: usb 4-1.3: current rate 16000 is different from the runtime rate 48000
Jul 09 23:19:54 alienware kernel: dell_smbios: Unable to run on non-Dell system
Jul 09 23:19:54 alienware kernel: dell_wmi_sysman: Unable to run on non-Dell system
Jul 09 23:19:54 alienware kernel: dell_smbios: Unable to run on non-Dell system
Jul 09 23:19:54 alienware kernel: dell_wmi_sysman: Unable to run on non-Dell system
Jul 09 23:19:54 alienware kernel: kauditd_printk_skb: 22 callbacks suppressed
Jul 09 23:19:54 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: Parent card not yet available, widget card binding deferred
Jul 09 23:19:55 alienware kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: sink widget AIF1TX overwritten
Jul 09 23:19:55 alienware kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: source widget AIF1RX overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget hifi3 overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget hifi2 overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget hifi1 overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: source widget Codec Output Pin1 overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget Codec Input Pin1 overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget Analog Codec Playback overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget Digital Codec Playback overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: sink widget Alt Analog Codec Playback overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: source widget Analog Codec Capture overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: source widget Digital Codec Capture overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: ASoC: source widget Alt Analog Codec Capture overwritten
Jul 09 23:19:55 alienware kernel: skl_hda_dsp_generic skl_hda_dsp_generic: hda_dsp_hdmi_build_controls: no PCM in topology for HDMI converter 3

there are some failed load kernel modules, something about nvidia …
but it did get stuck at something related to audio:

skl_hda_dsp_generic skl_hda_dsp_generic: hda_dsp_hdmi_build_controls: no PCM in topology for HDMI converter 3

do you have installed sof-firmware?
sudo pacman -S sof-firmware
reboot

yes. sof-firmware-2.1.1.a-1 is installed

well it really could be because of that, that your pc is new, so its not properly supported…
so also keep an eye on your network, if the parameter helped with it …

Yes, that may be the case.
Although, i have version 2.1.1 installed but there is version 2.2 available. Do you think i should manually install that version?

just checked and on stable the latest is 2.1.1 … so rather wait for the next stable system update

1 Like