Manjaro Cinnamon Bug: Reposting-Firefox web fields are black with sometimes black text with Adapta-Nokto-Eta-Maia theme

cinnamon

#1

Hi, I posted this before, but it got no real traction.

I recently reinstalled Manjaro on 2 different computers the default theme (Adapta-Nokto-Eta-Maia) for Manjaro on Firefox is broken.

Fields are black, and have difficult to read or otherwise have black text in the field.

Google Docs new doc

Google Docs when you click on the field to change text (it’s all black)

Not just Google Docs

Alliant Credit Union

Hacker News

This is a real issue for me as I literally can not read the fields on Manjaro Cinnamon. Since other themes are unsupported I want to try to get the bug fixed in the default install.

As far as I know, almost all non-stylized fields have this issue. Not an issue on Mint.

Steps to reproduce:

  1. Install Manjaro Cinnamon
  2. Use firefox to go to one of the above sites.

Edit: this issue has been in Manjaro before the 4.0 release (at least with Hacker News).


#2

A second bug is the “slideshow control” if selected does not show an icon on the panel just a space.
this space does however work with the exception of being able to click the icon which of course is not there.


#3

Would you post a pic?


#4

Screenshot%20from%202018-12-03%2021-41-44
See the gap between the printer icon and the removable drive icon.

Screenshot%20from%202018-12-03%2022-03-39

@oberon


#5

If you want to use Adapta, uninstall the one from the repo as it has not been updated (and probably won’t be anytime soon) for Cinnamon 4 and install the one from Settings > Themes.

A nice alternative theme is Matcha, available in the repos.


#6

Regarding the Firefox issue, it’s a reported Firefox bug which affects dark themes in general (Adapta, Vertex, Matcha are some of them) and it’s not Cinnamon specific.

The bug report in Bugzilla:

There is a partial fix mentioned in the report:

I just tested the fix in Xfce using the Adapta-Nokto-Eta-Maia and the Matcha-dark-sea themes and it works on all mentioned websites (after restarting Firefox).


#7

@Yochanan, this is the default theme for Manjaro Cinnamon with the default browser. It needs to be updated. Asking users to change themes because every form is broken by default seems like a bad idea to me.


#8

Adapta was dropped by it’s developer. It is currently not being developed, hence not supported. Manjaro will not be forking it and maintaining it. Bad idea, good idea, does not matter, simply pick a new theme or expect issues.


#9

@bill_t Thankyou, that fixed it.

For absolutely new users do this:

  1. Goto about:config in firefox
  2. Click past the scary warning
  3. Menu click on some white space->New->String
  4. For the title paste in “widget.content.gtk-theme-override”
  5. For the value (the next dialog) paste in “Adwaita:light”
  6. Restart FF

#10

Once again, this is the default theme for Manjaro Cinnamon. If Adapta-Nokto-Eta-Maia is not going to be maintained then it needs to be changed as the default theme.


#11

It will be changed once another one (probably Matcha or Plane) is ready. If you’re impatient, help with development.


#12

@Yochanan How do I help with development?


#13

Adapta and Adapta Nokto are maintained on Cinnanon Spices.
Just give it a try


#14

If you wish to fix the slideshow control icon problem before mint updates it…
navigate to “/usr/share/cinnamon/applets/slideshow@cinnamon.org” and open “applet.js” as root.
Remove all instances of “-symbolic.svg” from the file all 11 instances and save the file. I found a reboot was needed before this worked.

refers
The commit above has now been merged.

and is out in testing and it now works