Manjaro-Cinnamon 18.0.3 ISOs available

community-edition
cinnamon

#1

Fresh installation media for the Cinnamon edition are now availble!

DLOSDN

full edition:
direct | sig | sha1 | sha256 | torrent
minimal-edition:
direct | sig | sha1 | sha256 | torrent


Manjaro-Cinnamon 18.0 released
#2

Berry nais indeed


#3

Thanks for the new ISO. Appreciated, my installation medium was due for a refresh (still on something like 17.1.11 I think lol).


#4

architect may have worked but yeah that’s stale


#5

I do not use Architect personally, Calamares fulfill my needs completely. I don’t mind installing a couple of updates after installation, but my medium started to be really old.


#6

When will this get updated on the main download page? I’ve noticed it still has 18.0 listed.


#7

Good point! I have let Philip know that this needs to be updated. Thanks for letting us know!


#8

@oberon I think you should consider switching from Blueberry to Blueman as a front-end for connecting Bluetooth devices. I know Blueberry is the one shipped in Linux Mint by default, but I don’t think it work as well as Blueman.

On my side, I had trouble to transfer files from my smartphone to my laptop with Bluetooth with Blueberry, even with “Receive files from remote devices” enabled in Blueberry. I could only get the job done with Blueman, with the right option (Local Services > Transfer > “Accept files from trusted devices”) enabled of course.

Also, Blueberry use the CPU way more than Blueman, most likely because it perpetually scans for Bluetooth devices. See screenshots for comparison. When using Blueberry, I literally have over 20% of CPU usage on “3 cores” (in reality, the processor in my laptop is a dual-core processor with Hyper-Threading, that’s why you see 4 cores in system monitor). When using Blueman, I generally have less than 10% CPU usage on each core (or nearly). The difference is significant, especially for laptops, on which power usage is an important factor.

Blueberry

Blueman

I reported the file transfer issue to upstream. There is also one other issue opened around 9 months ago for a similar issue.

Mine: https://github.com/linuxmint/blueberry/issues/76
Other: https://github.com/linuxmint/blueberry/issues/65

It is also documented in Arch Wiki that Blueberry doesn’t support file transfer from outside to computer.

  • Blueberry — Linux Mint’s spin-off of GNOME Bluetooth, which works in all desktop environments. Blueberry does not support receiving files through Obex Object Push.

https://github.com/linuxmint/blueberry || blueberry

The issue about high CPU usage also got reported 1 year ago.

Also some different bad experiences from other users that replaced Blueberry for Blueman.

I think that for us, it will be way simpler to move on Blueman than waiting for upstream to fix Blueberry.

Fortunately, Blueberry is not deeply tied to Cinnamon, so the replacement is pretty simple to do. On my side, I only had to uninstall Blueberry and install Blueman (and I prefer to restart the computer after installing Blueman just to get a fresh new start, but maybe it is not necessary) to get Blueman working. That’s it, not more complicated than that.

So in the ISO profile, you could just replace >extra blueberry by >extra blueman and you should be good to go.

Obviously, you will lose the Bluetooth entry in the Control Centre because you won’t have Blueberry anymore, but it is not a big problem. If you want to have Bluetooth in Control Centre, you can just modify this patch to add an entry for Blueman in Hardware. (At that point, you could also add an entry for Qt5ct and an entry for Kvantum in Appearance, and perhaps keep the entry for Users and Groups, but it is not the main focus of my post.)

If you add an entry for Blueman in the Control Centre, perhaps an optional dependency for blueman could be added in the PKGBUILD of cinnamon.

Thanks for reading my suggestion.


#9

Actually this new update caused my machine to freezedead a few times, definitely much more resources running in the back.


#10

@oberon I’m back. I know the Deepin ISO is giving you a lot of work recently, but I had something to report again.

I noticed that you tried to implement a “bulk renaming” function in Nemo with nemo-bulk-rename package. Unfortunately, it doesn’t really work that well: if you try to use bulk renaming with files that contain spaces (which is a very frequent case), GPRename will crash. I don’t know if it has ever worked in the past.

Check this video to see the crash in action: https://www.youtube.com/watch?v=dBK4r1IMQiQ

It works fine if you only select files with no space in it.

Considering that GPRename is barely maintained nowadays by upstream (last update was in 2019, but the one before was in 2016, and the other one before was in 2014), perhaps you could consider simply dropping nemo-bulk-share package completely. By default, there isn’t any “bulk renaming” function in the file manager of Cinnamon, and nothing is implemented in Linux Mint Cinnamon too. I think it would be better to just stick with the default on that aspect. On paper, it seemed like a cool idea, but if it can’t even handle files with spaces in it, I’m afraid it is simply not good enough to be kept. The lacks of “bulk renaming” will be better than having a function that crashes in something that isn’t even a corner case scenario at all, and with little to no hope to have a fix for GPRename from upstream.

At first glance, GPRename seems to work in itself (if you launch it from the menu), so I guess you can keep GPRename if you absolutely want to have it on the ISO. But I suggest to simply remove nemo-bulk-renamefrom the ISO, and even remove it from the official repositories completely, and just stick with the default behavior on Nemo.

Thanks in advance.


#11

I just built some Cinnamon 18.0.4 ISOs. Everything looking quite good sofar, just, I am not convinced that blueberry is any better …

$ blueberry
[manjaro@manjaro-cinnamon ~]$ rfkill: cannot open /dev/rfkill: No such file or directory
rfkill: cannot read /dev/rfkill: Bad file descriptor
Traceback (most recent call last):
  File "/usr/lib/blueberry/blueberry.py", line 39, in on_activate
    self.create_window()
  File "/usr/lib/blueberry/blueberry.py", line 120, in create_window
    self.rfkill = rfkillMagic.Interface(self.update_ui_callback, debug)
  File "/usr/lib/blueberry/rfkillMagic.py", line 28, in __init__
    self.have_adapter = self.adapter_check()
  File "/usr/lib/blueberry/rfkillMagic.py", line 34, in adapter_check
    res = subprocess.check_output(RFKILL_CHK).decode('utf-8')
  File "/usr/lib/python3.7/subprocess.py", line 395, in check_output
    **kwargs).stdout
  File "/usr/lib/python3.7/subprocess.py", line 487, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['/usr/sbin/rfkill', 'list', 'bluetooth']' returned non-zero exit status 1.

#12

Maybe this is a wrong place but I still will ask you. There is the bug that rarely reproducible. Sometimes in “Show all windows” mode one of the windows is offset
Any ideas why?


#13

Hm. I’m not aware of this issue. Actually I never use that function :wink:
Did you try researching the linuxmint github for an issue about that?


#14

Ok. So this rfkill error is only an issue in vbox, not on hardware - which kind of makes sense …
I guess I can for now leave it like that.
In any case error handling in blueberry seems to be less than ideal :wink:


#15

I don’t understand. Didn’t you make the switch to blueman?


#17

Yeah. I got confused.
I was using a different machine here to build the profile where I forgot to pull the latest git version of the profile :wink: sorry …


#18

Alright, @Frog I am right now building another - hopefully last - test-ISO including an updated version of cinnamon with the modified settings page :slight_smile:

Right now this is on unstable branch only but I will forward everything needed when tested.
I have now also replaced yaourt with yay and isousb with etcher in the full edition.
Thank you for all your testing!


#19

One small issue: the icon for Kvantum Manager and Qt5 Settings is not correct.
cs-brokenicon
I could fix the issue by changing "cs-preferences-desktop-theme"and "cs-kvantum" for "preferences-desktop-theme"and "kvantum" in cinnamon-settings.py. I get this instead.
cs-okayicon

Outside of that, it is fine on my side. The new entries work correctly (as if I click on them, it opens the right window).


Manjaro-Cinnamon 18.0.4 released
#20

Ok. I’ll just include that in a package update …