Manjaro-Cinnamon 16.08

community-edition
cinnamon
16.08
#1

Manjaro Cinnamon 16.08 ISOs are now available from
https://sourceforge.net/projects/manjarolinux-community/files/16.08/cinnamon/

highlights:

  • Kernel Linux 4.4.19
  • Cinnamon 3.0.7
  • Nemo 3.0.6
  • Firefox 48.0.2
  • Thunderbird 45.2.1
  • Libreoffice-still 5.1.5
  • Gimp 2.8.18
  • Pragha music player
  • VLC media player
  • Manjaro Printer
  • Hexchat
  • Pidgin Instant Messenger
  • gtk- and Cinnamon-themes Vertex Maia, Vertex-Maia-Dark and Vertex Maia Square

utilities:

  • Manjaro Welcome
  • Manjaro User Guide
  • Installers Calamares and CLI
  • Manjaro Settings Manager
  • Mugshot
  • Pamac
  • Yaourt
  • Isousb
  • Gparted
  • Baobab Disk usage analyzer
14 Likes
#2

Sorry to say just installed this and entered qt5ct in a terminal and got the error meesage “Please remove the QT_STYLE_OVERRIDE environment variable” seems to be confined to cinnamon as other flavours don’t do this.

#3

@robinw0800 do you also get this window

#4

Is this in the live session or the target install? I had in fact checked exactly that before I uploaded the ISOs. Strange. I’ll look into that again. grrr Thanks for lettings me know anyway.

#5

Yes and I also noted on those that work in ~/.config/qt5ct are two folders “colors” and “qss” that are missing in cinnamon

#6

What do you mean with “those that work”?

#7

xfce & mate

#8

With Calamares or with the CLI installer?

#9

calamares on a uefi system and seperate home

#10

Right, it appears to be a few different topics here:

  • In the live something seems to have gone wrong with the live script and QT_QPA_PLATFORMTHEME was not set as it should have been, BUT theming of manjaro-settings-manager is following gtk theme fine! So there’s actually no reason why you’d need to use qt5ct at all :wink: is there?

  • In the target install calamares should configure QT_QPA_PLATFORMTHEME for you, and in my tests it did!

  • What apparently is currently a bug, is that Cinnamon session automatically exports QT_STYLE_OVERRIDE=gtk We can’t do much about this, but again: In the live session theming works fine for me and it also did in my test installs.

Multiple cinnamon-session Updates
#11

Well no! In the live session I have this:

[manjaro@manjaro-cinnamon ~]$ cat /etc/environment 
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
QT_QPA_PLATFORMTHEME=qt5ct
LANG=en_US.UTF-8
[manjaro@manjaro-cinnamon ~]$ echo $QT_QPA_PLATFORMTHEME
qt5ct
[manjaro@manjaro-cinnamon ~]$ echo $QT_STYLE_OVERRIDE
gtk

and qt-theming is working fine.
The QT_STYLE_OVERRIDE as I said apparently is exported by Cinnamon session directly.
Will check Calamares next…

#12

We need to create a patch and fix it until upstream does it. When I find time I might look into the code of cinnamon-session.

#13

Actually I don’t really think it is necessary!
Here’s a screenshot of an install I just did with Calamares in vbox:

So QT_STYLE_OVERRIDE=gtkis set, yes. But it doesn’t seem to hurt! As you can see msm is following the theme when I set it to dark. No problem there.
Well qt5ct refuses to start, but why do we need it to run as long as gtk2 is set in .config/qt5ct/qt5ct.conf
The user has no reason to change it I think…

#14

In fact to patch it won’t be a big deal:

I’ll just create an overlay package then without the variable set and we can go back to upstream once they have fixed it.

#15

Please check if the new cinnamon-session fixes the issue now …

sudo pacman -U http://repo.manjaro.org.uk/pool/overlay/cinnamon-session-3.0.1-1.4-x86_64.pkg.tar.xz
#16

I have installed new cinnamon-session, but I’m still getting:

Please remove the QT_STYLE_OVERRIDE environment variable

when trying to start qt5ct.

#17

Yes. That’s because cinnamon-session exports QT_STYLE_OVERRIDE by itself.
We are currently busy fixing it there.
But in any case: Why do you need to start qt5ct at all since gtk2 theming is being used successfully, I wonder? :wink:

#18

Just to be in line with Manjaro guidance as if I understood correctly, once cinnamon-session is patched, we still will need to make use of qt5-styleplugins and qt5ct. Is that correct?

#19

I take it that cinnamon-session-3.0.1-1.4 can’t fix the problem “QT_STYLE_OVERRIDE=gtk2” if the problem is already there it will only work if the problem is not there in the first place.

#20

I think you do need qt5ct if for no other reason to set the fonts the icon theme and the interface if you run manjaro notifier settings it is twice the height it should be. as it has not been set up.