Manjaro-chroot -a pacman error file too short

After a botched update on 4/3 I’m trying to recover with a live boot into manjaro-chroot -a but after doing pacman -Syy I get:

pacman: error while loading shared libraries: /usr/lib/ file too short

Any help for a solution is greatly appreciated. TIA

Never happened to me, but have you tried reinstalling libgpg-error as it looks corrupted ? Also what is the purpose of doing only pacman -Syy?

I’m trying to finish the aborted update which caused a non bootable system. I also got a shared libraries error when attempting reboot… libcrypto… file to short too so it’s not just libgpg-error that I messed up…

… can I finish the update from fallback boot mode without chroot?
… Looks like not… one kernel boot reports no kernel found and other kernels panic with shared libraries error libcrypto error.

Try to do this :

sudo pacman-mirrors -f 5 
sudo pacman -Syyu

can’t run pacman without shared libraries errors… usually file too short

try to update with
pacman-static -Syyu

still get:

/usr/lib/ file too short…