Manjaro can't get past GRUB menu

Hi I am new to linux and I had watched a video on how to stop the screen tearing I have been getting even with drivers installed and it directed me to edit my graphics driver slightly I then restarted and it worked perfectly for a month now after an update I get to the grub menu I select Manjaro Linux and I get the same four errors that I have gotten since installation saying No IRQ handler for vector. Then it goes to a black screen and won’t move past that I have tried to get into the command line by pressing F3, F4, F5, and F6 but it doesn’t change from the black screen. Any suggestions?

Hi and welcome!

Some Questions:

What Video? What did you change?

What was updated? What is the full error?

Do you mean this error?
do_IRQ: 6.99 No irq handler for vector (irq -1)

The F[number] key does nothing. You need to press

CTRL + ALT + F1/F2/F3

If you can enter another TTY, then it is probably fixable without a manjaro boot disk.

Thank you :slight_smile:

1 Like

Question One:
The name of the video I watched is “How to Fix AMD GPU Radeon Screen Tearing in Debian, Linux Mint and Ubuntu” by neon cipher and it worked until after I updated recently the video said I modified the x org configuration.
Question Two:
Sorry I didn’t word this part clearly I did a full system update recently and after I rebooted my computer to apply the update I as usual was greeted with the grub menu and selected manjaro linux to boot the os. That is one of the errors that show up the other three are the same except instead of 6.99 I believe one of them is 7.11.
Question 3:
I did press control alt F3 I just didn’t see the need to put that in my post sorry… I can’t enter another TTY I saw another post on here and tried to boot without x and nothing happened. I also saw something on that post about chrooting but I’m not sure what that is.

ok i understand.

Chrooting means “change to another root”. If you are on a Manjaro live disk, then you can open terminal and type manjaro-chroot -a and the script does the rest for you. Now you are on the local root and not the live root.

By explaining this, i would recommend to do this. At least to have more information.

In that chrooted terminal run this:

journalctl -b -0 > ~/journal.txt && cat ~/journal.txt

That displays the log of the current boot of you local root.

Copy that please and paste it here as code with ``` at the first line and the last line.

Thank you :wink:

1 Like

Ok so I ran manjaro-chroot -a and I got

grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda1]
 --> mount: [/mnt]

Then ran the journalctl -b -0 > ~/journal.txt && cat ~/journal.txt command and I got
``` – Logs begin at Tue 2020-04-21 18:42:54 EDT, end at Thu 2020-09-10 21:58:03 EDT. –

– No entries --```

After I ran those commands I tried to fire up manjaro on my local root and I got past the GRUB menu not sure exactly what fixed it but it works now.