Manjaro canot see btrfs boot partition

here are osprober results

   ~  sudo update-grub                                                                                        1 ✘ 
Stvaranje grub datoteke podešavanja ...
Pronađena tema: /usr/share/grub/themes/manjaro/theme.txt
Pronađena linux slika: /boot/vmlinuz-6.5-x86_64
Pronađena initrd slika: /boot/intel-ucode.img /boot/initramfs-6.5-x86_64.img
Found initrd fallback image: /boot/initramfs-6.5-x86_64-fallback.img
Pronađena linux slika: /boot/vmlinuz-6.4-x86_64
Pronađena initrd slika: /boot/intel-ucode.img /boot/initramfs-6.4-x86_64.img
Found initrd fallback image: /boot/initramfs-6.4-x86_64-fallback.img
Pronađena linux slika: /boot/vmlinuz-6.1-x86_64
Pronađena initrd slika: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Pronađena linux slika: /boot/vmlinuz-5.15-x86_64
Pronađena initrd slika: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Upozorenje: os-prober će pokrenuti otkrivanje drugih particija s operativnim sustavima.
Njegovi izlazni podaci će se koristiti za otkrivanje pokretljivih binarnih datoteka na particijama i stvaranje novih stavki pokretanja.
Pronađen MX 21.3 Wildflower (21.3) na /dev/sda3
Pronađen BunsenLabs GNU/Linux 10.5 (Lithium) na /dev/sda5
Pronađen MakuluLinux ShiFt 2022.12.29 (2022.12.29) na /dev/sda7
Pronađen Kali GNU/Linux Rolling na /dev/sdc2
Dodavanje stavke pokretanja za UEFI firmver postavke ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
---- gparted can see sda1 partiton flaged as boot (garuda.lxqt) (btrfs) (/run/media/wizac0/587fc138-efcd-4ffe-aadb-1db7e4be0387) 

before i was booting through garuda ,it was ok (garudas grub was seeing all oses) but while today updating mx somethinf goes wrong.
how can i fix this problem i m asking here becouse manjaro (on sdc1) is my main and daily driver .

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Please post the content of /etc/fstab:

cat /etc/fstab

I suspect the filesystem isn’t identified correctly. If true, someone should notice it in your fstab content. Cheers.

here is, thanx

 cat /etc/fstab                                                                                            ✔ 
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=0d364986-ebc2-409b-9f11-23bae7ccfe1f /              ext4    defaults,noatime 0 1
/swapfile                                 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
 lsblk -f                                                                                                  ✔ 
NAME   FSTYPE FSVER LABEL          UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1 btrfs        garuda.lxqt    587fc138-efcd-4ffe-aadb-1db7e4be0387                
├─sda3 ext4   1.0   rootMX21       75759398-dec3-4001-9181-5bf60724fd54                
├─sda5 ext4   1.0   bunsen lab     cc4b164a-d1f3-4f17-80f2-f0c858ab7a60                
├─sda6 swap   1                    e96158c6-6e94-45cf-8754-202c5bfdda60                
└─sda7 ext4   1.0   malkulul.shift ce56d1b3-19ee-46e1-be2b-dd5822104ad1                
└─sdb1 ntfs         wd1.0t         22247B9355483134                                    
├─sdc1 ext4   1.0   manjaro        0d364986-ebc2-409b-9f11-23bae7ccfe1f   54,7G    58% /
└─sdc2 ext4   1.0   kalit0         e9c734e2-7482-420f-a7f4-7b27465f152c

sda is hdd , sdc is sdd

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Also the output of sudo blkid.

   ~   sudo blkid                                                                                               ✔ 
[sudo] lozinka za wizac0: 
m/dev/sdb1: LABEL="wd1.0t" BLOCK_SIZE="512" UUID="22247B9355483134" TYPE="ntfs" PARTUUID="69a03ea1-01"
/dev/sdc2: LABEL="kalit0" UUID="e9c734e2-7482-420f-a7f4-7b27465f152c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="652dc307-02"
/dev/sdc1: LABEL="manjaro" UUID="0d364986-ebc2-409b-9f11-23bae7ccfe1f" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="652dc307-01"
/dev/sda7: LABEL="malkulul.shift" UUID="ce56d1b3-19ee-46e1-be2b-dd5822104ad1" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="f77f4034-07"
/dev/sda5: LABEL="bunsen lab" UUID="cc4b164a-d1f3-4f17-80f2-f0c858ab7a60" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="f77f4034-05"
/dev/sda3: LABEL="rootMX21" UUID="75759398-dec3-4001-9181-5bf60724fd54" BLOCK_SIZE="4096" TYPE="ext4" PTTYPE="dos" PARTUUID="f77f4034-03"
/dev/sda1: LABEL="garuda.lxqt" UUID="587fc138-efcd-4ffe-aadb-1db7e4be0387" UUID_SUB="21328699-f522-4634-90e1-b68420ac234b" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="f77f4034-01"
/dev/sda6: UUID="e96158c6-6e94-45cf-8754-202c5bfdda60" TYPE="swap" PARTUUID="f77f4034-06"

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

One suggestion is to continue using 'Garuda’s Grub as your main boot loader if it was working before. Enter your BIOS and find the ‘Boot’ section; set the Garuda disk first in boot order, and reboot.

However, there seems too much complication with the amount of systems you have on sda. I strongly recommend that you only have one OS per disk. As it stands, I’m unable to help much beyond this point.

You might consider reinstalling Manjaro; but first, disconnect disks sda and sdb so that they will not interfere with the process. The key is setting each OS up independently from the others (by removing the other disks before installing). When you know each OS boots without issue, then connect them all again, and choose which one to boot first via the BIOS. I hope this makes sense.

I’ve done it for you this time. :wink:

that s the problem,
i got 2 boot sets manjaro sdc1 grub and sda1 garuda grub and was using that bios sett cause manjaro grub was blind about garuda. updating mx owerwrited garuda grub so i cant enter it. now same is on sda and sdc disks - blind for btrfs os. bios settings cannot help.
even tried with rescatux usb grub&grub2 restore (that was succesfull when kali update-sdc2 overwrite manjaro grub) but it cannot see btrfs os.

thanx Yochanan, think i tried with quote button, i see it was need for "</>" button

OK, then try reinstalling Grub on the Manjaro disk – BUT-- disconnect the other two disks first. When the Manjaro disk is booting properly (with the other disks mot connected) edit /boot/grub/grub.cfg – and uncomment #GRUB_DISABLE_OS_PROBER=false.

Then, shutdown and connect the other disks again – Boot into BIOS – Set the Manjaro Grub as first in boot order. Reboot again.

m not shure i ll know that but how it ll catch infos about disconented disks. anyway nano- /boot/grub/grub.cfg gives 852 lines without any line about btrfs os

Uncomment #GRUB_DISABLE_OS_PROBER=false.

That’s all you need to so in those 852 lines. Uncommenting that line enables Grub to autodetect other operating systems during boot.

Disconnect the other drives first only if you will reinstall Manjaro. OK?

wouldnot such config. boot only manjaro?
i got no problems with boot into manjaro (nor the debians)

Uncommenting #GRUB_DISABLE_OS_PROBER=false in /boot/grub/grub.cfg should allow Grub to detect other OS. If your Garuda drive also has an EFI System Partition (ESP), and correctly functioning boot files, then it will also be detected.

BTRFS is irrelevent: /boot/efi is only a symbolic link to the ESP; the full path for example would become: /boot/efi/EFI/garuda or something similar.

To INSTALL any OS, do it without the other drives connected; connect them again after installation. This is the safest when multibooting.

Uklanjanje komentara iz #GRUB_DISABLE_OS_PROBER=false u /boot/grub/grub.cfg trebalo bi omogućiti Grubu da detektuje druge operativne sisteme. Ako vaš Garuda drajv takođe ima EFI sistemsku particiju (ESP) i ispravne datoteke za pokretanje, tada će i on biti detektovan.

BTRFS nije bitan: /boot/efi je samo simbolička veza ka ESP; puna putanja, na primer, postala bi: /boot/efi/EFI/garuda ili nešto slično.

Da biste INSTALIRALI bilo koji operativni sistem, to uradite bez povezanih drugih drajvova; ponovo ih povežite nakon instalacije. Ovo je najsigurnije prilikom višestrukog podizanja sistema.

I would install your Linux distro without btrfs boot partition.

OP claims (or, seems to) that Garuda is already working; this assumes the ESP is fine; the ESP shouldn’t work at all if formatted as BTRFS. This assumes it’s booting as UEFI. I see no evidence to the contrary.

there is no such line.
i think it can `t be uefi install cause pc is an old bios legacy engine.
btw. i try again with rescatux grub fix and it is reading sda1 partition as “windows or other” and when forced ,it can not restore grub of it

Thank you for explaining. I can no longer assist.

Maybe someone with deeper insight, and/or experience with booting multiple operating systems using Legacy Grub can assist further.

Good luck.

1 Like

tanx much, i ll try insall garuda.230501.iso over curent 221019 that was many times updated

1 Like

Then Grub was overwritten by MX Linux, when updating MX.