Manjaro Budgie Thinkpad T420 on dock, displays not working

budgie

#1

Manjaro Budgie used to work flawlessly on my Thinkpad Dock, two external monitors worked without a hitch. However within the last several months or more, my dock’s displays stopped working. I’m using DVI-D cables for both. I tried working around it with Arch documentation to use dockd. But dockd isn’t doing anything helpful.

Ubuntu Budgie works flawlessly, but I don’t want to abandon the Manjaro ecosystem just yet.

Please, HELP?!


#2

And you are confident that the connection between dock and laptop is clean and connections are as tight as they should be?


#3

Yes. Ubuntu Budgie works just fine with the dock, after all.


#4

I have had a T420 on dock with which I had no problems - the difference though was that I used the DisplayPorts on the dock.

The system monitor setup has been working - so what have changed?

If you boot a live Manjaro Budgie ISO - what happens?

Does it work or does it not.

Let us the result of the live ISO boot.

If it does you need to compare the configuration of live with your running system.

Is it a periodic issue - I mean you have waited several months before reporting and what have you tried besides the dockd package?

It would also be valuable if you could peek the config of Ubuntu Budgie and compare the config to your running system.


Another thought is - Ubuntu is not known for being up-to-date - package wise as it is a fixed release.

This leads to thinking that Ubuntu Budgie packages lags behind Manjaro and maybe an issue exist with later Budgie packages which has not yet reached Ubuntu but Manjaro.

As I don’t know much about Budgie I have to ask if the Ubuntu Budgie version the official Solus version or it is an Ubuntu offspring.
EDIT: I found according to Wikipedia that Ubuntu Budgie is an official Ubuntu flavor.


On wikipedia it states that version 11 of budgie will be rewritten in Qt and start using Wayland.

I have no idea of where Manjaro Budgie is in this regard. Is it v10.x?

In that case it might be an idea to test Manjaro Gnome - as it seems to be close to Budgie. But I see that @muvvenby already suggest something similar.


My Thinkpad - as I recall had no Nvidia card - just Intel.

Could you please post your inxi -CGMAxx preferably when attached to dock.


#5

Yeah, I already tested the Live ISO. It doesn’t work either. I was planning on evaluating another Manjaro desktop, but the Manjaro Budgie Live CD has the same problem.

There is one Manjaro Thinkpad dock thread related to nvidia driver choice. Considering I didn’t mess around with drivers before I didn’t think it would matter, and I tried selecting a different driver but nothing seemed to matter.

That is a good idea though, I’ll have to find a tool to do a diff from Ubuntu Budgie live cd to installed Manjaro Budgie.


#6

Can you test your setup with Manjaro XFCE, Gnome or KDE live ISO? That will give us a clue if it is Manjaro related or maybe just Budgie related.


#7

Manjaro Budgie - No external displays detected in Settings - Devices.
Manjaro Mate - Detected in Displays. After enabled there’s a black screen, mouse draws, but nothing else.
Manjaro Cinnamon - External monitor was enabled, but same problem as Mate, black with nothing drawing except mouse. When toggled, showed some graphical corruption but mouse drew fine.
Manjaro Deepin - Same issues as Mate.
Manjaro Gnome - Flawless
Manjaro KDE - Flawless
Manjaro LXDE - Worked well, had some issues with background refresh/redraw.
Manjaro LXQT - Worked well, better than LXDE.
Manjaro XFCE - Surprisingly well.

Manjaro Budgie seems to be the only one that can’t detect Thinkpad dock displays at all. I’ll do a diff with Ubuntu Budgie, expect some details by the end of the week, but it may take longer than that; idk how long it’ll take for me to narrow anything down.


#8

You need to get info to try troubleshooting this.
Try your monitors one by one and post Xorg log (it must be at ~/.local/share/xorg/. )
Also system info

inxi -SMGxxxz
mhwd -li
pacman -Qs budgie
cat /etc/X11/xorg.conf.d/*.conf