MANJARO -Budgie - Problems with update from October 11

Hi there,
Running Manjaro Budgie for some time now, I was pleased to see that we finally got a HUGE update.
So I applied it... but found it causes some problems on my Budgie Manjaro :frowning:

The problems I have are following :

  • 1°) I use desktop-icons and to get those I have installed nautilus-legacy ; thus, Nautilus does not update... With GNOME 3.34 that is a problem as the GUI doesn't open folders to show files...
  • 2°) the desktop-icons are gone ; I have been able to enable those in GNOME, but whatever I do, Budgie doesn't show those ;
  • 3°) I use a lot of workspaces to keep things "separate". After applying the update, I can have only up to 8 workspaces ; that doesn't happen in GNOME, but in Budgie => if I try to add a new workspace, I end up with a frowning on a grey background saying that something has gone wrong and that I should log in again...
  • 4°) without changing anything, Lutris behaves not too cool in Diablo III, with the mouse cursor vanishing every 4 or 5 minutes.

Anyone else having those problems ?
Or are those known bugs ?
Any workaround to fix those problems ?

I can live without the upgrade, but would like to stay more or less up to date...

Thanks for your answers.

  1. Please share your system information. The information you provided is useless without it.
  2. Did you reboot after the update?
  3. How did you upgrade?

Hi,
I don't know what you mean by system info.
But if it is hardware related :

  • Motherboard : Asus Z10PE-D16-WS
  • CPU : 2 X Intel Xeon 14c/28t
  • 128GB RAM
  • System on NVMe drive
  • Home on another NVMe drive
  • Several SSD's and HDD's
  • AMD Radeon RX 580 GPU

As far as software goes :

  • Manjaro with all updates applied as of last september update
  • Not too many packages installed other than the "stock" ones (basically, networking and building)
  • DE is Budgie with all updates applied
  • kernel is 4.19 LTS and 5.2.21 (both have been tried).

The update has been applied in 2 different ways :

  • 1°) using pamac-manager
  • 2°) using pacman

I tried second methond ; as I got those bugs I reverted back to previous sytem state by restoring a Timeshift back-up and then reinstalling all current packages.
I then tried to upgrade unsing the first method and got the exact same results.

Any more info you need ? I'll be glad to try to provide...

I good starting point for info is
inxi -Fxxxza --no-host

That's not going to help.

How does it not help to provide more comprehensive system information ?

Forum kindly sponsored by