Manjaro boot loader lost after mb update

Hi. I’ve been dual booting Windows 10 with Manjaro, two different disks and partitions. Windows creates its small little boot partition and Manjaro a 300MB one, in gparted labelled “esp” and “boot”.
I selected either manjaro or Win10 bootloader in the mb boot order and choosing manjaro would initiate Grub (which also contained the win10 bootloader).

After the UEFI update of my Gigabyte B550i Aorus Pro the manjaro boot option vanished and the system booted into Windows. I reset the UEFI options to optimized defaults like when I received the mb and that didn’t make a difference.

I tried booting from a live manjaro disc and choosing “Detect efi bootloaders” or something akin to that in the boot menu I saw the manjaro system one and could boot into it without issue.

So I followed https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader …now does my system have a separate GRUB partition? Well, there’s the 300MB one labeled “boot”, and I was booting via GRUB, so …perhaps? I continued as if that was the case.

Further down I chose the “For UEFI systems” because the 300MB partition is labelled both “boot” and “esp”.

I had to load the efivars module. Things seemed to work but I forgot “sudo update grub” and when I rebooted into the new “manjaro” uefi option I got a GRUB prompt, “Minimal BASH-like…”

Then rebooted to the live disc again and used the “Alternative method” because it didn’t deal with the separate GRUB partition conundrum. It did things without reported errors, and then the wiki page said
“After the above you could chroot and try the update-grub command as earlier.”

Which I took to mean “start from the beginning” because update-grub via chroot into /install said that it couldn’t find / and that I may have forgotten /dev. No reported errors anyways and I updated grub this time around, then rebooted…and now if I choose the ‘manjaro’ option in the mb uefi I get a boot attempt and then the machine reboots. Same thing if I boot from the live cd and choose detect efi bootloaders and pick the manjaro grub one.

In essence I’m a bit of a newbie requesting assistance in getting my UEFI/Grub headache sorted and hopefully my Manjaro system back on track without having to reinstall and lose a bit of data.

I don’t really need the GRUB menu; if possible merely being able to choose the UEFI boot option in the motherboard uefi boot menu would be enough.

(I updated the BIOS from version F1 because that was the next step in a thread about vanishing WIFI after having been booted into Win10 with the Intel AX200 chipset)

Thanks for reading all of that.


Edit. Reading about esps and bootloaders here Dual boot with Windows - ArchWiki and in other places I’ve resigned to installing the OS:es correctly, picking the efi boot option among the mb boot options. Whether that is possible with two esps (on two disks) remains to be seen. Recommended? Not everywhere: solus-efi-guide/README.md at master · kyrios123/solus-efi-guide · GitHub

Up until now I had the Manjaro option booting to Grub which showed and could launch the Windows bootloader and at that point everything isn’t efi, it would seem.

Can’t learn algebra before you know what a possum is. I think I’m going to try and use one EFI partition, which means resizing the win one as it is measly. Probably reinstalling windows too. And hrrm, the WIFI has been available on every boot to the live manjaro disc since the mainboard update yesterday, no more iwlwifi: probe of 0000:06:00.0 failed with error -110. I hope that persists once I get up and dual booting again.

can you boot on USB iso manjaro
open an terminal

inxi -Fza 
sudo parted -l
sudo lsblk -fs
sudo efibootmgr -v
test -d /sys/firmware/efi && echo efi || echo bios
sudo manjaro-chroot -a ( type 1 if only one line 0 )
cat /etc/fstab
exit ( quit chroot )

Hi, thanks for your reply. Here goes:

inxi -Fza 
System:
  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=se tz=UTC 
  driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MANJARO_GNOME_201 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: B550I AORUS PRO AX v: x.x 
  serial: <filter> UEFI: American Megatrends v: F10 date: 09/18/2020 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86276 
  Speed: 2194 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2241 2: 2025 3: 2195 4: 2194 5: 2178 6: 2195 7: 2195 8: 2196 9: 2505 
  10: 1891 11: 2103 12: 2196 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: ASUSTeK 
  driver: nouveau v: kernel bus ID: 07:00.0 chip ID: 10de:1f08 
  Display: x11 server: X.org 1.20.8 compositor: gnome-shell 
  driver: modesetting,nouveau alternate: fbdev,nv,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.7 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 07:00.1 chip ID: 10de:10f9 
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 09:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: N/A 
  modules: r8169 port: f000 bus ID: 05:00.0 chip ID: 10ec:8125 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 
  bus ID: 06:00.0 chip ID: 8086:2723 
  IF: wlp6s0 state: down mac: <filter> 
  Device-3: ASIX AX88772B type: USB driver: asix bus ID: 1-3:3 
  chip ID: 0b95:772b serial: <filter> 
  IF: enp1s0f0u3 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.42 TiB used: 134.91 GiB (9.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 2B6Q scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD5000AACS-00G8B0 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 3.0 Gb/s serial: <filter> rev: 4C05 scheme: MBR 
  ID-3: /dev/sdc vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1B6Q scheme: GPT 
  ID-4: /dev/sdd type: USB vendor: Corsair model: Voyager GT 3.0 
  size: 59.65 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition:
  ID-1: / raw size: N/A size: 11.73 GiB used: 226.3 MiB (1.9%) fs: overlay 
  source: ERR-102 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 33.1 C mobo: N/A gpu: nouveau temp: 24 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 871 
Info:
  Processes: 323 Uptime: 10h 16m Memory: 15.64 GiB used: 2.69 GiB (17.2%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1192 lib: 301 
  flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05 
sudo parted -l
Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   482GB  481GB   ext4
 3      482GB   500GB  18.5GB  linux-swap(v1)        swap


Model: ATA WDC WD5000AACS-0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 2      1050MB  500GB  499GB  primary  ntfs         boot


Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sdc: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.8MB  16.8MB               Microsoft reserved partition  msftres
 2      17.8MB  157GB   157GB   ntfs         Basic data partition          msftdata


Model: Corsair Voyager GT 3.0 (scsi)
Disk /dev/sdd: 64.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2817MB  2821MB  4194kB  primary               esp

sudo lsblk -fs
NAME  FSTYPE   FSVER            LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0 squashfs 4.0                                                                           0   100% /run/miso/sfs/livefs
loop1 squashfs 4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2 squashfs 4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3 squashfs 4.0                                                                           0   100% /run/miso/sfs/rootfs
sda1  vfat     FAT32                              9445-403C                                           
└─sda                                                                                                 
sda2  ext4     1.0                                277b4f4a-63c1-4894-aa49-0b3e1bcf4465    330G    20% /run/media/manjaro/277b4f4a-63c1-4894-aa49-0b3e1bcf4465
└─sda                                                                                                 
sda3  swap     1                                  921cc5f2-32c0-4937-9d97-7e6281ea7b21                
└─sda                                                                                                 
sdb2  ntfs                      Triton            7B5BE9365A0317CF                                    
└─sdb                                                                                                 
sdc1                                                                                                  
└─sdc                                                                                                 
sdc2  ntfs                                        C60843BC0843AA6F                       99.6G    32% /run/media/manjaro/C60843BC0843AA6F
└─sdc                                                                                                 
sdd1  iso9660  Joliet Extension MANJARO_GNOME_201 2020-09-11-16-22-35-00                              
└─sdd iso9660  Joliet Extension MANJARO_GNOME_201 2020-09-11-16-22-35-00                     0   100% /run/miso/bootmnt
sdd2  vfat     FAT12            MISO_EFI          33A2-BD05                                           
└─sdd iso9660  Joliet Extension MANJARO_GNOME_201 2020-09-11-16-22-35-00                     0   100% /run/miso/bootmnt

sudo efibootmgr -v
BootCurrent: 0006
Timeout: 1 seconds
BootOrder: 0000,0001,0006,0007,0003,0004,0005,0008
Boot0000* Windows Boot Manager	HD(1,GPT,ba9bffe9-5150-0d45-968d-88202e272971,0x1000,0x96000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...t................
Boot0001* manjaro	HD(1,GPT,ba9bffe9-5150-0d45-968d-88202e272971,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0003* Samsung SSD 850 EVO 500GB	BBS(HD,,0x0)..BO
Boot0004* WDC WD5000AACS-00G8B0	BBS(HD,,0x0)..BO
Boot0005* Samsung SSD 850 EVO 500GB	BBS(HD,,0x0)..BO
Boot0006* UEFI: Corsair Voyager GT 3.0 1.00	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(3,0)/CDROM(1,0x53f214,0x8000)..BO
Boot0007* UEFI: Corsair Voyager GT 3.0 1.00, Partition 2	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(3,0)/HD(2,MBR,0x0,0x53f214,0x2000)..BO
Boot0008* Corsair Voyager GT 3.0 1.00	BBS(HD,,0x0)..BO

test -d /sys/firmware/efi && echo efi || echo bios
efi
sudo manjaro-chroot -a

grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
1
==> Mounting (ManjaroLinux) [/dev/sda2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]


# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9445-403C                            /boot/efi      vfat    umask=0077 0 2
UUID=277b4f4a-63c1-4894-aa49-0b3e1bcf4465 /              ext4    defaults,noatime 0 1
UUID=921cc5f2-32c0-4937-9d97-7e6281ea7b21 swap           swap    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

I think I’ve understood that even when Manjaro shares an ESP with Windows 10 (or another OS) and is installed on a GPT drive it will install GRUB in the EFI and reference the Win10 bootloader in the nice looking menu that will appear on boot. This in contrast with Solus that aims to let the selection be made in the mainboard EFI boot options (sans a Solus menu on boot).

after mb update

I understand this as you replaced your main board - am I correct?

If so - nothing disappeared - but as your new main board do not know anything of your previous installs - the partition info is written inside the firmware - it wouldn’t know where to look.

So what you need to do is to add the EFI loaders to the firmware.

Most firmware support adding an $esp from inside the firmware.

Hi, sorry for being unspecific. What I did was update the EFI, from F1 (release firmware) to F10.

https://www.gigabyte.com/Motherboard/B550I-AORUS-PRO-AX-rev-10/support#support-dl-bios

OK - but the result is the same - the new EFI loader don’t know anything - it is a blank slate.

Or you can boot a live ISO in EFI mode and add the partitions to the loader - from memory it’s something like

efibootmgr -c -d $device -p $partnum -l "\EFI\Manjaro\grubx64.efi" -L "Manjaro"

Well the Windows bootloader remains and functions. I’m not sure that I installed Manjaro via the EFI and loading the optimized defaults shows the legacy boot options too. What changed was that one entry in the mainboard boot menu disappeared after the firmware update, and I don’t think it was actually called “Manjaro”-something. Booting to the Live USB and selecting “Detect EFI bootloaders” finds the Manjaro one and prior to the troubleshooting could boot my Manjaro system, now it thinks for a bit and then reboots the machine, just like the “Manjaro” boot option (which appeared after the ts steps in the op)

Having the Legacy options enabled will be confusing - especially if installing using Calamares - Manjaro recommendation is to disable Legacy or CSM aka compatibility mode in the firmware.

Hi, yep, that’s done now. No CSM or fast or secure boot. I see only two options, “Windows bootloader” and “Manjaro” in the mainboard boot order. The “Manjaro” one was added by the first post’s troubleshooting and does not function (reboots the machine). Shall I try to add it as a second entry, with a slightly different name, as per your advice above?

Secure boot come to mind - but I really don’t know - never tried it - I mean the firmware update destroying the entries.

Another thing - a little far fetched I admit - have you checked the partition type UUID for your Manjaro $esp? It should be EF00 (FAT32 formatted) - or a text containing something like EFI System?

Hi.

Secure boot was off. “Partition type UUID”? UUID and type are listed above, as

UUID=9445-403C                            /boot/efi      vfat

not sure if that answered the question.

Anyways, in contrast to what I wrote in the OP the 300MB partition labelled “boot” and “esp” on the “Linux” disk actually housed the Windows bootloader too, as can be seen or indicated by the efibootmgr -v command output above. Windows 10 creates its extra partitions as needed and as the 300MB esp predates the latest Windows 10 install its installer must have detected the esp and put its bootloader there instead of creating a 100MB efi partition (because there was and is no such).

I reinstalled Manjaro now with the 300MB esp mounted as /boot/efi and now the “Manjaro” f12 EFI option launches grub, where the Windows bootloader has an entry, just as before the mainboard firmware update. (I’m not sure why the Grub menu looks retro and not like most screenshots with the flashy manjaro graphics but it doesn’t make a functional difference. Followed the advice to skip it unless holding alt which works swell; I can completely ignore it and choose OS to boot with f12, or hold shift and choose in the grub menu).

I hope the wifi of the AX200 stays visible to Manjaro after visiting Win10 (brr) just for PBEM turns in Planetfall after this fw update. It wasn’t indicated as a change but who knows and it was listed as a ts step for that herearound. Knock on wood : )

Thanks for your help too. I needed to read up to get at least a paper boat understanding of MBR vs GPT, BIOS vs EFI and grub or no grub (and esps) and I’ve come to appreciate that Win10 won’t automatically annihilate an existing ESP it finds, and neither will Manjaro)