Manjaro boot drive not being noticed by bios when booting

Ok so I installed manjaro (only os present) through a bootable usb a few months back on my laptop. Whenever I try to boot I get

"No bootable device -- insert boot disk and press any key"

Ive done extensive googling to no avail so i figured make my own post. After I turn off and computer and reboot many times, it eventually will get in, but this is usully around 50 to 75 reboots. I am able to get back in with my bootable usb. I have reinstalled manjaro before and it has never fixed the issue, yes the drive does have the bootable flag ticked. I am in Legacy boot not UEFI mode. Any insight would be greatly appreciated.

1 Like

please be more precise

the drive you are referring to, is your laptop's internal hdd? if so then make sure its set as primary boot device in bios, also do a disk check, that seems to be a faulty drive

have you used other operating systems on this laptop ? installed, not from live usb

has anyone removed or replaced the hdd at some point ?

1 Like

Oh sorry about that. The drive is the internal on the drive and it is the only boot device. I used windows on the laptop for a while since it was stock but its been entirely replaced. I had removed the drive at one point but I made sure that it wasn't loose a few days ago.

Have you checked if the boot flag is set on the partition where /boot is located?

1 Like

how have you create your USB iso manjaro ?
can you tell model laptop ?

1 Like

Boot up using this link and when booted up provide info as stated in the link, namely..

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

PRINT output and if error , print error and proceed to the next command.

1 Like

Yes I loaded in through the bootable usb and made sure the boot flag was on for that partition

I just used the usb bootable, and I have an acer aspire e15 I believe

1 Like

Ok Ill try this once I reboot however many times i need for the drive to be recognised

You need to provide the outputs @gohlip requested.

This command output would also be useful:

cat /etc/fstab
1 Like

If the bios has trouble recognizing an internal disk, you may have a disk (rarely bios -maybe cmos battery) problem.
From outside the disk, try to fsck the partitions. It may help if the disk is not failing (or connection loose).

1 Like

I never managed to get into the drive last night ill try again now

Yeah possibly the disk, so I guess im stuck rebooting forever until I get in on occassion

update: drive gets recognised as WDC ROM MODEL -FBLITE- instead of not at all

[byteme@byteme-pc ~]$ efibootmgr -v
EFI variables are not supported on this system.
[byteme@byteme-pc ~]$ sudo parted -l
[sudo] password for byteme: 
Model: ATA WDC WD10JPVX-22J (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  991GB   991GB   primary  ext4            boot
 2      991GB   1000GB  9449MB  primary  linux-swap(v1)


[byteme@byteme-pc ~]$ sudo blkid
/dev/sda1: UUID="65dac06a-8ff1-49f1-8bb2-84e36a0f016b" TYPE="ext4" PARTUUID="71eec1e6-01"
/dev/sda2: UUID="c3dcff1c-77af-45a7-b564-fc6cbc780aef" TYPE="swap" PARTUUID="71eec1e6-02"
[byteme@byteme-pc ~]$ findmnt -s
TARGET SOURCE                                    FSTYPE OPTIONS
/      UUID=65dac06a-8ff1-49f1-8bb2-84e36a0f016b ext4   defaults,noatime
swap   UUID=c3dcff1c-77af-45a7-b564-fc6cbc780aef swap   defaults,noatime
[byteme@byteme-pc ~]$  findmnt /boot/efi
[byteme@byteme-pc ~]$

Okay, good. Can you tell us know you got it recognized?
Is it your cmos battery, loose connection or fsck the partitions?
Also remember that disk detection by OS is not the same as detection by the bios.
OS can detect disks that bios cannot in some circumstance - usually sata ports that bios do not use at boot, but should not be in your case (single internal disk).

Now, let's get your grub working well again (if it is not) and no harm doing it again.
First make sure you have this in your /etc/default/grub

GRUB_TIMEOUT_STYLE=menu

Then back at terminal,

sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install /dev/sda
sudo update-grub

When I try to install grub on sda i get the following error, after googling into it, ive only seen the error with sector 32 and it seems to be caused by adobe programs, which I did use but when I installed manjaro I did away with the windows partition.
grub-install: warning: Sector 48 is already in use by the program `FlexNet'; avoiding it. This software may cause boot or other problems in future. Please ask its authors not to store data in the boot track.
edit: formatting and I forgot to mention, it doesn't consistently recognize the drive

That says it all. If you search the forum for 'flexnet', you can see there's many instance where the program changes the mbr (or $esp). The wiki page also states

Due to the way the digital rights management (DRM) works in FlexNet Publisher, FlexNet affects bootloaders; this makes FlexNet Publisher incompatible with drives encrypted with TrueCrypt[6][7] and renders Linux-based systems unable to boot.[8][9] The TrueCrypt developers also state that “the issue is caused by inappropriate design of the third-party activation software.”[10]

Normally a grub-install and update-grub will fix it but I think the error will return if flexnet is used again.

You can try

sudo parted /dev/sda set 1 boot on

to set a boot flag and see if this any easier.

Sounds like a boot virus to me.

DRM, same thing. :wink:

1 Like

Forum kindly sponsored by Bytemark