Manjaro ARM Preview2 for Raspberry Pi 4!

Not knowing what your specific issue is as Strit alluded to above but this may be a good time to post that with the pi4 there are issues (that they are aware of) that with certain monitor's/tv's not getting the EDID info properly from the monitors. In my case it is my VIZIO tv and had to disable gathering EDID all together (hdmi_ignore_edid:0=0xa5000080), force output to the hdmi port ( hdmi_force_hotplug:0=1) and had to manually specify my tv's info. The :0 & :1 in the config lines in /boot.config.txt are for the hdmi port numbers for port 1 & 2 respectively on the pi4 board. You will have to change in the example below the hdmi_mode:1=39 for the hdmi_mode that is for your monitor that can be found here under the hdmi_group=2 section. Also note in my case hdmi_modes 39 & 81 says the same thing for resolution but only 39 will work!

https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

In /boot/config.txt this would manually configure the second hdmi port. Look up and get the correct hdmi_mode for your monitor's resolution and replace 39 with the correct number:

hdmi_ignore_edid:1=0xa5000080
hdmi_force_hotplug:1=1
hdmi_group:1=2
hdmi_mode:1=39

This is an example for the first hdmi port on the board:

hdmi_ignore_edid:0=0xa5000080
hdmi_force_hotplug:0=1
hdmi_group:0=2
hdmi_mode:0=39

Yes, no second monitor is being detected. I am etching the image again and starting over. I bought two new monitors and have and can use them with my other system. I appreciate your quick response.

You had mentioned before that Mate is on the horizon. Is that still a true statement? I do want to thank you and everyone else for the work you are all doing for Preview 2!!!

MATE edition is available via the Manjaro ARM Installer.

I don't have 2 monitors to test with, so I can't really test it.

Thanks Strit. Both monitors are on now, but mirrored. Display settings only shows one monitor. I am trying to figure out how to get them to display expanded.

Thanks again.

Darksky, that is awesome. Thanks for the link and the info! Both monitors display using hdmi_mode: 82. The display settings still show the one monitor. I did gimp the desktop image together to show the mirror I am experiencing. Most everything is spot on and pretty snappy. This is all pretty amazing for a Pi. Thanks again to everyone involved!

I am seeing the same here with my messed up monitor situation.

I read that the RPi people re-wrote their Screen configuration utility for the pi4 but every screen shot I saw of the utility just showed 2 screen icons but there was no screen shot of anything in it's menus. Also every picture I saw the monitors were mirrored.

The only way I see if expanded is possible is to load up the raspian image with their screen utility and go through the menu's to see if there is way to enable expand.

If that is possible to expand then that presents another issue as currently our desktop environment does not see but one monitor. There will have to be some code re-written for the p4 or some how some one ports over the RPi screen utility or write an equivalent program. If the RPi screen utility uses any libs under /opt/vc then all bets will be off of porting it as it has 32 bit libs and no one as of yet I know has been able to port those lib/headers over to use 64bit and the pi people have no interest in doing so up to now so /opt/vc directory does not exist on 64 bit images.

My reply in another thread here:

After more thought it might be possible to set up configs for both monitors in xorg.conf. Possibly if both monitors are recognized by xorg and show up in the Manjaro image Display utility then might be able to set the monitors to be expanded.

I got expanded working here. So I do not have to double post here is where I posted in the other thread involving duel monitors not using expanded mode.

1 Like

Hello!

This is my first post in the Manjaro community in general, pleas be gentle! :smiley:

I've been using Manjaro ever since I bounced hard off of Arch - I love how it blends Arch's robustness and overall stability with a non-tech-savvy user friendliness and how most stuff is pretty much OOtB. I've been using it on an ancient IBM laptop and it has given it almost a second life.

I've jumped on the rPi4 hypetrain pretty much on the drop date and while Debian runs quite smoothly on the tough little board, I've been itching for Manjaro to catch up.

Enough of my babbling - I do have one simple question - how would one go about installing Manjaro through a networked, headless connection, but still have GUI capabilities (like install through VNC or if it's impossible, through SSH at the least and then configure VNC?)

Welcome to the forums.

Depends on what you are wanting to do. If you are wanting to run an occasional GUI then ssh -Y is good as it does not take as much bandwidth as a remote desktop. I use it tuning my satellite and streaming over the lan with my dvb apps but some things needed to be added in sshd_config for that to happen first.

If you are wanting to have a remote desktop yes VNC or a lot of people like nomachine but do not know if it is readily available for 64bit; you may have to compile it from AUR.

Is there a topic for Manjaro Wallpapers, where I can upload rendered pictures? :slight_smile:

Thanks for the reply, @Darksky!
Sorry if i wasn't too clear. Getting around after the installation should be easy, I've worked with SSH and VNC enough to be able to find a solution afterwards, but what I'm actually asking is - after I drop the installation image ona na SD card and plop it into the Pi, assuming I know the IP, can I control the installation process itself remotely. It's a hardware/laziness issue - I'd like to avoid re-plugging my kbd/mouse and monitor multiple times :smiley:

Currently not. As far as I know.
The only user on the system is root, and it does not have a password before the OEM setup is complete.
We do plan on giving root a default password, so that might be possible from the next release.

I have a headless setup so in the absence of a password (so I can SSH), do you know of any Windows 10 emulation possibilities. I'm sure they'd be far more hassle than they are worth but I thought I'd ask any way.

Of course I could just check if my old, dusty monitor is working and get myself a mini --> HDMI cable :slight_smile:

You could use the Manjaro ARM installer (only runs on Manjaro though) to install it to the SD card. It will do all the setup for you, like setting up user and passwords.

Thanks for the response. So I could run Manjaro in a VM, plug in my USB/SD device (which I know the VM recognizes) and install into onto the card. That sounds great!

Just to ensure I'm looking at the right thing, is this the installer you're referring to:

I'm assuming the script offers a Pi 4 64-bit option otherwise you wouldn't be recommending it :slight_smile:

Not sure if I'm meant to reply to my reply but I just wanted to say, I booted up the x64_amd version in VMware to get the ARM installer going and wow, you guys have one gorgeous, useable OS! I'm new to Manjaro but I think you may have an additional convert.

On a marginally less positive note (!), I ran the installation and did a headless boot on my Pi 4. Is it possible that the ssh service is by default stopped upon initial boot (it is with the x64_amd version)? My ssh client isn't getting a whole load of response atm but I can see that the Pi has been assigned an IP address on my LAN. If there's an easy fix to this, great but otherwise I should probably just get a cable and monitor set up. I don't want to take up too much of your time for something pretty simple.

SSH should be enabled by default.
But the installer might not work correctly right now, because there is currently a restructuring of packages in place.
Arch Linux just switched from using a base group, to using a metapackage of the same name, but that package only brings in about half of what was in the old group. We are still adjusting our tools and installer for that.

Does the install boot with a screen and keyboard?

I've set up the Pi 4 with a monitor and cable. Here's what I did:

  1. wrote minimal raspbian-buster to my card, booted and it loaded. I wanted to check the sceen etc were okay.
  2. wrote Manjaro-ARM-xfce-rpi4-preview2 to my card, booted and full desktop loaded. Yes, you are correct, sshd was enabled.
  3. used the ARM installer, wrote to my card, booted, blank screen. Also, I noticed before booting that the boot partition (it happened to be E:\ in windows) was blank. That didn't seem right.

That's latest. Please let me know how I can further help, if neceesary.

Hm. 19.10 is just around the corner though. Maybe you can wait for that one?

Forum kindly sponsored by Bytemark