Manjaro ARM Plasma-Mobile Beta1 (PinePhone)

as long as the phone is working for you, the rest of the OS is decent (minus the keyboard errors) and the ideas are excellent.

for me, no reliable SMS, no manual APN adjustment, no outgoing calls, missing incoming calls - just unusable as a phone. modem is working fine, carrier is detected, messages can be sent through ofonoctl.

There is any way to select, copy and paste text on plama mobile yet? holding down your finger on text does nothing.

Thankfully I found it works in Angelfish (for copying one time login codes from email into another webpage tab) but not for much else.

I’d also be interested to find out if there’s any way to get it to work elsewhere.

1 Like

I managed to get the touch screen working after a few reboots!

Overall its a big improvement, ive installed my apps audiobook and qweather from the aur and they run slick and smooth without needing any changes from the desktop code.

I did notice that if i open a lot of apps at once, the button bar at the bottom of the screen becomes disabled, and I need to pull the battery out to reset the phone.

Im looking forward to beta 2, and hopefully I can give it a whirl as a daily driver!

In Dev-200919 Mobile Data was working for me, but in Beta1 (Also in Dev-210102) it is not working. If I go to Settings > Cellular Networks > Access Points, here is how it looks:

In the Dev-200919 the Active checkbox was ticked in green, whereas now it is grayed out :frowning_face:

ofonoctl wan gives this output:

[kde@manjaro-arm]$ ofonoctl wan
Interface    Protocol    APN     Method    Address           Gateway        DNS
-----------  ----------  ------  --------  ----------------  -------------  ---------
wwan0        ipv4        jionet  static    25.100.239.62/30  25.100.239.61  49.45.0.1

I am having the same issue. It seems that Network Manager is not updating the wwan dns servers in /etc/resolve.conf but that may not be the problem, it could just be a symptom.

Same for me, no mobile data with latest beta. This is the only problem preventing me to migrate from phosh to plasma as a daily driver. Plasma offers better experience IMO.

100% i really hope they get the phone aspects worked out then ill switch

Would config the screen timeout and/or the lockscreen to 4-5 minutes.

Anybody an idea where I can configure this (in the shell?) ??

1 Like

I am able to get a working data connection by using the following command in the terminal:

sudo ofonoctl wan --connect --append-dns

I will have to find a proper way to automate this so I don’t have to do it manually every time my connection drops.

Thanks you so much! I’m able to get working data too with this command. Yeah, would be great to automate this.

For me personally, the issues I have is that when my phone is locked and in idle for 3-5m the WiFi seems to always disconnect and needs to get reconnected when I wake the screen up.

The issue seems to not happen when its plugged in and charging and only when it’s using its battery so its probably some battery saving feature which may be buggy

Another issue seems to be that gtksink is not getting detected even if I have gst-plugins-good installed, so I can’t play local files

Not only WiFi, but also phone calls stop working. Sometimes, for others who call me, it gets ringed, but for me it doesn’t ring and also no missed call will shown.

Let’s hope it improves in Beta 2!
For me, that and gtksink is the only issue I am having :grinning:

Can keyboard be opened via terminal with a commad?

@Peter2469 i would like a button in the bottom tool bar

i only discovered that closing the keyboard is possible by swiping it down by accident.
but with the latest update, it stopped appearing at all.
running maliit-keyboard in the terminal doesn’t bring it back.

I have encountered the same, using unstable branch.

Yes, I didn’t know what to do and just performed clean installing Phosh. I’ll come back to Plasma Mobile later.

I still cannot get the mobile internet working. Finnish Telia. Anyone here from Finland with other operators? Only Phosh works now for mobile net.