Manjaro arm on Amlogic Tv box?

Great to know that Beelink Team and you have confirmed the Android bsp uboot is causing the Kernel Panic in GT King and GT King Pro on Mainline Kernel Linux.

Will it be a great concern for many GT King and GT King Pro owners/users on having to erase Android bsp uboot? Does the GT King Pro still boot up normal in Android and option to boot up Linux or other OS from SD card or USB Stick with the new mainline uboot?

Hope Beelink will upgrade their Android bsp uboot on GT King Pro in their next firmware upgrade via OTA to resolve the conflict with mainline Linux Kernel.

Thanks Beelink Team, Manjaro Team and Spikerguy for the great work and support.

Yes it is a concern as user will have to erase the emmc uboot which means you will have to erase android from emmc to get linux to work.

I have informed beelink developers to look into their uboot and find a fix for this issue, but this won’t be an easy task for them.

For those who don’t need Android can erase it using burning tool and flash any android image while unplugging the cable when burning reaches 15% which will make the emmc blank then we can boot mainline uboot and mainline linux over it.

I will discuss this with Bee-link android team and see if they can do something to fix Android bsp uboot issue.


I think it will be a great/grave concern to many Beelink GT King/Pro owners/users, many purchase/invested on a higher/highend Android TV Box typically have two objectives:

  1. A user friendly home entertainment and video streaming (whole family can enjoy together) where Android TV Box serve very well and
  2. With the extra CPU/GPU power like in the case of GT King/Pro or Ugoos AM6 are powerful enough as general purpose PC where Linux Debian/Manjaro/Ubuntu serve well.

To most users/owners of higher/highend Android TV Boxes, removing Android from the emmc just to install Linux alone will be a hard sell and having to chose either Android or Linux.

Beelink as a respected Android Box manufacturer should come out with a solution for Android BSP UBOOT to cater for the mainline Linux Kernel and furthermore some of their competitor like Ugoos AM6 (per comments from Tripole) “seems” to be able to support Mainline Linux Kernel without kernel panic.

1 Like

Yes, I can run Armbian arm-64 TV-box edition with kernel 5.9.0 rock steady (I have used it a couple of months) and I have (since a couple of days) also the Khadas image (Debian/buster/xfce) for VIM3 with kernel 5.9.0-rc2 running (built with their tool fenix) on my Ugoos, also seemingly rock steady (and everything works).

Edit: But I want the awesomeness of Manjaro.
Edit2: Both kernels mentioned above are mainline and only slightly patched (by Armbian, Khadas, respectively). At least the Khadas image moreover uses some “standard” u-boot (with code from Github, it is pulled from there by their fenix thingy). (I think, but am not sure, that the TV-box edition is based on a rockchip 3399 version of u-boot. I have built a “Franken”-image recently (Armbian/Manjaro) with the Armbian u-boot and booted the Manjaro system succesfully, but, alas, the glitches and freezes were still there.)

I also tried Single Armbian image for RK + AML + AW (aarch64 ARMv8) both Bullseye and Ubuntu many different kernel including the latest 5.9.0 on Beelink GTKPro and all have kernel panic/freezes. My experience on GTKPro, Armbian Kernel 5.7.16, 5.8.5, 5.8.7, 5.8.10, 5.9-rc6, 5.9-rc7 the kernel panic happen very frequent like Manjaro VIM3 20.06 (Kernel 5.7?) but on Armbian 5.9-rc8 and Armbian 5.9.0 it is far more stable, where in most of the time, successfully perform system updates and able install new apps (like Firefox or Chromium, LibreOffice suite) but kernel panic/freeze does happen and also at times corrupt the SD Card or USB Stick which cause the SD or USB not being able to reboot and have to re-burn the image.

Manjaro-ARM-xfce-vim3-20.11.img_xz on GTKPro also seems much more stable than Manjaro VIM3 20.06 image so far but then on Manjaro-ARM-xfce-vim3-20.11.img_xz, no opportunity for large system update yet, as the image is new. It did freeze/kernel panic once and power off and on, it reboot but Manjaro perform journal recovery or something like to that effect.

Looking forward to solutions to enable GTKPRo to be able to use Mainline Linux Kernel like current Manjaro 20.10 or other Mainline Distro without kernel panic but still with the option of using Android in emmc and Linux boot from SD/USB. Android used for family home entertainment and video streaming.

[Edit 3]GTKPro runs on Ubuntu with Kernel 4.9.206 - build by Darkstar or 4.9.224 (but could not login to Gnome Wayland but can login to Gnome Xorg. It is supposed to be able to work with Gnome Wayland) without issue.

[Edit 2] Second Freeze/Kernel Panic just after the first edit of this maessage and completed sending a shot email.

I have installed linux package yesterday (sudo pacman -S linux) which automatically uninstalls linux-vim package.

It might break your system (I had to use a different .dtb for my X96Max+ to be able to boot again) but then you will have kernel 5.9.1-3-MANJARO-ARM.

With this kernel and also kernel 5.9.6-1-MANJARO-ARM from the unstable branch my system is much more stable even in combination with the latest Panfrost GPU driver.

You might have a try and see if these new kernel also help your system to be more stable. But use on own risk!

For this solution you will have to push beelink team to fix Android bsp uboot issue which conflict with linux kernel, we might not be able to help with that, what I can do now is create an image which is based on mainline uboot and kernel, this is just a alpha test image as we cannot still get full ram usage as only 2gb is visible.

This is good but do you get audio over hdmi on linux ?

Unfortunately, my soundcard is not recognized and ethernet does not work with the new .dtb I had to use to make my box boot again.

Hi Spikerguy,

I have started a new Post at Beelink Forum “Beelink GT King Pro - Encounter Kernel Panic/Freeze in Mainline Kernel Linux”, hopefully Beelink Development Team will work on a new firmware with New Android BSP UBOOT to solve the GT King/Pro linux mainline kernel (Kernel Panic) issue.

[Edit] To avoid Kernel Panic for system upgrade I use Manjaro Package Manager to perform updates by breaking the updates into three blocks and was successful in updating to the latest Manjaro Arm 20.10 on GTKPro. Does the Package Manager also perform full system update just the same as “sudo pacman -Syu”?

[Edit 2: During “sudo pacman -Syu” a kernel panic happened and it corrupted the USB stick and unfortunately that USB stick is no longer recognisable (may be a bad USB stick quality). That is the reason, I breakdown the system updates into badges to minimise the size of updates to avoid kernel panic].

Does Manjaro Arm 20.10 is pre-configured with Panfrost enable or is there any command or environment had to set to use Panfrost in Manjaro Arm 20.10?

Just checking whether, there is any video hardware acceleration support in Manjaro Arm 20.10 (for amlogic S922X devices) Firefox 82 or Chromium-Browser 86?

Hi TheMojoMan,

Just completed updating the stable Manjaro Arm 20.10 (have to split into three uprades to avoid kernel panic may be specific to Beelink GT King Pro) which still is on kernel 5.9.0-1. I won’t be surprise with kernel 5.9.6-1 will be more stable on GTKPro. I presume it won’t be long the stable Manjaro Arm will be upraded to kernel 5.9.6-1.

Do we have to set up some commands or to use Panfrost in Manjaro Arm 20.10?

Hi Tripole,

Just checking after your latest Manjaro Arm stable update what version of kernel do you have? I just managed to perform update and still on kernel 5.9.0-1 (I use Manjaro Package Manager to perform the updates trying to avoid kernel panic specific to GTKPro).

I haven’t updated yet but I don’t think there was any update to linux-vim (Spikerguy is busy working on it I think, perhaps transitioning to another branch).

Edit: Corrected the name of the kernel package.

Type sudo pacman -S mesa to install mesa package which brings panfrost drivers. You can experiment with even newer panfrost drivers by installing mesa-git.

But my system was very unstable when using kernel 5.9.0-1 and panfrost drivers. That is the reason I switched to linux packages which comes with kernel 5.9.1-3-MANJARO-ARM. With that kernel my system does not crash anymore when using panfrost drivers. But as spikerguy described before there are problems with audio over HDMI when using linux package.

So, if you want to go experimental you might consider trying linux package and see if your system is more stable with kernel 5.9.1-3-MANJARO-ARM. If so you might add panfrost and e.g. supertuxkart and openarena in a next step and see if/how well it works on your system.


No, panfrost is not stable for g5x gpu yet, it will cause crashes so please don’t use it now. We won’t make it default until it is stable.

These are 2 different things.
Vpu for Media applications and vpu for browser is different use cases.
Vpu is not that yet it needs updates to all the video processing stack which starts from vpu support in kernel then ffmpeg then media players.
This will take long time to be stable.

Currently librelec have vpu support but it is still not stable as fast forward still breaks the video playback.

Yes I’ve tried to build 5.9.6 but it failed with panfrost patch Will try to fix it soon

Do not try this on 5.9.0 there is memory leak issue which will make ur ui unusable after few minutes and you might not be able to go back in some case.

Only try if you want to test it yourself but don’t complain if you have to reflash the os again.

Received a favourable response from Beelink:

"Hello, we are discussing this issue with the Manjaro developers. We will make the manjaro system compatible with the S922 chip in the future"

The good news is Beelink is discussing with Manjaro (I take it is with you, Spikerguy) to resolve the conflict with the mainline linux kernel. Hope it will be applicable for all Linux Distros.

1 Like

(About audio more generally:) Perhaps slightly redundant or not relevant, but here goes.
In order to get sound to work on my Ugoos I had to fiddle a little with the entries in


but I also noticed that on my Manjaro 20.06->20.10 install I did not have the file


Without this latter configuration file, only a basic device (“Analog audio” or something) would show up in pulseaudio but with this configuration file all the HDMI and surround devices would show up. (The file G12B-KHADAS-VIM3.conf is included with Manjaro ARM-vim3, however.)
In the Armbian TV-box images there are configuration files (with LibreElec GPL2 licence) like G12B-UGOOS-AM6.conf but also G12A-X96-MAX.conf, and many others, which may be useful.

Yes me and the project lead of libreelec as we work along with other linux projects together.

Yes as we dont support this hardware I didn’t use it but I will follow aliases method used by libreelec so all the hardware will have support.

Btw which kernel are you on?
If I change to mainline upstream kernel linux package then it doesn’t detect the audio card at all.

@spikerguy I haven’t upgraded beyond 5.9.0-1-MANJARO-ARM, so that’s where I am. I would be more than happy if the vim3 has full support and, perhaps, one or a few similar boxes have partial support (not necessarily my Ugoos). The rest of the community can certainly solve the smaller things (e.g. non kernel related) and come up with the tweaks necessary to get Manjaro ARM running on other boxes.

1 Like

Thanks for highlighting the issue of kernel 5.9.0 memory leak issue and not compatible with mesa-git. So it is best to wait for you to update the build to kernel 5.9.1 or 5.9.6. Thank you.