Manjaro arm on Amlogic Tv box?


FYI, Encountered second kernel panic (XFCE linux-vim 5.11.4-1 on SD Card) after around 2 hours up-time. This round after performing a “Screenshot” and switching tab on Chromium.

Additional information, I seem to have very often “system hesitancy” on XFCE linux-vim 5.11.4-1 (previouly linux-vim 5.11.2-1 also). It seems like the system is performing task at the background freezing the for a while (at time can up to a few seconds). Don’t seem to have this Manjaro-XFCE-linux 5.11.x (cpupower governor set to “performance”) so far that is on USB Flash.

Could it be a system setting on my linux-vim 5.11.4-1 image that is routinely writting to the SD card that is momentarily causing the in activeness? When it happen the “htop screen” also freezes momentarily.

Hey JFL. I’m running just the Beelink GT King… no pro… It’s a couple of years old now… I updated the firmware on it to the most recent (912p0)… box says “up-to-date”…

I then prepared an SD card with Manjaro using the recommended “meson-g12b-gtking.dtb”… everything installs just fine… Once in, I can get to the Network settings and manually create a wireless connection (SSID, login password etc…)… Maybe I’m missing something and my wifi is working but I don’t know how to “activate” the wireless connection I made… Ethernet works fine…

So with the above, I just assume that my wifi board is not active …

I’ve tried Mojo’s command line structure:

  • sudo pacman -S base-devel git bc dkms linux-vim-headers
  • git clone
  • cd RTL8822CS/
  • sed -i 's/$(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd)/$(MAKE) -j4 -C $(KSRC) M=$(shell pwd)/g' Makefile
  • sed -i 's/$(CROSS_COMPILE)strip $(MODULE_NAME).ko --strip-unneeded/strip $(MODULE_NAME).ko --strip-unneeded/g' Makefile
  • make
  • … (wait about 5 min.) …
  • sudo make install
  • sudo modprobe 88x2cs

The first line " * sudo pacman -S base-devel git bc dkms linux-vim-headers" brings up some error (I don’t recall) and doesn’t install… for the heck of it, I continued on until I get to the “make” command… it’s not found… so I assume the first line installs it…

Coming to my initial observation that Mojo released an install file, dkms-rtl8822cs, on Github, I wanted to try it but I feel that the fact that I can’t install the “make” command, this probably would fail as well…

Is there a way to “turn on” the wifi board within the Manjaro OS?

Thanks for your time.

Please share output of
uname -a
I need to check which kernel package are you using.

We already have RTL8822cs pkg in the repo thanks to @TheMojoMan

You can install it using the command
sudo pacman -S dkms-rtl8822cs

This should work fine.

If you can create wireless connection, you should be connected to the wifi. By the way, what kernel package are you using? If you are on any of the later kernel 5.10 and above you should already have have the wireless firmware. GT King Pro uses brcmfmac4356-sdio.bin, brcmfmac4356-sdio.txt and BCM4356A2.hcd drivers for Bluetooth and wifi. Not sure whether GT King uses the same drivers. Do check in /lib/firmware/brcm/.


I was complaining that I am having Bluetooth errors earlier. Now resolved, somehow I am missing this driver “BCM4356A2.hcd”. Once I copied it over to /lib/firmware/brcm/. No more Bluetooth error.

If I am not mistaken, “BCM4356A2.hcd” is missing in the Manjaro Firmware.

Edit: With the “Bluetooth Error” resolved, it seems the occasional system hesitancy doesn’t seem to happen anymore (after 75 minutes of usage). Interesting.

Edit3: Spoke too soon, 3rd system freeze strikes. (around 85 minutes uptime). Linux-Vim 5.11.4-1.

Hi SickOS,

If you don’t mind me asking, how did you go about installing “5.11.3 Ubuntu Kernel from”? Would you mind sharing the installation process? Did you install the Ubuntu kernel on Manjaro-Arm image? Interesting.

I already stated it was in Ubuntu ports distro.
Now I have again sound in Manjaro because changed dtb file. It was just a lucky trial, not my own thought :wink:.

Hey folks. So I can confirm that I have kernel 5.9.0-2-MANJARO-ARM #1 running… GT-King model (not the pro)…

I tried the line: sudo pacman -S dkms-rtl8822cs as suggest but I received error: target not found: dkms-rtl8822cs …

any other ideas?

I appreciate your help in advanced.

I think youre not using Manjaro or using an old image which doesn’t seem to be connected to later repo

5.9.0-2 is very old.

You might have to upgrade.

Try these commands.

sudo pacman-mirrors -f 5
sudo pacman -Syyu dkms-rtl8822cs

Things might break coz you’re using old image.

Thanks Spikerguy… How can I update to a later version? Is this a limitation of the beelink box or do I need a newer image file for my SD card? I need I used the latest image…

FYI, I started this venture here: [How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC post 1 by SpikerGuy… perhaps there is a new download link?

Hi TC2021,

On my post 739, I outline how I burn a new image on SD Card for GT King Pro and how to avoid kernel panic (this is only related to GT King and Pro).

The latest Manjaro-Arm for VIM3 on Manjaro Download website is 20.12. Somehow 21.02 for VIM3 image is not available. Download Manjaro-Arm-Vim3 20.12 and see whether Post 739 will help you to install Manjaro-Arm-Vim3 on your GT King.

Here is some bits from post 739. Hope is useful. Good luck.

Burned a fresh Manjaro-VIM3-XFCE 20201220 on a SD Card with linux-vim, to avoid kernel panic on GT King Pro, first I install the new boot-vim3 20.10-1 to use the new u-boot.ext which also convert the boot up using extlinux.conf instead of uEnv.ini.

Then “sudo pacman -Syu”, system update to linux-vim 5.10.5-1, just for your info the sound is loss after update to linux-vim 5.10.5-1, the issue is due to the Amlogic New Conf being used. Edit to revert to Amlogic Old Conf, and system enable sound and reboot sound return.

Please reply in amlogic device thread.
Let this thread be for rockchip devices.


FYI, GT King Pro Manjaro-Arm-XFCE-linux-vim 5.11.4-1 with current mesa-git on Stable Branch, Encountered 4th Kernel Panic/System Freeze in the last two days of use. This time the kernel panic strike on boot up so I can provide screen shot.

The good news is after inserting “BCM4356A2.hcd” into “/lib/firmware/brcm/” there is no more “Bluetooth Error”

NO more these Blutetooth Errors

[ 9.997055] Bluetooth: hci0: command 0xfc4c tx timeout
[ 18.395712] Bluetooth: hci0: BCM: Patch command fc4c failed (-110)
[ 18.395754] Bluetooth: hci0: BCM: Patch failed (-110)

And also there is no more occasional system hesitancy and the system is responsive now.

Certain website still triggers Panfrost “gpu sched timeout”.

[ 4064.043727] panfrost ffe40000.gpu: js fault, js=0, status=INSTR_INVALID_ENC, head=0x5982a00, tail=0x5982a00
[ 4064.047898] panfrost ffe40000.gpu: gpu sched timeout, js=0, config=0x7301, status=0x51, head=0x5982a00, tail=0x5982a00, sched_job=000000006a6369ff

1 Like


I remember you were looking for source code for chainloader. I happen to stumble on this, you might have already read, but just in case.


It looks like I am the only one facing system freeze/kernel panic with linux-vim 5.11.4-1. 2 more system freeze/kernel panic during boot up at Manjaro Greeter Login Screen. So no choice but to upgrade to your new linux-vim 5.11.7-1 (Unstable branch).

Installation of linux-vim 5.11.7-1 went without any issue. After successful linux-vim 5.11.7-1 upgrade, issue “reboot”. Kernel Panic at boot up. CPU 4 this round.

Power cycle, boot up and login to hotmail. Another system freeze after login to Hotmail.

If I am the only one facing this linux-vim 5.11-4-1 and linux-vim 5.11.7-1 system freeze/kernel panic, may be there is an issue with my Manjaro-Arm-XFCE-linux-vim 5.11.7-1 image.

Do you have the latest Manjaro-Arm-Vim3 21.02 for download? I noticed Vim2 21.02 is available but NO VIM3 21.02.


24 March Edit: Same XFCE-linux-vim 5.11.7-1 image as above.
2 more consecutive kernel panic on boot up (one after login and another during boot up CPU 5 kernel panic. Screen capture basically the same as above but CPU 5) and 3rd kernel panic session on Chromium about 5 minutes after boot up.

This same linux-vim 5.11.7-1 was running more than 6 hours with no issue even with heay memory resource usage.

I have had one of these freezes with linux-vim 5.11.4-1 on my Ugoos AM6 plus. I have therefore downgraded to linux-vim 5.10.8-1 which works perfectly stably since several weeks.

Yes I faced this on GT King Pro too, Looks like some regression in kernel as I switched to tobetters.

When linux-vim 5.11.4-1 and linux-vim 5.11.7-1 when it run smoothly (i.e. without kernel panic), it is very responsive. Even thinking of running KDE Plasma with it. Currently on XFCE. I am on linux-vim 5.11.7-1 (so far 15 minutes uptime). Let’s see whether kernel panic will strike this session. Will keep you updated.

By the way, is Khadas VIM3 21.02 image going to be available?

Edit: XFCE-linux-vim 5.11.7-1 encounter another system freeze after round 2 hours of uptime - running Chromium at the time of the system freeze.

Edit 2: It looks like linux-vim 5.11.7-1 system freeze on GT King Pro is very regular. Had 4 kernel panic just last two hours (2 on system boot up and 2 while browsing).

Will make 21.03 had some issues with panfrost at that time. Will try to get it tonight.

1 Like

Hey JFL. I tried your recommendation… No go… Kept getting errors. That said, before attempting the instruction set on No. 739 I did a “uname -a” and got and the kernel was 5.9.8, using img file “Manjaro-ARM-kde-plasma-vim3-20.12.img” … so a little closer to success hahaha! Anyway, I guess I’ll just wait for an updated vim-3 image…

Thanks everyone! I appreciate your patience with me.