Manjaro arm on Amlogic Tv box?

When linux-vim 5.11.4-1 and linux-vim 5.11.7-1 when it run smoothly (i.e. without kernel panic), it is very responsive. Even thinking of running KDE Plasma with it. Currently on XFCE. I am on linux-vim 5.11.7-1 (so far 15 minutes uptime). Let’s see whether kernel panic will strike this session. Will keep you updated.

By the way, is Khadas VIM3 21.02 image going to be available?

Edit: XFCE-linux-vim 5.11.7-1 encounter another system freeze after round 2 hours of uptime - running Chromium at the time of the system freeze.

Edit 2: It looks like linux-vim 5.11.7-1 system freeze on GT King Pro is very regular. Had 4 kernel panic just last two hours (2 on system boot up and 2 while browsing).

Will make 21.03 had some issues with panfrost at that time. Will try to get it tonight.

1 Like

Hey JFL. I tried your recommendation… No go… Kept getting errors. That said, before attempting the instruction set on No. 739 I did a “uname -a” and got and the kernel was 5.9.8, using img file “Manjaro-ARM-kde-plasma-vim3-20.12.img” … so a little closer to success hahaha! Anyway, I guess I’ll just wait for an updated vim-3 image…

Thanks everyone! I appreciate your patience with me.

You mean you are able to boot up and just NO wifi? In you able to boot and no wifi may be you are missing the wifi drivers.

In the /lib/firmware/brcm/ do you have these driver files brcmfmac4356-sdio.bin, brcmfmac4356-sdio.txt and BCM4356A2.hcd? These are the one GT King Pro uses and may be is the same for GT King or may be not.

Hey JFL. Correct; I am able to boot just fine, no wifi… I’ll check when I get home tonight… That’s what I’m thinking… a driver is missing… If I am missing these drivers, any idea where I might be able to download them? Also, is it as simple as copying these drivers in the directory you suggest and reboot?

Thanks alot.

If it is not in the Manjaro-Arm-Vim3 20.12 image then try to update to the latest image. But make sure you already boot-vim3 2020-10-1 installed before you perform system update else you will get a kernel panic.

Previously it is available in kvim2-firmware. sudo pacman -Syyu kvim2-firmware linux-firmware but now it is already in the newer linux-vim or linux 5.10 or 5.11 kernel images.

Hey JFL. So I have the brcmfmac4356-sdio.bin and txt files but am missing the BCM4356A2.hcd…

Even without the BCM4356A2.hcd (for bluetooth), if you have the others you should be able to get wifi. I was missing the bcm4356A2.hcd for a long time in Manjaro-Arm and wifi is available just having a lot of Bluetooth error message on dmesg.

Do you have wifi now? In the network connection icon you should be able to see your wifi and you need to select it to enter your password. If you don’t have wifi with the bcm4356-sdio.bin and txt, I am not sure your device uses the same driver as my GT King Pro.

No option for me to load the BCM4356A2.hcd here. It is available in Armbian image.

There is a version available here broadcom-bt-firmware/BCM4356A2-0a5c-6420.hcd at master · winterheart/broadcom-bt-firmware · GitHub and wlan-firmware-aml/bcm4356a2.hcd at master · openwetek/wlan-firmware-aml · GitHub.

Can you please confirm if are using Mainline kernel and are the installation instructions for mainline kernel from spikerguy for the X96 Air P3 correct?

Hey, can u provide any guide how to run Manjaro on A95X F3 Air?
Just when i try to run LibreElec with mainline kernel it doesn’t wanna boot, just bootloops

Hello and welcome to the forum,
I think it should work after making changing to the dtb file name in extlinux.conf

Hello and welcome to the forum,

As said it should work atleast to boot the device. I have no idea which dtb to be used for these devices.

No idea about LibreElec image you might have to try the box image and change the dtb accordingly.

After using the generic dtb, it is not confirmed whether all the IO will work out of the box.

This is a tutorial Link

Try it and let me know. Reply back on the amlogic link. This thread is for general discussion.

1 Like

Can you share which image, what dtb file you are using and what is working on your X96 Air P3 box? eg: ethernet, sound and bluetooth?

with linux-vim kernel, sound, ethernet and wifi (using rtl882cs @TheMojoMan package on the unstable branch) is working on my X96 air P3. Bluetooth is not working (I think. I never tried it) . I’m using meson-sm1-x96maxplus-100M-vim.dts from 551.4 KB folder on MEGA, that is a mix from the work of @TheMojoMan and some work made by another forum member that I can’t remember the name.

Thank-you dante6913 for your prompt reply.

Can you please elucidate on what exactly is the “linux-vim” kernel. Is that the same kernel that gets downloaded from “spikerguy” ([How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC ) forum thread or are we talking about a totally different kernel?

The kernel version I have from following the instructions in the “spikerguy” thread after running update (due to having ethernet connection) is kernel version

I look forward to your reply,
Kind regards,

You have two different versions of the kernel. the linux kernel that is the mainline kernel and the linux-vim kernel that @spikerguy as been compiling from the @chewitt git (If I’m not wrong). With mainline kernel I can boot and I get the Ethernet working, but I never was able to get the sound working on the x96 air P3. With linux-vim kernel I have sound (because the kernel has some patches?). You can change between kernel with the packages GUI, and you can change between branches from

While the stable branch offers older kernels and older versions of software packages which are meant for daily usage, testing and unstable branches brings you newer kernels and software packages but your system might crash from time to time because it uses software which is still in development/not fully tested.

You can switch branches with the following command:
sudo pacman-mirrors -aS && sudo pacman -Syyu
where is ‘stable’, ‘testing’ or ‘unstable’.

So you can have the latest’s kernel.

Thank-you for your prompt reply.

I am not a developer but have never heard of “linux-vim kernel”. My google search responds with references to the vi iMproved text editor for txt/src code which I am very familiar with. In my experience kernels always had a number regardless of being mainline or beta but I may be old hat now. So with that said and out of curiosity, is the kernel ( that I downloaded from the “spikerguy” installation thread. Is that a “linux-vim kernel”? and if you have the time…how does one check?

Kind regards,

Please share the output of the following command
sudo pacman -Ss linux | grep installed

uname -a

Linux x96Air 5.11.4-1-MANJARO-ARM #1 SMP PREEMPT Wed Mar 10 16:56:03 +03 2021 aarch64 GNU/Linux

sudo pacman -Ss linux | grep installed

core/archlinux-keyring 20210110-1 [installed]
core/archlinuxarm-keyring 20140119-1 [installed]
core/base 2-2 [installed]
core/hdparm 9.60-1 [installed]
core/iptables 1:1.8.7-1 [installed]
core/keyutils 1.6.3-1 [installed]
core/kmod 28-1 [installed]
core/libaio 0.3.112-2 [installed]
core/linux-api-headers 5.10.13-1 [installed]
core/linux-firmware 20210208.b79d239-2 [installed]
core/linux-vim 5.11.4-1 [installed]
core/man-pages 5.10-1 [installed]
core/manjaro-hotfixes 2018.08-6 [installed]
core/manjaro-system 20210302-1 [installed]
core/mdadm 4.1-2 [installed]
core/pacman-mirrors 4.19.1-1 [installed]
core/util-linux 2.36.2-1 [installed]
core/util-linux-libs 2.36.2-1 [installed]
extra/alsa-lib 1.2.4-3 [installed]
extra/alsa-utils 1.2.4-2 [installed]
extra/archlinux-appstream-data 20200720-1.1 [installed]
extra/avahi 0.8+15+ge8a3dd0-3 [installed]
extra/ddcutil 1.0.1-1 [installed]
extra/libiec61883 1.2.0-6 [installed]
extra/libimobiledevice 1.3.0-3 [installed]
extra/libraw1394 2.1.2-3 [installed]
extra/libva 2.10.0-0.1 [installed]
extra/libxshmfence 1.3-2 [installed]
extra/manjaro-settings-manager 0.5.6-7 [installed]
extra/manjaro-settings-manager-kcm 0.5.6-7 [installed]
extra/ndctl 71.1-1 [installed]
Submit a list of installed packages to the Arch Linux project
extra/v4l-utils 1.20.0-1 [installed]
community/i2c-tools 4.2-1 [installed]
community/mntray 1.1.3-1 [installed]
community/tlp 1.3.1-2 [installed]

You are at mainline kernel, you can change that with manjaro package manager.
Search for linux-vim and linux-vim headers and install it.

This line shows that the linux-vim kernel is (already) installed.