Manjaro arm on Amlogic Tv box?

Yes, that is how I did it.

UPDATE

I finally found a more straight forward method to install rtl8822cs wifi driver.

Howto: Compile and activate RTL8822CS wifi driver - easier version

Open a terminal and do the following:

  • sudo pacman -S base-devel git bc dkms linux-vim-headers
  • git clone https://github.com/chewitt/RTL8822CS.git
  • cd RTL8822CS/
  • sed -i 's/$(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd)/$(MAKE) -j4 -C $(KSRC) M=$(shell pwd)/g' Makefile
  • sed -i 's/$(CROSS_COMPILE)strip $(MODULE_NAME).ko --strip-unneeded/strip $(MODULE_NAME).ko --strip-unneeded/g' Makefile
  • make
  • … (wait about 5 min.) …
  • sudo make install
  • sudo modprobe 88x2cs
1 Like

This is easier to package.

Great work and good that you gave sometime to this topic and finally got it to work and also simplified it for other users.

Much Appreciated.

1 Like

Yes, on Manjaro 64bit. I think I have posted the tutorial in this forum and Armbian:

the performance is quite good for LLVM Pipe driver. I managed to install sketchup 8 and make some 3D models quite easily.

I see, so that’s the trick

OK, thanks for your guide, will try this on “Armbian Reforge”. Since that is my only hope to run linux on this board. At the moment I cannot boot into Manjaro or Armbian or TwisterOS. It just a black screen.

You are awesome, Many Thanks… :slight_smile:

I’ve lost sound from last update. Downgrading to linux-vim-5.10.1 does not work and running g12a_sound.sh either. How can I recover sound? Maybe I need detailed instructions because I just do anything wrong.

Maybe g12a_sound.sh does not detect your soundcard correctly. You can then try the following:
(I am writing this from memory because I currently do not have access to my box)

  • Open terminal and then type: aplay -l
  • Copy name of your device to clipboard.
  • Now type: sudo nano /usr/bin/g12a_sound.sh
  • In the top of the script under the section where script tries to automatically detect card1 (ca. line 6-8) add: card1=“NAME_OF_YOUR_SOUNDCARD” (Ctrl+Shift+v to paste)
  • Ctrl + S to save and then Ctrl + x to exit nano editor
  • Now run /usr/bin/g12a_sound.sh again
  • Type: sudo systemctl enable sound --now
  • Reboot and pray!

@spikerguy thank you so much for the nice feedback!

Finally, it is only the typical “clone, make, sudo make install” which did not work in my first attempt because the makefile is written for cross compiling. I learned all of this with the help of your rtl8723du package. Thanks for that!

@rna in fact you are awesome! Thanks for telling us about box86 and the great step by step tutorial how to install it. I missed it before.
So I followed it and everything went well … except at the very end after starting Sketchup 7.1 and choosing the default view it stops with an error “Cannot find OpenGL” driver. What am I missing?

Glad that you make it! Welcome to Box86 World on Arm64…!!!

In case of sketchup, actually it’s super easy. The bug is in the sketchup itself, even if you installed sketchup 7.1 / 8 in Windows 7 above, you’ll get the same error.

You have to edit the wine regedit and change the display setting

  1. Open Sketchup then close
  2. Open terminal then run regedit by typing:
    schroot -c debian-armhf ~/box86/build/box86 ~/wine/bin/wine regedit
  3. Then find:
    HKEY_CURRENT_USER\Software\Google\SketchUp7\GLConfig\Display
  4. Then change the “HW_OK” from “0” to “1”
  5. Then close your regedit
  6. Then open Sketchup 7/8, you should be ok.

This fix also works for windows 7 above

Anyway, I have updated the topic in Armbian Forum including the Box86 compatibility list link. Feel free to re-read my update.

Hope that helps,
Many Thanks
rna

Followed your instructions and now Sketchup works. :grin:
Really impressive that such a low-power ARM box is capable of running such a program so smoothly! I never would have thought it to be possible …

Must have taken you many, many hours to figure out how to run box86 on ARM 64. Thanks you so much for your effort!!!

Yes, I also impressed with this low powered box to run sketchup so smoothly on LLVM pipe drivers. Have you tried to use Panfrost? I disable panfrost since it causes my box to hang everytime.

At the moment I’m struggling with making winetricks to work. I am able to use winetricks and install sketchup 2014 on Armbian Reforge. But I failed to use winetricks by using this chroot method. Still trying to figure it out. Help would be appreciated.

I already posted that in the armbian forum. Maybe somebody else could help to solve this issue, then we are almost very good to run almost every win32 apps on Arm64.

Actually the trials took me from june 2020 starting with Binfmt_misc & Qemu-user-static, which is not usable, here’s my story: How To Install Box86 on Manjaro Arm64

But luckily I found box86 which is way faster than Qemu. There you have it now

Yes, I used Panfrost. When you install mesa-git package you get mesa 21 develop version which is a lot lot better than mesa 20.3.
Supertuxkart and OpenArena are running smoothly. Also: turn off compositor in XFCE.

Is it stable now? or still sometime crashes?

What Manjaro Image do you use? which kernel?
What is the DTB that you use?

I am using linux-vim 5.10.5 kernel, unstable branch, XFCE

BTW @spikerguy I was building this image with the manjaro-arm tools yesterday and sound is working out of the box now. Great job!

It was unstable and crashing with vim kernel <= 5.9 but with 5.10 everything is rock solid!

My custom .dtb derived from meson-sm1-sei610.dtb.
@gausus just posted a version of this .dtb where ethernet speed is reduced to 100M (because he had problems with speed set to 1G). See post#640.

Hats off for being so persistent! :tophat:

1 Like

Thanks for this information. I’ll try to switch to Kernel 5.10 then.

Have you tried to open Blender 2.8+ using Panfrost? last time I tried with panfrost it failed to open, but using LLVM Pipe it opens but too laggy. It seems there’s something wrong with the OpenGL 3.2 in Panfrost Driver?

blender-2.7 is working well even when you set the renderer to Cycles.

Blender 2.8+ demands OpenGl 3.3 which is currently not supported by Panfrost. Some days ago I tried to overwrite GL_VERSION to 3.3 and start Blender 2.9 that way but it only showed a grey empty window.

I also think to remember that Mali G31 only supports OpenGl ES up to version 3.2. So the rest of the implementation would have to be software anyway. Don’t know what priority Blender 2.9 has on the Panfrost dev teams’ list. I guess they will focus their efforts on new Mali chips first to get them up and running before implementing features beyond OpenGl ES 3.1 (need to look up - I thought mesa 21 devel has support for 3.1 now and not 3.2).

Would be great to have a hybrid OpenGL driver that uses Panfrost as much as possible and falls back to LLVM for features not supported by Panfrost, yet.

Yes I also tried blender 2.7, I think it is ready for production using x96 Max+. Even on LLVM Pipe the performance is very smooth.

I also tried to install Blender 2.7 on Armbian Focal, but failed. Don’t know how to compile Blender 2.7 on Focal, whereas on AUR it’s quite easy on Manjaro side.

On Armbian Bionic it is easy to install Blender 2.7.

This can be a solution if it is possible in the future, I think LLVM Pipe is quite mature in terms of features compared to panfrost

Did you notice this thread about the problems to compile Blender 2.7 (even when using Manjaro) and possible solutions?

Edit: I meant blender-2.7-es which I am using. See posts at the end of the thread I linked to.

I just noticed this post just now. But in my case, Blender 2.7-es was broken I think since around 3-4 months ago, but the last update fix this issue on AUR (around 2-3 weeks ago).

I think I have an idea to compile Blender 2.7 easily on Ambian Focal / Manjaro by using chroot debian buster. The same way as the box86 procedure. Will let you know the update

UPDATE:
Yes I can confirm using chroot method can easily run Blender 2.79b on Armbian Focal / Manjaro

  • sudo schroot -c debian-armhf
  • apt install blender
  • exit

to run blender, simply use this command:

  • schroot -c debian-armhf blender

Now Blender 2.79b should run perfectly on Armbian Focal / Manjaro

Many Thanks to you, finally I solve this issue because of our discussion on Box86.
I added the Bonus in the tutorial to install Blender 2.79b using schroot debian buster

Is there a server-only version without a desktop that I can download to install on my Tanis TX3 TV box?

Where do I download it from?

Yes I can confirm, using manjaro unstable Kernel 5.10+ and mesa-git, Panfrost is very stable on Mali G31.

With compositor active, I got
glmark2 score : 53
glmark2-es2 score : 83

After switching off compositor, I got
glmark2 score : 54
glmark2-es2 score : 188

Have you tried using Armbian Kernel 5.10+? do you know how to upgrade to this kernel using our box image?