Manjaro arm on Amlogic Tv box?

Ugoos AM6 Plus?

1 Like



merry christmas to all of you guys :grin:

1 Like

Thank you! All the best to you as well @dante6913 and also all the best to the rest - especially to our fabulous Manjaro Arm team! Thank you so much for all your work and dedication and for making this forum a nice place to be!!!


Hello @tripole

I see that you have Ugoos AM6 Plus right ? or is it AM6 only ?

I have a new image for AM6 but I was not able to get Lan and wifi to work on it, I have a feeling that my device is a newer release board where the wifi is not detected at all while lan is detected but cannot establish any connection with the router.

Just want to check if everything works for you with am6 dtb while running it on am6-plus device.


Yes my box is an Am6 Plus (in Android dmesg it is reported as Meson chip version = RevB (29:B - 40:0)). On my box everything works (upgaded to 20.12 something with linux-vim kernel 5.9.8-2-MANJARO-ARM). (In order to get WiFi up I have to use the SDIO bus speed hack however, as descibed in the other TV-box thread. Without this hack, the mmc0 “card” (i.e. the WiFi chip in the AP6398S combo module) is not detected.)

It is quite possible that you can get eth0 up if you go to e.g. Network Manager (or ethtool) and force 100Mbit (full duplex should work). On my box I still have problems with 1Gbit and I have to use this fix. (It is a “classical” problem related to the dwmac/RTL8211/PHY stuff, apparently.)

Edit: Happy holidays, and I totally agree with what @TheMojoMan wrote above!

1 Like

Thank you for the Mini how to fix on ugoos am6 do you have any reference link where they talk about changing the sdio-clock-frequency ?

I will create a new dts for ugoos am6 plus.

I found the inspiration over at Khadas. (I think it was Hyphop who came up the idea, to solve a similar problem for for AP6398, on Khadas vim3 maybe?). Anyway, they later made a patch based on this idea to manipulate the clock frequency, and this patch was used on some Khadas kernels, like 5.9-rc2.) I also wrote a post about it over at Armbian forum (where they stealth-edited away my credits to Hyphop for the idea :smile:).

Edit: This problem is related to recent Linux kernels since on Android the SDIO bus runs at full speed (200Mhz?, I don’t remember, but I can check in the Android dmesg). Anyway, I seem to recall that there is a built in speed-cap (to 50MHz, I think) in (some newer versions of) the mmc driver. (I found some discussions about this over at the Linux kernel mailing lists but I haven’t saved any links, unfortunately.)

1 Like

I wish you all a merry christmas and a happy 5.10 kernel :laughing:. Have fun!

Hey @tripole

Have you tried using linux-vim-5.10.1 ?

No, and I’m still using the old boot loader. (I did try the new boot loader on that Spikerguy-test image you provided a few weeks back, and everything worked fine. However, after the test I switched back to my incrementally upgraded 20.06 (or something) image.)

Edit: I don’t know if your image had “the new” boatloader, but it was at least from that branch which uses extlinux.conf instead of uEnv.ini (which I have on my current image), if I recall correctly.)

Edit2: I just saw the Ugoos Am6 patch on your Gitlab page. Does it work also on the 5.10.y series?

1 Like

Merry Christmas and Happy New Year to everyone,

Need assistance.

Install new “boot-vim3-2020-09-1” earlier and just installed linux-vim 5.10.1-1 (replacing linux-vim 5.9.8-2) successfully. But does NOT boot up with new “boot-vim3-2020-09-1”.

[jfl@MNJROGTKPRO ~]$ sudo pacman -U
[sudo] password for jfl:
linux-vim-5.10.1… 45.5 MiB 857 KiB/s 00:54 [######################] 100%
linux-vim-5.10.1… 310.0 B 0.00 B/s 00:00 [######################] 100%
loading packages…
resolving dependencies…
looking for conflicting packages…

Packages (1) linux-vim-5.10.1-1

Total Installed Size: 74.80 MiB
Net Upgrade Size: -0.92 MiB

==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful

But does not Boot up just a blank screen after “Beelink Logo”. I have installed the new u-boot from " pacman -U " It boot up after installing this new u-boot (and edit the extlinux.conf) on linux-vim 5.9.8-2 but does not boot up after installing linux-vim 5.10.1-1.

Any suggestion how to recover.

Edit: Also tried this u-boot for_linux-vim-5101.tar — Yandex.Disk . With this u-boot it at least try to boot up to tty level and searching extlinux.conf and it tried to boot with odroidn2.dtb but never reach to meson-g12b-gtking-pro.dtb. Timeout at tty level. Did NOT succeed to boot up.

edit extlinux.config FDT
or change file.dtb

Yes, I did edti the extlinux.conf to reflect “meson-g12b-gtking-pro.dtb”. The new item I notice after upgraded from linux-vim 5.9.8-2 to linux-vim 5.10.1-1 is “INITRD /initramfs-linux.img” where usually it is “INITRD /uInitrd”.

LABEL Manjaro
LINUX /Image
INITRD /initramfs-linux.img

FDT /dtbs/amlogic/meson-g12b-gtking-pro.dtb
APPEND root=LABEL=ROOT_MNJRO rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

When I use the for_linux-vim-5101.tar — Yandex.Disk to boot I got this

But does not boot up with or without Ethernet connected.

I think the name uInitrd is typically used for u-boot compatible ramdisk images. Perhaps, the file initramfs-linux.img is a ramdisk file which is not in the right format? (I know that you know this, but still; in one of the last stages of the upgrade process for a new kernel (to be booted by u-boot) the post-install script converts the ramdisk image to u-boot format, and the result is uImage.) Just my 2 cents…

Edit: You can check what type of file the file initramfs-linux.img is like so (modify the path according to your location of the image):

$ file /path-to-image/initramfs-linux.img

On my box (when done “natively”) the result is the following:

$ file /boot/uInitrd
/boot/uInitrd: u-boot legacy uImage, uInitrd Image, Linux/ARM 64-bit, RAMDisk Image (Not compressed), 8477779 bytes, Wed Dec  9 10:53:22 2020, Load Address: 0x00000000, Entry Point: 0x00000000, Header CRC: 0xF8FB01EB, Data CRC: 0xC1E0DA81

Edit2: With the boot sequence with for_linux-vim-5101.tar — Yandex.Disk it looks that you are trying to do some form of netboot, if I read the picture correctly. Is this what you intend to do?

Need assistance to boot “H96Max RK3399”.
Which Image and dtb should I use?

Many Thanks

Looks like gtking pro dtb is missing can you check if it is present in your boot partition.

Indeed, initramfs-linux-img was created by the system during the last stage of installation of “linux-vim 5.10.1-1” which indicated it created the image successfully.

==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful

My Manjaro-ARM-VIM3-XFCE-linux-vim 5.10.1-1 is not booting up so I don’t think I can perform:

$ file /path-to-image/initramfs-linux.img

In the for_linux-vim-5101.tar there is a u-boot.ext file which both TheMojoMan and uropb were successful to boot linux-5.10.1-1 with this u-boot.ext from linux-vim-5101.tar. So I tried to use it (this u-boot.ext from linux-vim-5101.tar) to boot since the "u-boot.ext from “boot-vim3-2020-09-1” did not work.

May be the initramfs-linux.img was an incomplete image. I notice the “Image” and “Image.gz” are both modified on 12/19/2020 which is the Manjaro 20.12 Release date.

Not sure why “boot-vim3-2020-09-1” u-boot.ext did not work with linux-vim 5.10.1-1 (it should it is part of the Testing Branch updates with linux-vim 5.10.1-1.

The “boot-vim3-2020-09-1” u-boot.ext did work with linux-vim 5.9.8-2 and 5.9.12-3.

No idea as it depends on which sbc clone is present in that device.

You can try with rockpi4c if that doesn’t boot than rockpro64.

You are correct (I just check the dtbs folder), after installing linux-vim 5.10.1-1, meson-g12b-gtking-pro.dtb disappeared or deleted from the /BOOT_MNJRO/dtbs/amlogic/ most likely over-written by the linux-vim 5.10.1-1 installation. Will copy the “meson-g12b-gtking-pro.dtb” back into dtbs and reboot again.

Edit: For your information, I did make a copy of the Manjaro amlogic dtbs and found out that “meson-g12b-gtking-pro.dtb” and “meson-g12b-gtking.dtb” are NOT in the original Manjaro dtbs. It was in the Manjaro-ARM-VIM3-XFCE 20.12 Release. I don’t understand how it disappeared.

Edit 2:
Copied “meson-g12b-gtking-pro.dtb” to /boot/dtbs/amlogic. Use “boot-vim3-2020-09-1” u-boot.ext, does not seems to boot up (just black screen).

The extlinux.conf is as follows:
LABEL Manjaro
LINUX /Image
INITRD /initramfs-linux.img

FDT /dtbs/amlogic/meson-g12b-gtking-pro.dtb
APPEND root=LABEL=ROOT_MNJRO rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

Edit 3: Confirmed “boot-vim3-2020-09-1” u-boot.ext, does not boot.