Manjaro arm on Amlogic Tv box?

I’m having the same issue. I wasn’t able to boot my X96 air P3 S905x3 with any dtb :hot_face: in the 5.10.1-1 linux-vim

Great! :smiley:

I forgot to mention that I had to redo the procedure after reboot because sound was off again. To fix that problem you first have to turn sound on as described before and than open a terminal and type sudo alsactl store to make the changes permanent.

Seems that we have to wait for multiboot/u-boot.ext to be fixed for S905X3 …

Thank you for your work in making kernel 5.10 work on tv boxes.

Kernel 5.10 works on s912 and s905w, but not on s905x2 and x3.

Vim3.20.06 updated to unstable.

Works with u-boot-s905x-s912 renamed to u-boot.ext for S905w and S912

Does not work with
u-boot for S905x2 / 3

Tested on:
A95x for S905w meson-gxl-s905w-p281.dtb
M96X S912 meson-gxm-q200.dtb
X96s S905x2 meson-g12a-u200.dtb
X96 max + S905x3 meson-sm1-sei610.dtb

Its in unstable so please be patient and update fully or else it will break the system.

Unstable have boot-vim3-2020-09 which have chainloader and can not 5.10 without any issue.
5.10 is also in unstable so users will recieve it once it is available in stable.

Did you try the s905x3-s922x version and changed it to u-boot.ext ?

What do you do with these tv boxes? :o

Do you see uboot on hdmi output? Can you share details of where it gets stuck?

HI, all users!
My tvbox X96AirP2 (s905x3) boot with linux-vim-5.10.1

u-boot.ext and meson-g12a-x96-max.dtb i take from balbes150’s libreelec

(…-amlg12.img.gz) His img have kernel-5.10.1 and boot on my box.
No sound.
1 Like

Hello and welcome to the forum.

You have sound it is just not configured properly.

Try the Khadas-utils-4-1 from unstable.
sudo systemctl enable sound --now

If this doesn’t work then let me know, I think it is some alsa config issue with 5.10

linux-vim is balbes branch kernel so the dtb will be the same in libreelec and manjaro if you use linux-vim

I can see sound card detected fine by alsa you only need alsa config fixed.

Sound work with meson-sm1-sei610.dtb from chewitt’s libreelec (…-box.img.gz)
If anybody wont, u-boot.ext+meson-sm1-610.dtb at one place: for_linux-vim-5101.tar — Yandex.Disk


Hi Spikerguy,

Just downloaded and burn new Manjaro-ARM-VIM3-XFCE-20.12 on Beelink GT King Pro. Boot up with no issue. Kernel is linux-vim 5.9.8-2.

Just notice that the VIM3-XFCE-20.12 image size seems to be quite a bit larger than normal (941MB vs 839MB) and the u-boot still uses the uEnv.ini instead of the newer extlinux.conf method.

Thanks for the great work and support. Wish Manjaro Team and you A Merry Christmas and A Happy New Year.

Thanks :grinning:, now I can boot with 5.10 linux-vim, with u-boot.ext+meson-sm1-610.dtb the only issue now is I don’t have Ethernet

Edit: everything working with this u-boot and with meson-sm1-x96-max-plus.dtb
Ethernet and sound
Great thanks @spikerguy
Now lets try the mainline kernel

Another great thing I’m getting video hardware acceleration with mpv kernel-5.10.1, it seems that vdec driver is working now.
edit gui hardware acceleration on panfrost XFCE

Extended renderer info (GLX_MESA_query_renderer):
Vendor: Panfrost (0xffffffff)
Device: Mali G31 (Panfrost) (0xffffffff)
Version: 20.3.1
Accelerated: yes
Video memory: 3711MB
Unified memory: yes
Preferred profile: compat (0x2)
Max core profile version: 0.0
Max compat profile version: 2.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 2.0
OpenGL vendor string: Panfrost
OpenGL renderer string: Mali G31 (Panfrost)
OpenGL version string: 2.1 Mesa 20.3.1
OpenGL shading language version string: 1.20
OpenGL extensions:

is working, but when I open some windows I get some crashes

SuperTuxKart is working

Hi dante6913,

Does Panfrost work with linux-vim 5.10 kernel?

Ethernet still with 100MBit/s I assume?

yes is working, but with some errors when using the xfce windows.
With firefox is working fine for me. I was able to play supertuxkart and I didn’t notice any error.
So for desktop with some error it seems that is working on x11
Kodi is working with gui accelerated by panfrost, for video it says that is software accelerated but the video is working so smooth that it looks that is hardware accelerated by vdec?
Edit kodi is using software acceleration, I can see the difference when comparing with mpv with video hardware acceleration. So kodi needs to be compiled so that can uses vdec driver

From odroid forum about vpu decoding (video hardware acceleration vdec)

Re: Panfrost Status on Odroid N2

Post by chewitt » Thu Dec 10, 2020 10:01 pm

H264 is upstream and you can start playback but when the stream goes out of sync or your seek; it stalls and you often need to start over. HEVC is not upstream and works with 8-bit content but not 10-bit and has the same issues with seeking. FFmpeg is where the seeking issue needs to be fixed. Raspberry Pi Foundation are actively working on the changes needed to make this work with their H264 codec (Amlogic and Pi H264 are both stateful decoders and share a common code path) and I’m tracking the changes to give an additional angle on the work. Right now there is nice progress being made (seeking in H264 is not perfect but working well) but at some point soon there’ll be a need to make changes in the Amlogic H264 code which is not being actively worked upon (the guy who wrote it has been radio silent since March). On an N2/N2+ device you can software decode all 1080p content except files with exotic encodings or super-high bitrates but I think we’re a few months from where we want to be (at least with H264). The terrtiary challenge is; once we make it all work we need to tidy up the code and get it upstream, and that will take time and lots of iterations. Anyway… that’s the status.

These users thanked the author chewitt for the post (total 6):

istanbulls (Thu Dec 10, 2020 10:41 pm) • jonathon (Fri Dec 11, 2020 1:33 am) • odroidn2user (Fri Dec 11, 2020 4:26 am) • jgmdev (Sat Dec 12, 2020 1:55 am) • Sav (Sat Dec 12, 2020 9:01 am) • hjheins (Sat Dec 12, 2020 5:15 pm)


yes, there is no change on this dtb

well I’m going to try to ask here for help, since I used armbian and now manjaro I’m having an issue with my tv (where I have my tvbox) I get the right resolution 1360x768 @60 hz but the image is always 1 cm offset from the top. So I need to push the entire image 1 cm up to be matched with my tv. If I used other monitor it works correctly, so the issue is just with this tv. I already tried xrandr but for now without success. Does anyone have a clue how this could be solved?

Hi dante6913,
I have noticed a similart artifact on my (old) TV too. (On legacy kernels 4.9 the image is displayed correctly but not with any of the 5.x.y kernels: With the newer kernels I get a small strip of about 8px on top of my monitor the automatically detected 1360x768 60Hz mode.) You can follow the standard recipe and detect more modes like Armbian outlines and then add them manually as modelines in a file in /etc/X11/xorg.conf.d (All modes that are supported by the monitor can also be found e.g. in /var/log/Xorg.0.log. For me the best one, with the smallest strip at the top, is a 1368x766 mode that I found this way.) Edit: These problems/solutions of mine are identical regardless of distro; Armbian, Khadas/Debian or Manjaro so I concluded it was the kernel.

1 Like

Great, that u-boot.ext did the trick for booting (the 5.10 vim kernel). Thanks a lot!

(And as described before by @dante6913 sound and ethernet works with meson-sm1-x96-max-plus.dtb and Panfrost driver does not crash anymore with vim kernel :grinning: )

1 Like

I have same issue. I don’t know how to resolve so I do with 1024x768 that fits well. Maybe adding a new resolution with changed size in mm? Other than the CVT one I mean.

Thanks a lot. My TV box (A95x F2) is working on Linux 5.10 thanks to your link. Where does it come from?

Now testing time :smile:


Wow like a stone. I can not freeze it. 5 mpvs playing and no freezing. Firefox without a problem. It’s the first time the box gets some temperature.

Good to know that Panfrost is now working with both linux-vim 5.10 and linux-5.10 on Bifrost G31. I am now back on Stable Branch with Manjaro-ARM-VIM3-XFCE-20.12 (linux-vim 5.9.8-2) as my previous Testing Branch crashes during a system updates (Kernel Panic) and corrupted the USB Drive.

Looking forward to test linux-vim 5.10 or linux 5.10.