Manjaro arm on Amlogic Tv box?


Thanks. Just burn the image to new acquired 64GB USB 3.0 Stick. Noticed there are 4 u-boot files.

I have edited the extlinux file to reflect meson-g12b-gtking-pro.dtb. Do I have to rename anything on u-boot? Example u-boot-s905x2-s922 to u-boot.ext which already exist.

Edit: Figured that u-boot.ext is not empty, I just boot it after editing extlinux. Able to boot up to enter all the user name, etc and system reboot KDE login screen. After entering password. Just Black Screen! Is there anything that I need to do?

Edit 2: Turn Off and On again. At KDE Greeter Screen, I notice at the bottom left side Session: Plasma (wayland) as default which is what I tried the first time and just a black screen after keying in password.

This time around (second boot up), I selected Session: Plasma and was successful in starting the session in Plasma. Just did a System Information.
KDE Plasma Version 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.9.0-2-MANJARO-ARM
QS Type: 64-bit

Just for your info the kernel version is stated as 5.9.0-2 not 5.9.8-1. I notice there seems to be screen flashing artifacts occurring more frequently compared to Manjaro_Xfce on linux-kernel 5.9.9-2.

Wifi is available on start up (NetworkManager.service is enable on start-up and the wireless drivers are available for GT King Pro). No sound available start up “Dummy Output”.

Edit: Will try the following to see whether I will get sound.
[jfl@GTKPro ~]$ sudo chmod a+x /usr/bin/

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for jfl:
[jfl@GTKPro ~]$ systemctl enable sound --now
Created symlink /etc/systemd/system/sound.service → /usr/lib/systemd/system/sound.service.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/sound.service.
[jfl@GTKPro ~]$ sudo reboot

Edit 2: Tried Session: Plasma (wayland) login again. Does not work, just Black Screen. Need guidance what need to be set up to be able to login to Plasma (wayland).

Restart and login in to Session: Plasma. Sound is now available after the above running the above bash and commands and reboot. The flash screen artifacts seems very frequent.

1 Like

You don’t need to do this.
Just starting the sound service will do the work.

Thanks for the details information, yes plasma Wayland was set as default which doesn’t work without panfrost.

Then 5.9 8 is still in testing branch sorry.

This graphical glitche is present since the beginning on all the s922 boards I am not sure of any developer is looking into it, if you change the resolution to something smaller then it might get reduced but it is always there.

Thanks for trying the image.

Sorry for being such a noob, but I’m not familiar with the structure of the forum. Where are the links of your images?
Edit sorry I notice that you posted the link, I thought there a section in the forum with the images

The graphical glitches went away on Ugoos once I switched to fixed cpu frequency (by setting the governor to performace, see my posts above) and my system became …stable… aaah.

Edit: I have been running a recent (manjaro-arm-tools) image (with kernel 5.9.0-2) for about two days without a single problem, no glitches, no freezes.

You can find it here (I renamed it to meson-sm1-x96maxplus.dtb):
Click on ‘download’ button on the left of the screen.

1 Like
  • I used to be able to boot my X96Max+ with meson-sm1-sei610.dtb when using linux-vim kernel. This does not work anymore with the new image.
  • Instead I can boot using the modified .dtb that I created for running linux kernel.
  • Ethernet is working.
  • Soundcard is recognized but no sound via HDMI.
  • German keyboard layout is not working. I have selected ‘German’ in KDE settings and pressed ‘Apply’ but keyoard layout is not switched (even after reboot).

Will do some further testing later. Thanks for your great work so far @spikerguy!

1 Like

Hi Spikerguy,

Thanks for the clarification. Appreciate if you can guide how I can logon to Plasma Wayland session. I don’t seem to be able to login to Plasma Wayland. What do I need to install or set up to be able to login to Plasma Wayland?

Thanks TheMojoMan I will try it tonight when I’m home.

Sorry, did not catch this part earlier. Is linux-vim kernel 5.9.0-2 stable with Panfrost? You did indicated earler kernel 5.9.0 wasn’t and linux-vim kernel 5.9.8-1 is also not stable with Panfrost, Any changes to linux-vim kernel 5.9.8-1 being stable with Panfrost?

Just enquire, if you install cpupower
pacman -S cpupower
set it to performance “sudo cpupower frequency-set -g performance”
systemctl enable cpupower --now

  1. Does it heat up the Unit since it is always running at highest frequency

The only difference it would make would be when the box is idling (or low load), but I haven’t really seen any difference (perhaps a few degrees higher idling temp with governor set to performance).

In order to make the selection of governor be persistent across reboots you must also edit /etc/default/cpupower (only one line needs edit).

Edit: You can also fiddle with the settings of the governor (see /etc/default/cpupower) so that the CPU(s) run at a constant frequency, but not necessarily the maximum that the chip(s) support. (My Ugoos is also currently frequency capped since the dtb doesn’t exactly match my particular version of the Ugoos, which in fact supports higher clocks than specified in the dtb.)

dmesg output on Panfrost,
[ 4.573519] panfrost ffe40000.gpu: clock rate = 24000000
[ 4.575344] panfrost ffe40000.gpu: supply mali not found, using dummy reg
[ 4.582784] panfrost ffe40000.gpu: mali-g52 id 0x7212 major 0x0 minor 0x0
status 0x0
[ 4.590230] panfrost ffe40000.gpu: features: 00000000,13de77ff, issues: 0
[ 4.598348] panfrost ffe40000.gpu: Features: L2:0x07110206 Shader:0x00000
000 Tiler:0x00000809 Mem:0x1 MMU:0x00002830 AS:0xff JS:0x7
[ 4.610061] panfrost ffe40000.gpu: shader_present=0x3 l2_present=0x1
[ 4.617461] panfrost ffe40000.gpu: error powering up gpu L2
[ 4.622928] panfrost ffe40000.gpu: error powering up gpu shader
[ 4.628866] [drm] Initialized panfrost 1.1.0 20180908 for ffe40000.gpu on

Notice Panfrost error powering up gpu L2 and power up gpu shader when using the “meson-g12b-gtking-pro.dtb” that came with the this image. I have notice the “meson-g12b-gtking-pro.dtb” from Manjaro_Xfce_ Mainline linux-kernel 5.9.6-1 or 5.9.9-2 size is slightly different that KDE_VIM3 with linux-vim kernel 5.9.0-2. If I am not mistaken the "meson-g12b-gtking-pro.dtb from linux kernel 5.9.6-1/5.9.9-2 does not have the panfrost gpu error: powering up gpu L2 or error powering up gpu shader.

Will confirm shortly.

Edit: The Manjaro_VIM3_Xfce_ linux-kernel 5.9.6-1, dmesg output on Panfrost does not have Panfrost gpu powering up error.

rc rc0: meson-ir as /devices/platform/soc/ff800000.bus/
[ 7.353950] mmc2: queuing unknown CIS tuple 0x81 (9 bytes)
[ 7.373049] panfrost ffe40000.gpu: clock rate = 24000000
[ 7.373555] panfrost ffe40000.gpu: supply mali not found, using dummy regulator
[ 7.373808] panfrost ffe40000.gpu: mali-g52 id 0x7212 major 0x0 minor 0x0 status 0x0
[ 7.373811] panfrost ffe40000.gpu: features: 00000000,13de77ff, issues: 00000000,00000400
[ 7.373815] panfrost ffe40000.gpu: Features: L2:0x07110206 Shader:0x00000000 Tiler:0x00000809 Mem:0x1 MMU:0x00002830 AS:0xff JS:0x7
[ 7.373818] meson-vrtc ff8000a8.rtc: registered as rtc0
[ 7.373820] panfrost ffe40000.gpu: shader_present=0x3 l2_present=0x1
[ 7.373853] meson-vrtc ff8000a8.rtc: setting system clock to 1970-01-01T00:00:07 UTC (7)
[ 7.381987] meson-drm ff900000.vpu: Queued 3 outputs on vpu
[ 7.382168] meson_vdec: module is from the staging directory, the quality is unknown, you have been warned.
[ 7.383008] rc rc0: lirc_dev: driver meson-ir registered at minor = 0, raw IR receiver, no transmitter
[ 7.383097] input: meson-ir as /devices/platform/soc/ff800000.bus/
[ 7.387246] audit: type=1130 audit(7.510:6): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg=‘unit=systemd-networkd comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
[ 7.390619] meson8b-dwmac ff3f0000.ethernet: IRQ eth_wake_irq not found
[ 7.390628] meson8b-dwmac ff3f0000.ethernet: IRQ eth_lpi not found
[ 7.390799] meson8b-dwmac ff3f0000.ethernet: PTP uses main clock
[ 7.393755] [drm] Initialized panfrost 1.1.0 20180908 for ffe40000.gpu on minor 0
[ 7.399753] meson-ir receiver initialized
[ 7.422174] meson8b-dwmac ff3f0000.ethernet: User ID: 0x11, Synopsys ID: 0x37
[ 7.426008] meson8b-dwmac ff3f0000.ethernet: DWMAC1000
[ 7.426019] meson8b-dwmac ff3f0000.ethernet: DMA HW capability register supported
[ 7.426021] meson8b-dwmac ff3f0000.ethernet: RX Checksum Offload Engine supported
[ 7.426026] meson8b-dwmac ff3f0000.ethernet: COE Type 2
[ 7.426028] meson8b-dwmac ff3f0000.ethernet: TX Checksum insertion supported
[ 7.426030] meson8b-dwmac ff3f0000.ethernet: Wake-Up On Lan supported
[ 7.426129] meson8b-dwmac ff3f0000.ethernet: Normal descriptors
[ 7.426132] meson8b-dwmac ff3f0000.ethernet: Ring mode enabled
[ 7.426135] meson8b-dwmac ff3f0000.ethernet: Enable RX Mitigation via HW Watchdog Timer
[ 7.426852] libphy: stmmac: probed
[ 7.430215] mmc2: new high speed SDIO card at address 0001
[ 7.432487] libphy: mdio_mux: probed
[ 7.459732] Bluetooth: Core ver 2.22
[ 7.459765] NET: Registered protocol family 31
[ 7.459766] Bluetooth: HCI device and connection manager initialized
[ 7.459777] Bluetooth: HCI socket layer initialized
[ 7.459781] Bluetooth: L2CAP socket layer initialized
[ 7.459788] Bluetooth: SCO socket layer initialized
[ 7.474199] meson-dw-hdmi ff600000.hdmi-tx: Detected HDMI TX controller v2.01a with HDCP (meson_dw_hdmi_phy)
[ 7.474546] meson-dw-hdmi ff600000.hdmi-tx: registered DesignWare HDMI I2C bus driver
[ 7.475522] meson-drm ff900000.vpu: bound ff600000.hdmi-tx (ops meson_dw_hdmi_ops [meson_dw_hdmi])
[ 7.476031] [drm] Initialized meson 1.0.0 20161109 for ff900000.vpu on minor 1

Edit2: Interesting, if transfer the Manjaro_VIM3_Xfce linux kernel 5.9.9-2 "meson-g12b-gtking-pro.dtb’ over to Manjaro-ARM-kde=plasma-vim3-22-11-2020.img.xz the same Panfrost error powering up gpu L2 and error powering up gpu shader where as it does give any Panfrost error in Xfce. Wonder why?

If I use the Armbian “meson-g12b-gtking-pro.dtb” on Manjaro-ARM-kde=plasma-vim3-22-11-2020.img.xz, NO Panfrost error.

Can you share the command you used? Is it cpu frequency or gpu ?
Currently we use OnDemand as default cpu governor, If you think performance will fix the graphical glitch then I can test it and then with new kernel we can user performance mode as anyways amlogic soc doesn’t really get hot and doesn’t consume much power.

I would suggest not to use it until we have stable panfrost as wayland will result into black screen for now.

Everything is already present except for panfrost support :stuck_out_tongue:

No Not to get your hopes high but this is a a kernel from custom branch which have something extra which is causing panfrost unstability.

@spikerguy Yes, on my Ugoos (AM6 plus) it definitely fixes both problems (glitches, freezes) and makes the box completely stable (yay!). I did like this. (It is cpu frequency.)

If I use this command " echo performance >/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor" and reboot if will boot up in “performance” mode?

No. That does not survive a reboot. You must do like I outlined here (i.e. edit a conf. file) (and enable the cpupuwer systemd service, if you have not do so already.)

Edit: I could of course have formatted this post better, but all the info is there.

P.S. Fiddling with the /sys/devices/… variables must be done as root (or using sudo).

echo performance >/sys/devices/system/cpu/cpu0/cpufreq/scaling_go
bash: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Permission denied

-> FIXED: I was using the wrong .dtb file.

-> Only a problem when using Wayland, no problem with Plasma.

Just installed “cpupower” using Package Manager.
Synchronizing package databases…
Warning: boot-vim3: local (2020.09-1) is newer than core (2020.05-1)
Resolving dependencies…
Checking inter-conflicts…
Downloading cpupower (5.9-1)…
Checking keyring…
Checking integrity…
Loading packages files…
Checking file conflicts…
Checking available disk space…
Installing cpupower (5.9-1)…
Running post-transaction hooks…
Reloading system manager configuration…
Arming ConditionNeedsUpdate…
Transaction successfully finished.

[jfl@GTKPro ~]$ sudo cpupower frequency-set -g performance
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
Setting cpu: 4
Setting cpu: 5
[jfl@GTKPro ~]$

[jfl@GTKPro ~]$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

[jfl@GTKPro ~]$ systemctl enable cpupower --now
Created symlink /etc/systemd/system/ → /u

Is there anything else I need to edit to ensure it boot up as “performance” mode? Somehow I am not clear. Sorry to trouble you and your patience.

There seems to be NO more screen flashes or glitches for the past 10 minutes! TQ
But just as open up two more tabs on Firefox, encountered the first Kernel Panic on my GT King Pro. So the “cpupower performance” setting seems to solve the Manjaro-ARM screen glitches or flashes but it does not the Kernel Panic on GT King Pro.

It seems linux kernel 5.9.9-2 is more stable than linux-vim kernel 5.9.0-2 at least on my GT King Pro so far (just a perception).

Also this is good news. I think it shows that the problem with graphics glitches can be fixed by setting a fixed (high) cpu frequency, and that this works (well, might work) for several boxes/platforms. At the same time, I think we know by now that (at least some of) the kernel panics require a special fix for some boxes (e.g. GTKing Pro). Still, progress, I think.

P.S. In order for this work across reboots you must edit the conf file /etc/defaults/cpupower (and edit the line with governor=…stuff…). It must be uncommented, too.