Manjaro arm on Amlogic Tv box?

Hi spikerguy thank you
I tried from the top link
Is it the wrong link? I will wait for your image, it would be great to use dual boot in my s905x3 box.
Thanks for your time

@dante6913 Hi, I think that the link you posted goes to an image of mine, which is unofficial (so use at your own risk). I have put up also a newer image that I’m running now, see this post (with the same disclaimer).

Hi tripole
The issue that I have is that I couldn’t try it because I always get
" Temporarily Unavailable

The file you are looking for is temporarily unavailable due to maintenance!

Don’t worry! Check back later and it will be available again!"

I never used any Arch based distribution so every thing is a little confusing, but at same time I think that will be fun to get out from debian based distributions

The link in the newer post (in the message just above) worked for me, just now.

thanks tripole the one that you posted is working for me, now I’m downloading.
But is different from the one I tried
Manjaro-ARM-xfce-vim3-201117-3pole.img.xz - AnonFiles your link the one on the top post

Yes, they are different; the one you are downloading now (the one labeled …-3pole.img.xz, I hope) is a newer version. Both images are built with the official Manjaro ARM build environment (manjaro-arm-tools) according to this post (but, of course, by some random guy on the internet; me).

Thanks, I will try it and I will come back with my feedback and doubts!

1 Like

OK first impressions with my X96 air s905x3
Installed and booted with the toothstick with meson-sm1-sei610.dtb. No ethernet and no sound. I enabled sound and network manager following tripole instructions.
Ethernet didn’t work so I tried with meson-g12a-sei510.dtb as said by TheMojoMan, but again after reboot still didn’t work. I remembered that with Balbes images we had to change meson-sm1-sei610.dtb to be able to use ethernet so I used the changed dtb “meson-sm1-sei610-ethfix.dtb”, the I was able to boot and the Ethernet worked.
The sound from the box didn’t work but I didn’t lose anytime with it, I used my fiio usb dac, that worked.
I enable ssh and I did a uname -a I got 5.9.0-2-MANJARO-ARM kernel. So for now I’m looking to update the kernel. So is possible to update the kernel?
Sorry for my English, is not my first language.

It is indeed possible to change kernel, I refer you to JFL and TheMoJoMan (in this thread and other threads on e.g. Panfrost), they have done a lot of experimenting. (I think also that TheMojoMan has similar hardware as you have, if I remember correctly.) As for the sound, yes this is tricky (fiddling with dtb to get the h/w properly detected) but I just noticed that the VIM3L h/w seems to be similar to your box, at least according to this link so perhaps you could try meson-sm1-khadas-vim3l.dtb ?

Edit: Of course, it is only reasonable to hope to get the digital sound working.

Hi dante6913,

I am new to linux and Manjaro so I use the easy way, Package Manager to update the linux kernel. Start up Package Manager, search for “linux” you will be able to see what linux kernel or linux-vim kernel are available for you to install. Select the linux kernel you want and click “Install” and “Apply”. That is all it takes.

meson-sm1-khadas-vim3l.dtb didn’t boot, but I saw TheMoJoMan post reference to meson-sm1-sei610-2.dtb and that solved the issue. So for x96 air meson-sm1-sei610-2.dtb is the way to go for sound and Ethernet.
JFL I’m going to try now.
Thanks you all

1 Like

I updated to kernel 5.9.6-1 but I can only boot now with meson-g12a-sei510.dtb but with this dtb I don’t have Ethernet so I can’t do anything anymore.
TheMojoMan did you tried 5.10 rc2? Doe Ethernet work?

Hi TheMojoMan can you share your modified meson-sm1-sei610-2.dtb for be able to boot with kernel 5.9.6-1?
I tried to change the dtb converting to dts, but after changing the dts Iḿ not able to covert to dtb (FATAL ERROR: Unable to parse input tree)
Thanks in advance

Do not try 5.10 as there is no text offset anymore so it will never boot on any device with Android bsp uboot.

I am currently uploading a new image with new boot script which should work better but won’t change any of the issues that are caused by difference in dtb.
Will upload the link once it is fully uploaded.


Thanks spikerguy

Hi Spikerguy,

This means many Android TV Boxes will not be able to upgrade to kernel 5.10 including Beelink Android TV Boxes. Your new image with new boot will allow it to work on kernel 5.10 is that what you meant?

Yes all the Amlogic boards but there is a way to make it boot which is a legacy method adviced by the kernel developers.

Latest Manjaro-Vim3-22-11-2020 image

Please try and report back, as I have not tested this image cause I don’t have android on emmc.

I suppose the new image is with kernel 5.10, does image fit in 8GB USB Stick? That is all I have currently to try it out.

No 5.9.8-1

Yes will do.


Thanks. Just burn the image to new acquired 64GB USB 3.0 Stick. Noticed there are 4 u-boot files.

I have edited the extlinux file to reflect meson-g12b-gtking-pro.dtb. Do I have to rename anything on u-boot? Example u-boot-s905x2-s922 to u-boot.ext which already exist.

Edit: Figured that u-boot.ext is not empty, I just boot it after editing extlinux. Able to boot up to enter all the user name, etc and system reboot KDE login screen. After entering password. Just Black Screen! Is there anything that I need to do?

Edit 2: Turn Off and On again. At KDE Greeter Screen, I notice at the bottom left side Session: Plasma (wayland) as default which is what I tried the first time and just a black screen after keying in password.

This time around (second boot up), I selected Session: Plasma and was successful in starting the session in Plasma. Just did a System Information.
KDE Plasma Version 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.9.0-2-MANJARO-ARM
QS Type: 64-bit

Just for your info the kernel version is stated as 5.9.0-2 not 5.9.8-1. I notice there seems to be screen flashing artifacts occurring more frequently compared to Manjaro_Xfce on linux-kernel 5.9.9-2.

Wifi is available on start up (NetworkManager.service is enable on start-up and the wireless drivers are available for GT King Pro). No sound available start up “Dummy Output”.

Edit: Will try the following to see whether I will get sound.
[jfl@GTKPro ~]$ sudo chmod a+x /usr/bin/

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for jfl:
[jfl@GTKPro ~]$ systemctl enable sound --now
Created symlink /etc/systemd/system/sound.service → /usr/lib/systemd/system/sound.service.
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/sound.service.
[jfl@GTKPro ~]$ sudo reboot

Edit 2: Tried Session: Plasma (wayland) login again. Does not work, just Black Screen. Need guidance what need to be set up to be able to login to Plasma (wayland).

Restart and login in to Session: Plasma. Sound is now available after the above running the above bash and commands and reboot. The flash screen artifacts seems very frequent.

1 Like