Manjaro ARM (KDE) gets stuck while booting on my Raspberry Pi 3 B+

kde
arm
manjaroarm

#1

hello everyone. i tried to install manjaro arm on raspberry pi 3b+ using etcher. I downloaded the image (kde) from the official website and burnt it to my formatted usb drive using etcher. when i boot it up , it succesfully starts but it gets stuck on fb: switching to vc4dfrmb from simple. i left it on all night but in the morning its still stuck. how do i fix this?


#2

i’ve never used arm with any linux, are you sure you downloaded the actual ARM release of manjaro and not the x64 one?


#3

Yes i got it from manjaro-arm website


#5

i believe @Strit is the ARM guy, have you read through https://forum.manjaro.org/c/manjaro-arm for similar issues? sorry i cant be of more help but like i said, i know nothing about ARM/linux.


#6

How are you plugging in the monitor?
With a HDMI to HDMI cable or a HDMI to DVI cable?

I’ve had similar issues when using HDMI to DVI cables.

PS: Moved to ARM category.


#7

I used Hdmi To Hdmi Cable @Strit


#8

Hm, can you try with another cable?
Like a high quality one?

Also, confirm that the rpi is actually booted by connecting via SSH.


#9

@Strit an you explain how to connect it to a ssh( im a newbie)
Also can you post what a high quality cable looks like (i thought they were all the same)


#10

Turn on the rpi3 and plug in an ethernet cable from the router.
Then from your desktop, run the following command:
ssh manjaro@<IP of rpi>
If it’s booted, it will ask for the password for manjaro user, which is manjaro by default.

A high quality HDMiIcable are usually gold on the inside (the connectors themselves).


#11

ok ill try and i will infrom you . Thanks @Strit


#12

I tried high speed hdmi cable but there is no differnce @Strit


#13

Ill try ethernet. ill post by tommorow @Strit


#14

Hi @Strit I connected ethernet cable to my Rpi while Manjaro Started up and the issue seems to be resolved as it didn’t get stuck there. I encountered another issue though. It said “failed to load regulatory.db”. How do i fix this?


#15

According to this post it should not be anything to worry about. Sounds like left over kernel code from pre-4.15 days.