Manjaro ARM for Pinebook (preview3)



Ah I see your meaning now.

Question is then, what is the difference of Manjaro and Manjaro-ARM’s dbus daemon control?


actually you said you had problem with timedatectl above.
the dbus interface is the same as timedatctl but by using dbus if if I’m not wrong.


Yep. It’s actually not a problem with Manjaro Settings Manager.

So must be some underlying permission issue.


I can’t run any localectl commands either. These commands are provided by systemd itself. I have no intention of maintaining systemd on my own, but I guess I will have to, if that’s how Manjaro does this.

But I wonder how it is done on Arch…


I have one question.
Why is the Wifi driver used 8723cs but in the Pinebook Wiki it says the Wifi is 8723bs ?

Could that make a difference? My Wifi stability on battery is still a bit so so. Usable but with some breaks.


8723bs is merged into the kernel, but it is not recognised on the pinebook. So rtl8723cs is used, because that is actually seen.


As the Wifi works fine with A/C power but is a bit so so on battery I am suspecting the power management a bit.

I have tried to turn power management off for wifi and found this parameter fwlps=0 that I have added to 8723cs.conf:

options 8723cs rtw_initmac=00:ba:fe:33:92:46 fwlps=0

It seems not to work though, or not to help. Do you have a solution for the Wifi on battery ?


Try disabling tlp


Seems this comes along great. As each hardware project, it is hard to pull it off. But it seems we have support directly from @PINE64 which is great. Keep me in the loop on this project.


It got me thinking when I wanted to find out what tlp means.
I have learned now that you get the full list of parameters for a module with e.g. modinfo 8723cs

With that I found the parameter rtw_power_mgnt and that set to 0 (zero) it now seems to work better. My original parameter was completely wrong, it seems

So the full line with my MAC is:

options 8723cs rtw_initmac=00:ba:fe:33:92:46 rtw_power_mgnt=0

I have only tested it for the last hour but so far, no connection loss.
There are also many many other parameters, so maybe a better solution than turning power management completely off for wifi can be found. I will test now a bit longer…


Let me know if this fixes it. I can then fix that at the next release. :slight_smile:


Hi @Strit .

So I have tested Wifi with the power management parameter and it works nicely.
No drop of connection so far. I have not experienced differences in battery life, but that might need more time.

I make a list here of all the smaller changes I did in the last days for the LXQt version to improve on some of the niggles.

  1. Wifi
    Set rtw_power_mgnt=0 in /etc/modprobe.d/8723cs.conf

  2. Keyboard

  • To get the key between LShift and Z working correctly set the keyboard variant to English (intl, with AltGr dead keys)
  • I think the SUPER/META key is very useful but I also learned to like the MENU key that is mapped in the pinebook between FN and Alt. So I suggest the following mapping: MENU -> META, CapsLock to MENU.
setxkbmap -option caps:menu,altwin:alt_super_win

I have added this to .bash_profile but I am sure there is a better more Xorg like way. Still, it works.

  1. Touchpad

To set reverse scrolling for the touchpad use this command

xinput set-prop 7 "libinput Natural Scrolling Enabled" 1

again in .bash_profile

  1. Bluetooth
    To get bluetooth working I installed these packages and used bluetoothctl to set it up for an external keyboard and loudspeaker. Works but the setup took a moment.
  • bluez-utils
  • pulseaudio-bluetooth

This guide in the Archlinux Wiki was helpful.

  1. Font size and adoption to high(er) resolution display
  • LXQt Setting Appearanc: set Font Point size to 12
  • LXQt Setting Appearanc: Resolution (DPI) to 120
  • LXQt Setting Openbox: Font: Add 1 to all font sizes to 11 11 10 10 10 10
  • Firefox: In about:config set layout.css.devPixelsPerPx = 1.4
  • Firexox: In Preferences:Font:Advanced set Minimum fot size to 16
  1. LXQt shortcuts to support window management

All these changes require that the META key is available and mapped as described in 2) The following mappings are inspired by some windows functionality and also a lot from tiling WMs. This setup was so useful that for the moment I stopped using a tiling wm.

So to start I have activated 4 desktops in the openbox settings.

In LXQt Settings -> Shortcuts I have added these keybindings:

desciption key
Move to desktop 1 META + 1
Move to desktop 2 META + 2
Move to desktop 3 META + 3
Move to desktop 4 META + 4
Open Terminal META + Enter
Open Runner to start programme META + Space
  1. Openbox shortcuts for window management

This part of the openbox configuration should be added to file: .config/openbox/lxqt-rc.xml behind all other <keybind> and before </keyboard>

The following keybindings get implemented:

desciption key
Move window to desktop 1 META + Shift + 1
Move window to desktop 2 META + Shift + 2
Move window to desktop 3 META + Shift + 3
Move window to desktop 4 META + Shift + 4
Maximise window META + Arrow Up
Unmaximise window META + Arrow Down
Move and resize window to left half of the screen META + Arrow Left
Move and resize window to right half of the screen META + Arrow Right
Maximise only vertically (max upper and lower display edge META + Fn + Arrow Up (PgUp)
Maximise vertically and increase size horizontally META + f
Center window META + c

This is the config:

    <keybind key="W-S-1">
      <action name="SendToDesktop">
    <!-- Keybinding to move window to desktop 2 -->
    <keybind key="W-S-2">
      <action name="SendToDesktop">
    <!-- Keybinding to move window to desktop 3 -->
    <keybind key="W-S-3">
      <action name="SendToDesktop">
    <!-- Keybinding to move window to desktop 4 -->
    <keybind key="W-S-4">
      <action name="SendToDesktop">
    <!-- Keybinding to maximise window-->
    <keybind key="W-Up">
      <action name="Maximize"/>
    <!-- Keybinding to unmaximise window -->
    <keybind key="W-Down">
      <action name="Unmaximize"/>
    <!-- Keybinding to move window to the left or right half of the desktop -->
    <keybind key="W-Left">
      <action name="UnmaximizeFull"/>
      <action name="MaximizeVert"/>
      <action name="MoveResizeTo">
      <action name="MoveToEdge">
    <keybind key="W-Right">
      <action name="UnmaximizeFull"/>
      <action name="MaximizeVert"/>
      <action name="MoveResizeTo">
      <action name="MoveToEdge">
    <!-- Keybinding to maximise the window to the top and bottom but leave the width as is-->
    <keybind key="W-Prior">
      <action name="MoveResizeTo">
        <!-- adjust a window's height and width -->
        <!-- <width client="yes">2/3</width> -->
    <!-- Keybinding to maximise the window to the top and bottom -->
    <keybind key="W-f">
      <action name="MoveResizeTo">
        <!-- adjust a window's height and width -->
        <width client="yes">3/4</width>
    <!-- center the window on the first monitor -->
    <keybind key="W-c">
      <action name="MoveResizeTo">


Already added to be included in next release.

So far I added the keyboard variant. Did not add the -option yet. But I could include it also in next release.

Touchpad scrolling works the same as it does in regular Manjaro, so I will keep it that way I think.

Nice one. Will be present in next release. Does this include an applet/widget for lxqt panel?

I feel the current settings fit the 1080p screen nicely. This is a personal preference.

I don’t think I will add multible virtual desktops to the setup.
But I should add key bindings for the terminal and runner ones.

Thanks. I will add these too.


Regarding a bluetooth app for the tray.
I had a quick look and it seems for the time beening the LXQt team recommends in a discussion in October blueman an gtk3 app.

I have installed it and with dependencies it came to ~20 MB install size. I might be worth testing if this is the same with a fresh image.

In a short test it worked and the UI is simple and beginner friendly. Very much in difference to the cli tool bluetoothctl that I had used before.


Yeah. Sad that there is no QT bluetooth applet at all, except the KDE one.

I was glad that I found nm-tray which is a better QT network applet.


Some LXQt developer seem to be very fond of ConnMan as network manager, but for me nm-tray is also fine.


I find the best way to augment FF for hidpi or otherwise is using:
layout.css.devPixelsPerPx (i have mine set to 1.25 … but ymmv)


I installed manjaro arm KDE preview 3 on my pinebook from sd to 64 gb emmc using ethernet usb dongle.

Goes ok.

Using chromium without tweaks instead firefox goes very very good! :stuck_out_tongue:

A sample video test here


you should have recorded in the other side with your phone. :wink:


I have only tested using the SD card, so glad to hear that it works on the eMMC too.