Manjaro ARM for Pinebook (preview3)

preview
release
manjaroarm
pinebook

#41

Soooo. I tried the same and sound is working out of the box.
Wifi is working well on battery so far

I have no idea what problems my first copy has, but it seems to not a general problem with the image.
Very cool.

EDIT:
I have now found a lead why there was no sound. With the original manjaro user sound works. I have then created a new user and added it to the same groups as manjaro and sound does not work anymore. I have to look into that a bit more…


#42

Ah, I wonder if that’s my problem! I did the same thing: created a new user, deleted Manjaro user, changed root password.


#43

The manjaro user has some systemd scripts in .config/systemd
The scripts deal with pulseaudio etc…
Should be easy to fix now… Tomorrow :smile:


#44

Yeah. I pulseaudio is a user service, so it can’t be run system wide.
So if you create a new user, you have to start/enable the service with:
systemctl --user start|enable pulseaudio.service

This is done for the manjaro user on image creation.


#45

@Strit
not releated to pinebook.
is all the packages from manjaro x86 are in manjaro arm?


#46

No. Some packages would not make sense, like mhwd.


#47

I do wish, however, that some AUR packages would cross-compile. Particularly this one. It doesn’t seem like Plasma widgets should have trouble, particularly if they’re c++ and QT. For example, this one compiled and works perfectly on the Pinebook.


#48

It builds fine for me, when I add the correct architecture to the arch=('aarch64') field in the PKGBUILD.


#49

Wow; cool! So the issue is we need to train PKGBUILD maintainers to add ARM architecture to their packages. :wink:

I learn something new every day coming here.


#50

Well yeah, but it’s up to the individual maintainers if they want to “support” ARM.


#51

Sorry for the delay, @hfw
Pinebook 1080 refers to the second edition of Pinebooks as sold this autumn.
The first edition had a 1366x768 display, the current one has a 1920x1080 display and to distinguish between them the second is often referred to as Pinebook 1080.

The linux images are sometimes minimal different to cater for the different displays.

However, the Manjaro image with the mainline linux kernel is the same for both Pinebook editions.


#52

Thanks.
Your posts have persuaded me to buy the PineA64 LTS card.
Initially will have it sitting beside and powered from my desktop and attempt to install android hooked up to the second monitor, a 40 inch Tv.
Using the 5 inch DVD bay could be a latter option…Manjaro/Android dual settup on a 11 yr old HP7800!!


#53

I have been looking into this a bit today.

So far I’ve discovered.

  • On regular Manjaro switching Timezone in MSM changes the symlink of /etc/localtime correctly.
  • On Manjaro ARM switching Timezone in MSM does not change the symlink of /etc/localtime.
  • Running timedatectl set-timezone Europe/London, results in a Access Denied error.
  • Running sudo timedatectl set-timezone Europe/London, results in same error.
  • Running timedatectl set-timezone Europe/London as root does not give an error, but does not change the symlink either.

And the timezone only keeps the change after reboots, if /etc/localtime is set correctly.
Non of the above issues are a problem on regular Manjaro.


#54

I have tinkered with that a bit as well, but no luck also.

I noticed that I can change the the timezone in the Manjaro Settings manger and and on the display it actually shows the correct timezone, however the actual time does not get changed.
This also persists if I close the settings manager and open it again. It shows the correct timezone but not the correct time.

No idea why though…


#55

yeah. I’m concluding that Manjaro uses some polkit/permission magic to make Manjaro Settings Manager work on their end.

Don’t really know what or how they implemented it.


#56

when MSM need root privilege it use kauth that use polkit and dbus

all the binaries that need privilege are in (msm_xxx)
/usr/lib/kauth/

and all policies files are in (org.manjaro.msm.xxx)
/usr/share/polkit-1/actions/

and dbus servcies (org.manjaro.msm.xxx)
/usr/share/dbus-1/system-services/


#57

Yes. It’s a dependency of Manjaro Settings Manager, so that is also installed on ARM.


#58

but for time date etc, I don’t think it use any privilege escalation trick… :thinking:

it use the system dbus interface “org.freedesktop.timedate1” and that this interface that will ask for password if needed.

https://www.freedesktop.org/wiki/Software/systemd/timedated/


#59

Yeah, and Manjaro Settings Manager does not give an error. But if you change the timezone on Manjaro ARM, log out and log back in, it will have reset to the default (Europe/Copenhagen) because the symlink for /etc/localtime has not been altered.

So it works on Manjaro, but not Manjaro ARM…

It only works if I manually change the symlink.


#60

I just mean that msm don’t do anything on the system…
it’s the systemd dbus deamon that do all. then the problem should be around that.