Manjaro ARM Beta7 with Plasma-Mobile (PinePhone)

I tried to use cronie to reboot the phone when the modem is down but with no succes since I would have to sudo in cronie.
Does anyone know how to get sudo cronie to work?

My workaround for this is (I’m using pmos/xfce4) is a script I made that just disables both network manager and modem manager that I run every time I know my screen will be off for more than a couple minutes, then running another script to enable them after I wake my phone up.

Also, I’ve noticed that when network manager is still reading wifi networks when the modem tries to connect, it will fail and require a reboot.

So I just keep everything disabled on boot, then manually enable either wifi or the modem depending on if I’m trying to connect to WiFi or 4G. You could also just wait a few seconds after booting to start the modem.

Without wifi disabled my phone always has issues trying to connect to 4G when driving down the road, seemingly because all of the wifi networks that is jamming up network manager.

I’m not sure it’ll alleviate the issue for you but it’s been working pretty good for me with my setup.

The only distro that seems to wake the modem up and connect really fast reliably (mostly) is UT, however it’s been a couple months since I’ve been using pmos/xfce.

Let me know if you decide to use this method and if it works, very curious.

The only reason I switched to pmos/xfce is because i really wanted typing suggestions and they work great with onboard. Last time I tried plasma they didn’t work in most apps, and only the terminal iirc.

Thanks for all the hard work everyone involved!

Restarting the phone is exactly what I’m trying to avoid.
(I have no experience with cronie)

Apparently, demon cooperation is pretty hell. :thinking: Hopefully the announced transition to ModemManager will put that right.
I’m using PP in the configuration:

  • eMMC - Manjaro/PlaMo for “stable” daily use
  • uSD - multi-distro for experiments (current version allows individual distributions update :+1:).

However, pmOS/XFCE is not offered by multi-distro (the author requires an official image and it probably isn’t), so I won’t try this.
I have only run UT once. Thanks for the tip, I’ll take a look.

For testing ModemManager I suggest to give Phosh Dev Daily a test-run: Releases · manjaro-pinephone/phosh-dev · GitHub

(@oberon) Why is the bugtracker not public? :thinking:

It is public. You have been using it for a while. :wink:

You’re right, it’s public.:+1: It’s just that my browsers dedicated to testing and limiting snooping from companies like Facebook and Google use SOCKS5, and there’s something going on for https://gitlab.manjaro.org that I haven’t encountered yet. I mistakenly attributed it to non-public access.

What is the relationship between dev, Nightly (above) and branches?
(+ Is it possible to see, without downloading the whole image, the dev version of /etc/pacman.conf? I’d like to compare it with mine.)

The defference is that the Dev image is based on unstable branch and uses [kde-unstable] repo for all the Plasma packages, while branches are just different update schedules. Unstable branch is every day, testing branch once or twice per week and stable branch usually every 2 weeks or so.

The Dev version of pacman.conf, is the same as our regular pacman.conf, except it has the [kde-unstable] repo added as the first repo in the list.

Thanks. I’m trying, but I’m still not sure.:woozy_face: Sorry. I’m paraphrasing with examples.

Manjaro branches differ only in the frequency with which packages in directories are maintained by a bot (in our case arm-stable, arm-testing, arm-unstable). Where Pacman reaches is set with # pacman-mirrors --api --set-branch <my_choice>.
The dev variant of Manjaro/PlaMo takes KDE Plasma Mobile applications packages from directory kde-unstable, the regular one from community. I don’t know what exactly was meant by “image is based on unstable branch”. Dev branch of arm-profiles?
Images are created for the purposes of flashing. Dev by sudo buildarmimg -d pinephone -e plasma-mobile-dev -v 20210226 -b unstable command, regular by sudo buildarmimg -d pinephone -e plasma-mobile -v 20210226 -b stable -s plasma-mobile -o (nice article :+1:).
Correct?

Not quite. The dev variant is based on unstable branch and has [kde-unstable] repo active.
The “stable” variant is based currently based on testing branch, but does not have [kde-unstable] repo.

Again, not quite. The plasma-mobile-dev profile no longer exists. The dev image is build by doing something like this:

sudo buildarmimg -d pinephone -e plasma-mobile -v 20210226 -b unstable -k kde-unstable

and regular is just using -b testing and without the -k part.

1 Like

If I understand correctly, if I want to transform Manjaro/PlaMo from regular releases to dev (I’m thinking in the context of multi-distro), it means:

  • switch to the unstable branch # pacman-mirrors --api --set-branch unstable
  • into /etc/pacman.conf add [kde-unstable] part
  • make changes defined by the arm-profiles (services, packages, …)
    • the list installed ( # pacman -Q) can be compared with the list of a daily dev releases i.e. *-pkgs.txt files
  • update the distribution # pacman -Syyu
1 Like

Ok, this is likely the wrong spot to make this post, so if a mod can help me redirect it that would be great. I was expecting to find a “Manjaro ARM Beta8 with Plasma-Mobile (PinePhone)” thread, but one doesn’t exist yet (nor does a tag for Beta8 exist in github)… which is weird as I did apply an update today where pacman -Q <appname> revealed my kernel is linux-pinephone 5.14.12-1, pipewire is 1:03.38-1, and megapixels is 1.3.0-2… so beyond what Beta7 delivered. Unless that’s normal?

The Manjaro ARM 21.10 released! post is what inspired me to check check for and install updates, and although it does include mention of the pinephone in it… the pinephone is not listed in the “Supported Devices” list.

Anyway, below is what I wanted to report… so if this post does move, feel free to purge anything above this line.


Ran into issues on my Pinephone with the update via Discover today.

At some point I missed a message on the bottom of the phone (caught that it mentioned libtool tho)… and post install/reboot I was given a notification that the “package” had failed… with options to (1) Launch Discover or (2) Repair… neither which seemed to really trigger an action/change.

But once within Discover, I was informed there were no updates to install… so it made me question the notification.

Swapped to the terminal and ran sudo pacman -Syyu for a second opinion and learned two things:

  1. Two packages I had installed were somehow newer… libtools and kpeoplevcard (likely what the missed message was about)
  2. There was “nothing to do”… nothing further to update

Used pacman (sudo pacman -S <appname>) to re-install both packages which downgraded them to match the repository, ran sudo pacman -Syyu once more, and was only informed there was “nothing to do”.

Rebooted the phone to see it the notification resolved, but it repeated… which I eventually resolved by sudo rm /var/lib/PackageKit/offline-update-competed (yes, “completed” was spelled wrong).

Any news on modem manager support?

The Beta releases of the PinePhone images are not tiedto strable updates as such. And yes, it’s normal that we don’t do a new Beta for Plasma Mobile for each stable update.

Discover on the PinePhone has been broken since the update of PackageKit and Pacman.

Likely those two packages was downgraded in the repo at some point.
If pacman says nothing to do, it can mean 2 things. Either you are completely up to date with the repo, or your mirror is out-of-date. To check for the latter you can run sudo pacman-mirrors -f5 && sudo pacman -Syyu.

It’s being implemented in upstream these days.

3 Likes

The Posh project has moved from “Gnome Software” to Pamac/GUI… will this project likely do something similar with “Discover”?

Hi, sorry if this is a common question, but Google only pulls a rather old thread…Is there any updates regarding GPS connectivity? I haven’t seen much info other than that old thread mentioning that it wasn’t available at all…is there a roadmap for it? Or any buggy way of attempting to connect to it? I’d love to jump to manjaro-plasma, as I love everything else and how well it performs, but the lack of GPS seems to be my final stop before I can do so…

GitHub - Biktorgj/pinephone_modem_sdk: Pinephone Modem SDK: Tools to build your own bootloader, kernel and rootfs (I have not personally tested the GPS functionality)

Does waydroid work with plasma mobile? any instructions on how to install it? Will it be preinstalled on next Betas ?