Manjaro ARM Beta3 with Phosh (PinePhone)

Have similar problems with power consumption since the update. The device starts discharging from about 85%.

I think the Charging Functionality w/ Convergence Dock is broken.
No HDMI output while charging through Dock.

Beta 3 / 5.9.9-1
PinePhone PmOS CE

The PinePhone loads exactly to 4.2V. It’s a restriction by Megi Kernel and Drivers to prevent the battery catching on Fire or overheat.
At least that’s what a dev of Arch ARM version said, which is using Megi Kernel aswell.


Thank you for your answer! That’s right, the voltage is displayed as 4.2V. Shouldn’t the charge level actually be 100% at this voltage?

1 Like

Geri: Thank you for your answer! That’s right, the voltage is displayed as 4.2V. Shouldn’t the charge level actually be 100% at this voltage?

There is a good explanation about PinePhone battery.
I think I am not able to post links. Even with a fix for 4.35V.
Search for “xnux eu” Website → Devices List → PinePhone (Detailed Information) → Battery/USB Power

Haven’t tested it. Not going to, since 80-90% is good enough for me. :slight_smile:
Since it’s able to charge further I don’t think 100% would be accurate. It’s a minor flaw I can gladly ignore since it doesn’t really impact my usage.

1 Like

The megi kernel should only charge to ~89% unlike older ones.

In addition to this check that you have plugged in the charger after DE starts loading. At least for me the phone only charges at 0.5A if i leave the charging cable plugged in during boot, i need to reconnect it after DE started loading to reach full 1A charging speed. If you run any applications in the background 0.5A is not enough to charge, or it will take many hours to raise even 10% in battery indicator.

Regarding Battery. Yes the Megi kernel prevent you from charging it fully up to 100%. Only 80% on Phosh or 89% on Lomiri. You may want to read-up on how a PinePhone can be a risk and what can be done to prevent it.

So I’m happy testing Lomiri on battery to see what we may get. Phosh on the other hand needs more power in terms on how you configure it. Lomiri is mostly programmed to save battery all the time:


Isn’t the only difference that Lomiri immediately goes to deep sleep whenever you push the power button to lock the screen while Phosh has at minimum a 5 minute timeout before deep sleep kicks in?

The convergence dock no longer works at all for me. If connected the phone will start to charge, but the device does not indicate it will dock. If a mouse is plugged in it will turn off when the phone is connected. I assume these are all power issues as well?

EDIT: after allowing the phone to charge until it wasnt charging anymore, the dock worked again, and the keyboard and mouse did as well. Once connected, the Powersupply app showed 0 capacity, 0 voltage, although the charging indicator said it was charging.

By the way what is the preferred method for follow up? Reply to myself or edit like I did here?

You can adjust that timeout in settings if you want. Lomiri on the other hand has a total different power management from UI also, which is not given with Phosh yet.

I have to try out the dock more with the PMOS CE Phone and the Manjaro CE Phone. There are small hardware differences in these editions. But yes, the power management still needs improvement.

“Yet” as in it is planned to be ported there? :slight_smile: Admittedly, I had a much better battery life when running Lomiri Alpha1 so that would be a huge improvement for Phosh as well.

I’ll try decreasing that timeout to something shorter to see if that improves anything. Given that wakeup from deep sleep has been quite stable recently this shouldn’t cause many problems, right?
For posterity:

$ gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 120

This will set the timeout to 2 minutes.

I just received my Pinephine Manjaro E, i started it up, all seemed fine :slightly_smiling_face:
Then i tried to upgrade to Beta 3, in terminal, all files/programs are downloaded, but when it shall upgrade, i get that some pgp keys need to be imported.
When i say “y” to allow the import i get the error message “import pgp key ‘CAA6A59611C7F07E’ could not be looked up remotely”.
I started the upgrade with “sudo pacman -Syu”
appreciate any help that i can get.

Try sudo pacman-mirrors and sudo pacman -Syyu.

Hmm, that is odd. Is an old problem it seems.

gpg --keyserver --recv-key CAA6A59611C7F07E

Nice Work so far.
But I have 2 problems with the keyring.

  1. Unfortunately the keyring doesn’t get automatically unlocked when unlocking the phone.
  2. The prompt for the keyring is over the regular login/unlock screen.

Hopefully this hasn’t already been answered… But the app store on my recent Beta 3 install doesn’t work. I’ve adjusted my date and time to be correct and already pulled one update. But when I attempt to use the app store I’m just given a blank screen.

It doesnt populate, its blank for everyone. But you can search and it will find software you can add. Then when you install it may say that it cant or wont install, but it does, depending on the application, but it actually will. With some applications I had to restart the phone to get it to work right. Gnome Web and Libre office for example.

Is everyone experiencing very slow app launch times? e.g. 10 seconds to launch firefox

I half expected this would be the case, just looking for some sort of indication that it’s normal at the moment.

Yeah, that matches with what I’m experiencing too. I’m not worried about it just yet.