Manjaro ARM Beta2 for PineTab

The Manjaro ARM project is proud to announce the second beta for the PineTab!

This image uses kernel mainline kernel 5.11.

Since our last developer release in October we were able to fix a lot of important bugs.
These images are based on the arm-testing branch.

Known issues

Plasma Mobile

  • Wakeup from standby sometimes takes more than one press of the power button.
  • Megapixels does not launch, can’t find pine64,pinetab-early-adopter.ini file. Solved by copying the pinephone one.
  • Autorotate does not work (no accelerometer in the kernel yet)


  • Megapixels does not launch, can’t find pine64,pinetab-early-adopter.ini file. Solved by copying the pinephone one.
  • Autorotate does not work (no accelerometer in the kernel yet)
  • External Speakers does not seem to work


  • Autorotate does not work (no accelerometer in the kernel yet)


Device Phosh Plasma Mobile Lomiri
PineTab (Early Adopter version) Beta2 Beta2 Beta2

About the device

The PINETAB is similar in both form, function and underlying ARM64 architecture to the original 11.6″ PINEBOOK. It is powered by the same Quad-Core ARM Cortex A53 64-Bit Processor used in our popular PINE A64 Single Board Computer. The optional keyboard and trackpad – which doubles-up as a screen cover – effectively converts the PineTab into a petite on-the-go laptop with a touch screen functionality. It runs numerous mainline Linux distributions as well as *BSDs and Android.

As a new open source platform, the PineTab development is an ongoing process and represents a great opportunity to get involved with computing on a different level, to customise and personalise the portable computer experience, to understand what is going on beneath the surface.


The PineTab is currently out of stock in the Pine64 Store, but it will be back soon.
Currently UBPorts is the default OS on the PineTab. But you can flash Manjaro ARM to an SD card or directly to the internal eMMC and it will boot that.

How to install

Download the image/xz file from the download location. Verify that the download completed successfully.
After that, install Etcher ( sudo pacman -S etcher if on Manjaro) or Manjaro ARM Flasher (if you are on Manjaro ARM) and burn the image to an SD card (8 GB or larger).
The PineTab should recognize the SD card as a bootable device and boot from it.

The preconfigured users on Lomiri and Phosh are:
User: manjaro
Password: 123456

User: root
password: root

The Plasma Mobile edition uses Pico Wizard as it’s First Run setup tool.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Installed it and booted it:

First setup runs and I made an reboot:

Screens brightness changes in an 1-second rythm from 0% to 75%.

Nearly impossible to do anything with the system. Any hints??

Try another reboot. Happened to me on the PinePhone today, but has not happened since I rebooted.

Maybe this is a problem of “orientation”. I have tested rotating the screen with the included “Display Configuration” widget. After using that the screen flickers and no further actions possible. Also can login and 2 seconds after succesful login the system throws me out to the login screen.

Can You please check this? maybe this is the problem. Or have You another tip for me to rotate the screen properly? Mine is a tablet with keyboard attached and portrait mode is a real pain

Let the original build unchanged in matters of screen orientation:

Same problem after a reboot. Brightness jumps between 0% and somewhat about 75% or so
Must be a problem of the build itself I think. Reboots and cold reboots do not help. Is there an ambiente sensor which could produce this issue?

I haven’t experienced this on my PineTab. Only once on my PinePhone, which was resolved after a reboot.

Plasma Mobile does not use the sensor, but Phosh, and probably Lomiri, does. What DE are you using?


Thanks for the new build Strit. Does anyone know if there a terminal command that can be run under Plasma Mobile to force the screen to rotate to landscape?

The way I’ve been doing it has been installing systemsettings and then changing it in the display settings to the appropriate orientation.

Great beta. Thanks for all your work.

Just a few things I picked up while playing with it for about 2 hours:

  • Disabling 24 hour time doesn’t do anything. It stayed on 24 hour regardless.
  • If the Settings app is opened while it is running in the background, it gets stuck in the"loading" screen
  • Updating the pinetab-post-install to the 20210306-1 version after already setting up the device would cause an operation not permitted error on reboot and would not let me login.
  • Changing the Turn off the Screen setting doesn’t seem to change the time until the screen turns off. It stays at 1 minute regardless of the set value.

Another issue that is most likely a third-party issue is that if you try to login to Bitwarden without the physical keyboard, the virtual keyboard does not appear when selecting a field. I got around this by typing my credentials into Nota and then copy pasting them into the Bitwarden fields.

I’ll keep playing with it but overall it seems much more stable than the dev versions that I tried out before. I appreciate the hard work.

Yes. This is a known Plasma Mobile issue.

I haven’t seen this. But I must admit, I always close my apps when I’m done with them, especially since the Close function is right there on the bottom bar.

Can you elaborate a bit more on this one? Like the exact error, would be nice. :slight_smile:

The settings is completely new (like under a month old), so it might just be the UI that’s there and not the permissions to handle it yet.

Writing with the virtual keyboard in GTK apps have been an issue from day one. I was hoping they had fixed that by now.

I will install the update again and get the exact error. I’m currently stuck with the same issue as Manjaro ARM Beta2 for PineTab - #5 by zash1958 right now so can’t login. Unfortunately I’ve rebooted about 6 times and the brightness issue seems to keep occurring. It keeps decreasing the brightness quickly and then locking the screen as if the “turn off and lock” setting is set to 0 or 1 seconds for some reason. Just a guess.

I’ll reflash the system in the morning and try to see if I can reproduce both of those errors again.

It only happens after an update?

Yes, the permission error + not being able to login error was after I updated pinetab-post-install through Discover and then rebooted. When I setup the install before updating, I chose a different username that wasn’t manjaro but I used the same password (123456). Could that combination cause some permission issues? I reflashed the device after and was able to use the same credentials + reboot several when I didn’t update at all.

Could you check if you have /etc/sddm.d/00-defaults.conf file?
If you do, what is it’s contents?

Or even /etc/sddm.d/99-autologin.conf?

Thanks Bosnia, I’ll give this a try after work.

Of course, after I try to replicate the process two more times I’m unable to reproduce the error. Must have been something else that I did that caused the issue originally. Sorry for the false alarm.

In regards to:

I have both files. The /etc/sddm.d/00-defaults.conf contains:

# Created by Manjaro USER Module Handler


and /etc/sddm.d/99-autologin.conf contains:

# Whether sddm should automatically log back into sessions when they exit

# Name of session file for autologin session (if empty try last logged in)

# Username for autologin session

# Halt command
HaltCommand=/usr/bin/systemctl poweroff

# Input method module

# Initial NumLock state. Can be on, off or none.
# If property is set to none, numlock won't be changed
# NOTE: Currently ignored if autologin is enabled.
RebootCommand=/usr/bin/systemctl reboot

# Current theme name

# Cursor theme used in the greeter

# Number of users to use as threshold
# above which avatars are disabled
# unless explicitly enabled with EnableAvatars

# Enable display of custom user avatars

# Global directory for user avatars
# The files should be named <username>.face.icon

# Theme directory path

# Default $PATH for logged in users

# Comma-separated list of shells.
# Users with these shells as their default won't be listed

# Comma-separated list of users that should not be listed

# Maximum user id for displayed users

# Minimum user id for displayed users

# Remember the session of the last successfully logged in user

# Remember the last successfully logged in user

# When logging in as the same user twice, restore the original session, rather than create a new one

# Enable Qt's automatic high-DPI scaling

# Path to a script to execute when starting the desktop session

# Directory containing available Wayland sessions

# Path to the user session log file

# Path to a script to execute when starting the display server

# Path to a script to execute when stopping the display server

# Enable Qt's automatic high-DPI scaling

# The lowest virtual terminal number that will be used.

# Arguments passed to the X server invocation
ServerArguments=-nolisten tcp

# Path to X server binary

# Path to a script to execute when starting the desktop session

# Directory containing available X sessions

# Path to the user session log file

# Path to the Xauthority file

# Path to xauth binary

# Path to Xephyr binary

This is the issue.
It’s trying to autologin the kde user, but that does not exist (I think). That’s the issue with providing these files in packages…
Try changing that User=kde line in 99-autologin.conf to User=bosnia.

It was working before with that configuration but also worked when I changed it to User=bosnia. What I did notice was that when it was set to User=kde, the KDE spinning logo would appear, disappear after a few seconds, reappear, and then I would get the login screen. WIth User=bosnia, the logo appears once and then goes to the login screen. Again this is just after a fresh install so might just be a random observation.

in the lomiri image, is there a way to edit screen orientation? (heh, i just noticed that during the manjaro/lomiri loading screen, the landscape orientation is correct with the dock. and once it loads, the login is 180 from the keyboard dock.)

also, is there a way to increase scaling for window controls?

noticed last night when placing the tab back on the dock, lomiri changes to “docked” but keyboard+mouse of dock don’t work. they only seem to work if docked at boot and left docked.