Manjaro ARM Alpha5 for PinePhone - Testing Branch

I have no issues with wifi whatsoever.
I do most of Linux related stuff (update/upgrade, compilation, etc) via SSH, and it's working without any issues, however I did notice it disabling wifi when I leave it unattended, I assume it has something to do with the power saving. I does reconnect if I unlock it, though.
My phone is a BH.
I tested vvave with some audio files, it shows them as playing, but it doesn't produce sound. I'll try video/youtube and let you know. If I play the same files using, e. g. mplayer - everything is fine.

Hi @afigegoznaet

Thanks for informing about this issue. I missed one dependency which is needed for audio output.

Please install the dep using this command.
sudo pacman -S gst-plugins-good

After you install this package you will be able to hear audio output.

I will update the vvave-git package in the next release.

1 Like

Yup, that fixed it, thanks.
Also, I noticed that one time wifi reconnected and then disconnected after I opened the screen (re WiFi issue), but this only happened once.

@afigegoznaet: I don't know if it matters, but did you install Manjaro to the eMMC of your Pinephone? Or are you running from SD-card? For me it's the latter.

it's on eMMC

With the last update, I have a black screen. The Pinephone was started and I can ssh in. When I start the Pinephone, Manjaro logo and Plasma logo appeared 2 seconds and disappeared.

Anyone have this problem ?

Ps : ssh is not stable in this state, it's laggy

Edit : I just burned again and it's work, I don't know why but I think a potential hardware issue, not Manjaro

I have the same issue. On first boot using my BH phone Alpha5 booted great. I ran the updates via discover and added the clock widget to the desktop. Then I rebooted and since then the resolution is crazy high and all icons are tiny. No clock widget either or the installed search bar. Tried it off and on several times but it seems it's now stuck like this unless i reflash the sdcard.

1 Like

I will try tonight on my device and see if I can reproduce it.
Thanks for reporting it.

1 Like

Are there any instructions how to install on eMMC?

Thanks for letting me know :slight_smile: Will try from eMMC as well then

I also have this exact same issue. After flashing and running from SD-card, the phone boots up fine. Then when I setup wifi and run updates (sudo pacman -Syyu) through SSH, the phone won't boot up after that any more after I shut it down. I see the Manjaro logo, then the Plasma logo, then a black screen. Not sure if the phone is on or not after that.

If it's any help, I recall I also had this issue with alpha's 3 and 4, so I don't think it's specific to alpha 5.

Thanks. I never had this problem but just burn again and it's ok now. I don't know the origin of this bug.

Do not flash this on emmc yet as these are alpha images and if it breaks then everyone will need uart to figure the issue while on sd you can easily flash anything but if you want to try it then Here is how to flash it.

  • Flash the img onto the sd card.
  • Insert the sd card in the phone and boot it once.
  • Uncompress the img file so you get a .img file.
  • Power off the phone and insert the sd cd into your pc and copy the uncompressed img file to /home/manjaro
  • Boot into the sd card on the phone and run this command on terminal
  • sudo dd if= Manjaro-ARM-plasma-mobile-pinephone-alpha5.img of=/dev/mmcblk2 status=progress
  • Once done power off and remove the card and it will boot into emmc.

Also I can confirm that update breaks plasma mobile shell. I will try to debug it tomorrow and try to push the fix.

1 Like

mine has the same with tablet sized icons , i had the correct pinephone sized icons a couple of reboots ( installed on an SDcard ) , then it changed to the tablet size and has remained like that since.
i did ,a double check of the name of the file i downloaded just to make sure LOL

I like the smoothness of the UI , you guys are doing great work Thanks

UPDATE now it has booted up with the correct phone sized icons.

Google Photos

i have wifi connected ,but Discover doesnt think so, and
blocked from logging back in by the keyboard.

It doesnt when to try to search something and if there is any new update it shows just the home page of discover seem to have some problem


Strange decided to switch on my pinephone today after several failed reboots the other day which did not fix the abnormally high resolution issue. Low and behold the resolution is now back to normal. Can't find any reason for this either ? :thinking:

Is phone call sound working? I can make a phone call, but only hear noise.

Are you using Braveheart edition? I think users with Braveheart edition are experiencing strange UI and wifi behaviours while the dev kit devices don't have any such issue except my yesterdays update didn't let the plasma shell start but today when I tried to power it on again it was working fine.

I am waiting for my BH kit so I can do some more testing for such strange behaviour.
Thanks for reporting.

Did you try it after a reboot?
Can you share the output of the following command?
sudo systemctl status pinephone-modem-audio
After this try this command and share the output.

sudo systemctl enable pinephone-modem-audio --now

Thanks.

Yes I am using the BH edition. Does anyone know exactly what the differences are between the two versions ? Can the BH edition be modified to match as I'm an electronics engineer by trade ?

Forum kindly sponsored by