Manjaro ARM Alpha1 with Lomiri (PinePhone)

Got my phone today, is there a reason why the Lomiri desktop here on the website is in alph1, while Phosh is in Beta1.

As written above maintainer is sick. Also phil wrote they going to port to a new Qt and SystemD but thats on hold and won’t get picked up until early 2021.
Its a pitty isn’t it? :frowning:

Until this gets some progress again check out PureOS from PinePhone multi-distro demo image. The only OS i tried so far reaching the resonsiveness of Manjaro Lomiri alpha build.

1 Like

Which DE or edition? Phosh?

This thread is for Lomiri DE by Ubports also known as ubuntu touch.

Lomiri and Plasma mobile are the most promising for me from user perspective. Looking forward to see updates for this :slight_smile:


Hi All,

Lomiri would be great, I guess, but it asks me for a passphrase on the a lockscreen, which I never set before and “root”, “123456” and “manjaro” are not working.

Can you please help?

Password is 123456
User used is manjaro

Can you share screenshots?

I tried a new image few days ago and it was all good.

I am facing the same issue as @cefre00. I just flashed my pinephone UBPorts edition with Manjaro Lomiri Alpha1. The username and password worked fine initially. I then proceeded to the terminal and did
pacman -Syu

I got some messages asking whether I want to remove some conflicting packages. Initially I said know, and then I got an error saying that the “transaction could not complete”. So I ran it again, and this time I selected yes. After a while of inactivity on my end, while the update was happening, the screen locked. When I entered 123456, I got lockscreen error. Typing “root” did not help either. Nor did “Manjaro”. Typing in other standard passwords have now blocked me from further attempts for 5 minutes.

Steps to repro:
Install Manjaro Lomiri Alpha 1
Open Terminal
sudo pacman -Syu
– It first replaces some Manjaro and Arch keyrings

  • It then offers a full system upgrade and asks some questions. Press ENTER (Y) for all of them:
    Replace eg25 with community/pinephone-modem-scripts? [Y/n]
    Replace geoclue2 with extra/geoclue? [Y/n]"
    Replace pinephone-modem-audio with community/pinephone-modem-scripts? [Y/n]
    Replace pygobject-devel with extra/python-gobject? [Y/n]

Then it spits out this output:
looking for conflicting packages…
warning: removing ‘kwayland’ from target list because it conflicts with ‘kwayland-git’
:: rtl8723bt-firmward-megi and rtl8723bt-firmware are in conflict. Remove rtl8723bt-firmware? [y/N]

Selecting the default here will immediately terminate the upgrade, and the password 123456 still works. Redo and this time select ‘y’
:: kwayland-git and kwayland are in conflict. Remove kwayland? [y/N]
Selecting N terminates the upgrade and the password still works. We also see these messages
“error: unresolvable package conflicts detected”
“error: failed to prepare transaction (conflicting dependencies)
:: kwayland-git and kwayland are in conflict”

Redo “sudo pacman -Syu” and this time select 'Y/y" for everything

Leave the phone unattended and let the screen lock due to inactivity. Issue reproduced. Device power off/on does not help.

Keep tapping the screen to prevent it from timing out. At the end of the system upgrade, key in
$ passwd
Enter current password: 123456
New password:
$ exit

Power off the phone and then power it on. Now able to login with the new password that was set.

1 Like

UT as a daily driver user here. I’ve tested Sailfish OS UI on the Pinephone thanks to Megi’s dual boot. I must say that is far more developed and snappy compared with Lomiri. The downside is that Sailfish OS on Pinephone just doesn’t handle the HW at all yet and they have this weird thing that doesn’t allow you to boot the OS without a SIM card inserted. Plus is proprietary.
Yes, Phosh is not the best UI out there, but you guys have reached a milestone in the Pinephone development with or without Lomiri, so many thanks for the work.
Sure you’re gonna receive another donation from me!