Manjaro ARM 21.06 released!

210614 is arm-unstable
21.06 is arm-stable

so depends on what you want in a system, i toasted my 210614 install earlier in the day after the update left me with a frozen cursor on a gray screen.

unstable = newest untested stuff
stable = better for a daily driver

beat me to it, guess i type to slow.

does the same build profile?

Profile it uses is the same, yes, other than the changes that was made to it, from when 20210614 was made up to 21.06 was made.

Hi,
Do you have or plan to have support for Apple M1 Macs since it is possible to run some Linux ARM distros via Parallels Desktop?
Thanks,

No current plans, no.

sway-21.06 stop BTRFS support(test)?

Hi @Strit and @spikerguy,

Just downloaded Gnome Khadas Vim3 21.06 and burn on USB. After numerous boot up (kernel panic due to linux-vim 12.9.1-1) during booting process or right after login, was able to finally switch to mainline linux 5.12.11-1.

I noticed that there is NO Hardware Acceleration eventhough /run/media/jfl/ROOT_MNJRO/etc/X11/xorg.conf.d/01-panfrost.conf is set to “glamor”.

Section "Device"
    Identifier  "Default Device"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"     ### "glamor" to enable 3D acceler>
EndSection

Section "ServerFlags"
        Option  "AutoAddGPU" "off"
        Option "Debug" "dmabuf_capable"
EndSection

Section "OutputClass"
        Identifier "Panfrost"
        MatchDriver "meson"
        Driver "modesetting"
        Option "PrimaryGPU" "true"
EndSection

 jfl@MNJROGTKPro    glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa/X.org (0xffffffff)
    Device: llvmpipe (LLVM 12.0.0, 128 bits) (0xffffffff)
    Version: 21.1.2
    Accelerated: no
    Video memory: 3773MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 12.0.0, 128 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 21.1.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 21.1.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

Both in GNOME or GNOME Xorg session NO Hardware Acceleration. Appreciate yourguidance on how to enable Hardware Acceleration in GNOME or GNOME Xorg session?

Another perculiar situation is that the keyboard keys. @ key and " key are switched! Only in this Manjaro GNOME (keyboard selected is US).

@strit & @spikerguy,
Edit: For whatever reason, after reboot Hardware Acceleration is available on GNOME (Wayland) Session. For your info, I did not modify the /etc/X11/xorg.conf.d/01-panfrost.conf as it already set with “glamor” on first boot up or any other gdm3 settings. Will check GNOME Xorg session later and update.

Manjaro-Arm GNOME 40.2 desktop is quite different from the Ubuntu-Desktop (GNOME 3.38.5).

Edit 2: Login to GNOME Xorg, check with “glxinfo -B”, Panfrost NOT enabled. Open /etc/X11/xorg.conf.d/01-panfrost.conf: Option “AccelMethod” “none”. Changed to “glamor” and re-login to GNOME-Xorg session, Now Panfrost enabled.

@appelgriebsch

For the keyboard settings: looks like a bug related to ISO/ANSI version of keyboard settings. Can you please check in the gnome settings?

Somehow the according to “Settings” the keyboard is “ENGLISH (UK)”. During the first boot up setup I have selected US keyboard, don’t know why the system configured “ENGLISH (UK)”. Resolve it by adding another keyboard “ENGLISH (US)” and select “ENGLISH (US)” on the top right menu bar.

1 Like

Btrfs is an option when building the OS images via Manjaro-arm-tools. The default is ext4 (and it still seems to be the preferred option of most users). If you want to go with btrfs you can either build your own image, or use the Manjaro-arm-installer script…

I’m not into the details of this specific device, but the output device: llvmpipe caught my interest. To me looks like it falls back to a software rendering mode…

For the keyboard settings: looks like a bug related to ISO/ANSI version of keyboard settings. Can you please check in the gnome settings?

Will check for the keyboard issue… usually the oem-installer script should set the keyboard settings according to your selection on first boot…

Would like to thank @Strit and Manjaro Team for a great work on the new Manjaro-Arm GNOME Edition. This is the firm GNOME-Arm that I have use where GNOME-Wayland and GNOME-Xorg works with Desktop Acceleration (Panfrost Enabled) without any typical Panfrost visual artifacts. Two of the other distros GNOME-Xorg session have bad visual artifacts when desktop acceleration (Panfrost) is enabled. In Gnome-Wayland no or very minor visual artifacts.

So far Manjaro-Arm GNOME (40.2.0) both GNOME (Wayland) and GNOME-Xorg function well with desktop acceleration (Panfrost). Congratulation.

Don’t why the other distros I tried had issue on GNOME-Xorg session with Panfrost enabled.

sway took 10+ second to menu show up after login.
wonder it waiting wifi to connect?

which menu?
the first time you use anything, it creates settings & things.
just go about setting up, then reboot a few times & you’ll find it takes less time.

recommend you setup keyboard shortcuts in ~/.config/sway/config

menu? panel?
it took 23 second, Pi4 sdcard boot, no overclock.

i’m on the rpi400 using sd card as well.
stock out of the box, the panel has applets that the pi does not need, go into ~/.config/waybar/config & comment(//) out the 1’s you don’t need.

Hi @Strit & @spikerguy,

Additional info on GNOME Edition. The “quiet splash plymouth.ignore-serial-consoles” on extlinux.conf seems to cause my device (GT King Pro) to loose connection to monitor and at times just a blank screen with no hdmi connection. I modified the extlinux.conf to the following:

APPEND root=PARTUUID=a43f02e9-02 rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 audit=0
#quiet splash plymouth.ignore-serial-consoles

After this modification it boot up all the time.

Just found out on Manjaro-Arm GNOME Edition on Chromium with this settings

chromium --enable-features=UseOzonePlatform --ozone-platform=wayland --in-process-gpu

Chromium WebGL Aquarium fps improved significantly to around 31-34fps.

3 Likes

I’ve had the same experience with the gnome image, after entering the required info in the installer script there is a msg: setting the keymap to uk. I’m trying to find out why/how by re-imaging the card and choosing different options and see what results I get.

Edit: So far the choice for ISO/ANSI does not seem to matter, changing the locale does not seem to matter either. I’ve used en_US.UTF8 & nl_NL.UTF8. Timezone is alway’s Europe/Amsterdam.

After logging into gnome the keyboard is set up as GB.

Edit2: for reference the sway image selects the right keymap so it seems to be specific to the gnome image

Same is true for Vivaldi btw.

1 Like