Manjaro ARM 20.10 released!

I would like test an image for odroid c4
is it possible to get it?
the connection hdmidvi is working under debian

is it possible to get an x86 minimal image iso with the arm flasher 4 sd?
thnks

Right now, you can only get an Odroid C4 install, by using the Manjaro ARM Installer.

No.

question where i could get the arm image for odroid c4?
as i saw no link for odroid c4.
could you post the link?
thnks

Nowhere. As I said in the post just above yours. You can only install Manjaro ARM on the Odroid C4 via the Manjaro ARM Installer.

I do need a software to start odroid c4 and the apply the manjaro arm installer…
Where to look for?
Or should i start with debian?

Hi,

look here

Hi. I don’t know what to try anymore. update my rockpi4 from debian, with uboot on spi updated. Manjaro in nvme with dd and starts well. After the first update and reboot, it hangs on the manjaro logo. I have tried with xfce, Kde and with both images the same thing happens.

How do you overclock the cpu on the rpi4 on this os? my board’s actively cooled and I want to have a decent performance.

By adding these lines in /boot/config.txt

#Overclocking 
over_voltage=5
arm_freq=2000

Then reboot and test the cpu frequency.

When will the next release be? Thanks.

Has anyone received the Pinebook Pro Docking Deck and have it working with HDMI? HDMI works with a MacBook Pro but I have had no luck with the PBP and Manjaro (tried both stable and arm-testing branch). In some cases it seems like the dock video output is simply ignored and in the other the PBP screen becomes garbled and unreadable. Unplugging the dock afterwards will not fix it and a reboot is required.

Do you use the linux-pinebookpro kernel, or the default one? As part of release notes it is mentioned that HDMI out via USB-C is broken on latest kernels…

Right, that probably explains it then.

Thanks, I guess it is a kernel issue then.

I’m running Linux pbp 5.9.11-2 which I assume is the linux-pinebookpro kernel?

The dock also has VGA out which has the same issue. Not sure how the dock implements VGA compared to HDMI but I guess that is to be expected?

Not sure… it mentions here to install linux-pinebookpro as mitigation to the external display issue: [ARM Stable Update] 2020-11-24 - Kernels, Phosh, LXQt, Plasma 5.20.3, Frameworks, Bitwarden, UBoot

I guess it’s an older kernel based on 5.7.x in which the feature was still operational.

It’s not. You are running linux, which is mainline, where it’s currently not working.

Correct. linux-pinebookpro is an older kernel, based on the 5.7 branch, where the hacks still works.

2 Likes

Yes, silly me the pbp part threw me off. This is of course the machine name and not part of the kernel name :man_facepalming:

Is it worth switching to the pinebookpro kernel just to get the DP Alt Mode working or should I just be patient and wait for a mainline fix?

I can answer you shortly, as we are testing some stuff.

If you urgently need DP alt mode for something, you should switch kernel.

EDIT: I just uploaded linux-5.9.12-4 to unstable branch, which should have working DP Alt mode. I tested it on my PBP with a USB-C dock and HDMI and it worked for me.
So there’s light at the end of the tunnel. :wink:

1 Like

Unfortunately it didn’t seem to fix my issue. It does work with the older pinebook kernel though. Also, I get screen corruption on reboot which I initially thought was related to having the dock plugged in but I learned that this is an uboot issue. Anyway, thanks for the effort. At least I know the dock can work with the Pinebook Pro so it will hopefully be resolved in due time.

1 Like