Manjaro ARM 20.08 - Headless setup via ssh

The release notes for Manjaro ARM 20.08 say this:

“ First Time setup
This release sports the First Time setup for all images, also via SSH.”

My rpi4 boots up just fine and shows up on the network but when I try to log in using putty, gives error “connection refused”.

Found a soultion in the link (Is headless setup via SSH available for the ARM images (RPI4)?), but didnt work.

Tried with both “KDE PLASMA” and “XFCE” images, no success.

I do not have a monitor, but a keyboard and mouse.

Any help would be appreciated.

Are you sure you are trying to ssh to the right ip address and as user root? Mine would be this here:

ssh root@

This only works for going through the initial setup. After that when it reboots then you will get the error you posted (“connection refused”). You then have to ssh to the pi using the username you created in the Setup.

ssh your-user-name@

1 Like

I am sure this happens when i am trying to boot for the first time. I do not have a monitor, so i am not done with the initial setup.
Is there any automatic login happens ??

Did you remember to connect to the Pi as root@IP the first time?

That should auto login and get you through the setup.

I tried with root@ipaddress, there i get the error “connection refused”

More info:
My pi and my windows computer are connected to the same network.
I got the ip of PI from the router page.
iam using putty to connect to PI with root@ipaddress, port : 22 thouugh SSH

Okay. We have had reports that the 20.08 rpi4 images takes a while to boot completely, like 10 minutes or so.
Have you tried just waiting 10-15 minutes and then SSH?

Could simply be that the boot process is not complete yet, and thus the SSH service has not started.

I will try this and come back soon…

Thanks for your suggestion…

Thanks for all your suggestions.

Unfortunately nothing worked for me.

Finally i found a monitor and boot into desktop. Now actually i am unable to connect to any WIFI, system is trying to connect for sometime, then asking for password again. It keeps on going like this, unable to connect. Error shows “No secrets were provided”

any help would be much appreciated.


Sounds like you did not provide a passcode in your wifi setup.

I did it, it keep on asking several times, even i enter again and again, no connection is being established…