Manjaro ARM 19.12 released!

Same here, network manager doesn't start after update. It works after going back to version 1.22.4-1.

how do you downgrade? does it require internet to downgrade?

https://wiki.archlinux.org/index.php/Downgrading_packages
or with http://aur.archlinux.org/packages/downgrade if installed

weird. downgrade from cache, rebooted, and

NetworkManager --version

shows 1.22.4-1 now, but still no internet. did you have to do anything else?

works with 1.22.2-1 in my case

1 Like

I have removed the faulty networkmanager 1.22.4 (and friends) from the repo. Rebuilding 1.22.2 to upload that instead, until Arch Linux ARM gets it fixed on their end.

1 Like

FYI, after an update this morning, plasma would not come up. I worked around it by downgrading plasma-desktop and plasma-framework.

2 Likes

Thanks for reporting.
Fixing....

Just (re-)installed Manjaro XFCE to my Raspberry Pi 4 (4GB) and am once again digging how responsive this system is on the Pi!

One weird thing cropped up though - there was no keyboard shortcut set up for the Whisker menu, and also not for window tiling? Odd, but it's pretty easy to open the keyboard settings and add these. I prefer the super key to trigger the menu (matches Windows that I have to use at work, and most other Linux distros). For some reason I couldn't get super + arrow keys to work for tiling, so had to use ctrl+shift+arrows, guess I'll get used to it..

Hi, I would like to install Manjaro on my asus c101pa Chromebook
Which method (if any) would you recommend. Is it similar enough to try the pinebook pro image or should I just stick to archarm?
https://archlinuxarm.org/platforms/armv8/rockchip/asus-chromebook-flip-c101pa

Thanks in advance.
-timttmy

We don't currently have support for Chromebooks. So if you want an easy install, you should stick to Arch Linux ARM. :slight_smile:

Hey there, I am wondering how to run a windows exe on this version here. Wine doesn't seem to be support.

What type of exe and for which architecture? There should be easier way for Windows 10 Arm executable. But you are generally looking at qemu solutions.
Some games offer modified engines (like OpenMW, OpenArena, etc).

Currently I'm fighting with hangover for x86 / x64 emulation :smile:

LOL
Manjaro ARM 19.12 on Pinebook Pro.
The program is called Purple Pen http://purplepen.golde.org/
I used wine before on a different system and was hoping I can do the same here

Well, for the moment you are looking at user space emulation with qemu: https://wiki.winehq.org/Emulation It won't be fast but it doesn't look like purplepen is a heavy program.

There ought to be some youtube videos about this setup (most likely with RPi4)

1 Like

Not sure if the 'Sound gets output to both Speaker and headphones at the same time' issue has been fixed but on PBP with KDE I am happy to report that my USB-C headphones are working great with the speaker output volume muted!

image

It has not yet.

But USB devices should work like they would on regular hardware (if the kernel supports it). :slight_smile:

Sway on mesa-git using Panfrost here. Performance is still pretty awful and I'm looking for more improvements.

A couple bugs:

  • Firefox crashes regularly.
  • Telegram crashes frequently.

I'm using a 128gb emmc. Would switching to an nvme SSD like the Intel Optane 660p offer improved performance interacting with UI elements etc? Can we expect performance to dramatically improve with improvements to Panfrost?

I use manjaro xfce 19.12 on pi 4. Can i disable login password? When yes, how to?

Lightdm should have some option for autologin in LightDM settings somewhere.

Forum kindly sponsored by