Manjaro ARM 19.06 released!

Manjaro ARM 19.06 released!

I am proud to announce the immediate availability of Manjaro ARM 19.06.

We also started supporting the new Odroid N2 device, with a 4.9 kernel. It's Hardkernels version of a RockPro64 board, just with an Amlogic S922x SoC.
So the Odroid-C2 prebuilt images have been switched for the Odroid-N2 ones.

We also finally support the rockpro64, which we have worked for the last few months.
And the Rock64 prebuilt images has been switched for the RockPro64 ones.

And a last minute entry is support for the rockpi4 device, which is also an rk3399 based board.

You can still install Odroid C2 and Rock64 with manjaro-arm-installer.

New eMMC flash image for Pinebook

We also introduced a special kind of image with this release.

It's an image for supported laptops designed to flash Manjaro ARM to the built-in eMMC module, so you don't have to fiddle with DD and/or take out the eMMc module yourself.

Right now an image for the Pinebook is available in the download folders linked below, but will be named emmc-installer in addition to the regular filename.

OEM Setup

This release sports the custom install option for all images. This means that at first boot, you will be asked about the following:

  • username
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • keyboard layout (except on pinebook, that is fixed to us layout)
  • hostname

Then the setup script will set these settings and reboot to the login screen.

KDE:

LXQT:

Downloads:

No torrents this time! Sorry!

Features:

  • New kernels and packages all around.
  • LXQT 0.14.1
  • KDE/Plasma 5.16.1

Updating from 19.04:

  • Old releases should just keep on rolling.
  • If you want the 19.06 experience, I recommend re-installing the system.
  • Please install archlinux-keyring before updating.

Known issues:

  • No lockscreen installed (LXQT only).
  • No audio cards on RockPro64, Rock64, OC2, ON2 and RockPi4.
  • Rock64 rev3 does not boot from SD cards. Need correct uboot patch.
  • Wifi/BT not available on Rock Pi 4. Mainline support should be coming in 5.3.
  • Raspberry Pi 3 not increase from base clock frequency, do to a kernel bug.
  • Devices using mainline kernel might have issues with internet connections. Turn of ipv6 for the active connection and force it to run ipv4. It's a kernel bug.

Supported Devices:

  • Raspberry Pi 3 (tested on B)
  • Odroid C2
  • Odroid N2
  • Rock64
  • RockPro64
  • Pinebook (tested on 11" 1080p edition)
  • Rock Pi 4
  • Pine64-LTS / Sopine (tested on Pine64-LTS board)

What about other devices?

Manjaro ARM is dropping armv7h support entirely this August. So if you have/use an armv7h device, you should be looking at other distro's that might fit your need. Some could be:

  • Arch Linux ARM
  • Armbian
  • Raspbian (for the raspberrypi)
  • Ubuntu Mate
  • Parabola

All package updates have stopped for armv7h. That means, no more package updates for armv7h at all going forward. I am also removing any armv7h support still present in manjaro-arm-tools, arm-profiles and manjaro-arm-installer.

August 1st, the armv7h repo will be removed from the repo server and mirrors.

I am still waiting on the Pinebook Pro for testing.

I won't be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.

Donate!

Please consider supporting Manjaro ARM via Patreon, Ko-Fi or to Manjaro's Paypal.

12 Likes

Hi,

Congratulation for this work.

Before installing the n2 19.06 I updated the n2 preview 2, something go wrong

paquet non valide ou corrompu (signature PGP):

same issue with the c2, see below, sorry for the screenshot...

Then I installed the n2 19.06

Échec de récupération du fichier « community.files » provenant de www.uex.dk : Could not resolve host: www.uex.dk

Static information about the filesystems.

See fstab(5) for details.

LABEL=BOOT /boot vfat defaults 0 0

[nln2@n2-2019-06 ~]$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0 179:0 0 58,2G 0 disk
├─mmcblk0p1 179:1 0 243M 0 part /boot
└─mmcblk0p2 179:2 0 58G 0 part /
mmcblk0boot0 179:32 0 4M 0 disk
mmcblk0boot1 179:64 0 4M 0 disk
mmcblk0rpmb 179:96 0 4M 0 disk

[nln2@n2-2019-06 ~]$ uname -a
Linux n2-2019-06 4.9.177-2-MANJARO-ARM #1 SMP PREEMPT Sun Jun 2 21:24:06 UTC 2019 aarch64 GNU/Linux

Somebody else confirm this issue ?

Does GPU accelleration work in Manjaro KDE 19.06?

I've just found the Pinebook 11,6" 1080p OS table and it says "No?" (though it hasn't been updated since December 2018).

For KDE Neon the option says "Yes?", so I'm slightly confused.

Not really understanding your language in above pic with pgp signature but it looks like it might be the same issue I am having with the pi3 with the new 19.06 with the new manjaro-arm-keyring. Looks like strit needs to re-sign and or sign the package.

error

Read here https://uex.dk/about

Regarding the GPG key issue, I am looking into it, I just don't know what goes wrong.
I'm signing using the exact same key as I always have. The only real change is that we added @dodgejcr's new key, but that's not used for signing. Only mine is.

I have tried repackaging, resigning and reuploading the keypackage at least 3 times now since I saw this issue. I get no errors, but it still does not work. :frowning:

Okay. Just fixed the keyring issue.
manjaro-arm-keyring-20190621-3 should be working fine. Just tested it on my Pinebook.

Worked like a champ!

Thanks Strit!

So will just keep on rolling lead to the same result as re-installing?
Why would re-installing be required to get the 19.06 experience?

It is not required, just recommended.
The reason can be many, like new packages might have gotten added to the profile or a new setting has been tweaked.

OK, I have just installed KDE 19.06 EMMC and it's looking good so far, except for one obstacle:

The touchpad is not recognized (KDE Settings is telling "No Touchpad found"). It can be used, but tap instead of button press and pressing both buttons for middle click are not working.

Any clue on this issue?

The touchpad on the Pinebook is actually an emulated mouse. So it won't show up as a touchpad.
It's a hardware issue.

This is not the first time I've heard this. It very weird, because tab to click are working fine on mine without changing settings.

Definitely not working here on a fresh installation. So I guess there is no way to middle click then?

I tried to select "Left and right button for middle click" in mouse settings, but it can not be saved (always reverts to unselected).

Something else:

When I open the Manjaro Kernel Manager, it's empty. No kernel management supported?

My first Pinebook KDE experience: Fine so far :slight_smile:

Since not all our devices actually boot on mainline kernel, we can't use the management, because we can't "filter" on what kernels are supported on what devices.
And ARM does not support multiple kernels at once. So if you install a non-working kernel, the device has to be reinstalled.

1 Like

Hi,

The keyring issue is solved, nice.

I updated the c2 and n2, the devices are both working well with the 19.06
congratulation manjaro
The c2 need a screen to boot... not the n2 :slight_smile:

Thanks all for your feedback.

Enjoy !

Does that mean that when running pacman -Syu that the kernel of 19.06 will not be amung the updates installed?

It will be. All packages will get updated.

Just some settings and stuff is only added in 19.06, and such would not get applied on an updated system.

Good news for those affected by the black screen for the Pinebook 1080 with LXQt (and I believe KDE Plasma as well)

Although not entirely solved the black screen only happens very occasional now and 19.06 is completely usable in the last days of my testing.
:grin:

2 Likes

Hi,

Today I updated the c2 with the kernel 5.2, it's ok, congratulation manjaro !
I'm maybe wrong, the system use less ram :slight_smile:

Unfortunately the c2 don't boot X without display, I can ssh into the c2 after a reboot without display, manjaro is on.
(it indeed sounds like it does not bother initializing the display stuff from HDMI, when there is no display connected to it at boot)

This could be because of the amlogic.service.
Try disabling that and reboot. It will not turn on HDMI display, but should otherwise boot the board.