Manjaro ARM 19.02 released!

release
manjaroarm
#21

Is there any guide on building manjaro for arm?

#22

Installed LXQT on a Pi 3B+. The graphical package manager would not work (said ‘SU’ command failed) so I had to update/upgrade via terminal/CLI. Could not get audio to work properly. It plays back as if it was a vinyl record spinning too slow. This was playing through the browser, either streaming online radio or Youtube.
Firefox used too much memory (and caused frequent lockup) so I removed it and installed Chromium which is a little leaner, and installed “The Great Suspender” plugin which also helps - puts tabs to sleep which are not used withing XXX seconds/minutes. I also created a 2GB swap partition. These two things seem to have diminished lockups quite a bit.
Modified it to boot also from USB flash drive. Works fine. Would’ve been nice if an installer automated this config.

#23

Did you provide it with the correct password? :slight_smile:

If you find a fix for this, let me know. I haven’t been playing with the audio side on the rpi for a while.

Browser choice is up to the user. I just use Firefox, because it feels snappier in my tests.

I considered swap partitions a while back, but since the swap resides on an SD card, the system would either lock up or slow to a crawl anyway, because of the slow write speeds to the SD card.

Not everybody wants to do this, since IIRC it voids the warranty on the Pi.

#24

If I didn’t use the correct password then CLI would also not have worked :slight_smile:
does it use a different password?

#25

Pamac should use the sudo password. Just like pacman.

#26

Octopi must be using the ‘manjaro’ user instead of my logged in user? because it’s using pacman commands that work fine for me when I do it with just “sudo …” in the terminal, but when I run Octopi and use the same password it doesn’t work. Or Octopi is doing something else that is causing the error.
Anyway, it’s pretty slow, unusable really on the Pi 3 so the experiment is done for me.
At one point it locked up when just using Octopi and I had to power off then after the USB drive was corrupted and fsck could not fix it.

#27

Octopi uses the root password. It also says that in the window that asks for the password. But you said you where using the LXQT edition, which has Pamac by default.

#28

There’s a little typo RK3328. This is not essential, but if someone uses the correct rk3328 keyword in a search engine, they may not find the topic.

1 Like
#29

Thanks. Edited.

#30

What is the default username and password for LXQT? I put Manjaro for both but I just can't login.

#31

I believe you set those up during the first time you run it, no?

#32

First time the device boots, you have been greeted with some dialog boxes where you put in your desired username and password.
So those are the one used on the installed system. There is no default ones in 19.02, only on Minimal images.
In 19.04 the minimal images also use the configuration setup.