Manjaro-Arm 18.12.1 - keyboard layout at login US only


#1

Hi there.

I switched language/locale etc to German on my installation.

Inside the login screen I cannot select a German keyboard though. Just the US kbd is listed.

Where do I have to configure this?

Thx


#2

I’m pretty sure the login screen only detects the keyboard layout in use by the system. Which is “us” by default.

You can change that in the usual Arch way.


#3

As soon as I login it becomes german. I did it the Arch way I guess.

It is just not available for selection at the login manager screen.


#4

You should be able to set it to german on login manager with:
localectl set-x11-keymap de

However, there is a bug right now in libxcb, so the layout won’t be shown until you start typing in the login manager. I just tested this today, and it works fine on the lXQT edition, after I run the above command and reboot.


#5

I can confirm what you’re saying.

After typing a character the country flag and the keyboard setting changes now.

I did setup the locale and keyboard from the LXQt desktop GUI before.

Obviously:

localectl set-x11-keymap de

is not being taken care of.

I’m wondering if that should be considered a bug.
Having a wrong keyboard installed at login will cause issues. It did in my case when using special characters in the password.

Again. Thx for your support.