Manjaro-Arm 18.12.1 - 3B+ - Turning off bluetooth


#1

The mainline kernel doesn’t come with the device tree overlays (.dtbo) - afaik.

On the RPI kernesl there’s been an overlay to turn off bluetooth:

dtoverlay=pi3-disable-bt

I already tried to blacklist the modules with no effect.

Any hints are appreciated.

Thx.


#2

Maybe just stop and disable the bluetooth service?
sudo systemctl stop bluetooth && sudo systemctl disable bluetooth


#3

The best method to disable bluetooth is to add the following entry to the configuration file:

/etc/modprobe.d/blacklist.conf 

Add this line to the conf file:

install bluetooth /bin/false 

Save the changes to with root privileges, and exit your text editor.

Next we must totally disable the bluetooth service:

sudo systemctl stop bluetooth
sudo systemctl mask bluetooth

Then, restart.


#4

@tbg
Your bruteforce :wink: method did the trick!

Great. Thx a lot.

Just disabling the service would not cut it.

I’m wondering if this “process” could be introduced when disabling Bluetooth
from the GUI (what I tried in the first place) !?!?

Thx again.


#5

Glad to hear that worked.

Please mark your thread solved.


#6

That would entirely depend on the GUI application you use to disable it. :slight_smile:
I maintain nothing related to bluetooth, so that would be an upstream suggestion. :slight_smile:


#7

I used this command:

gsettings set org.blueman.plugins.powermanager auto-power-on false