Manjaro ARM 18.10 released!



Manjaro ARM 18.10 released!

I am proud to announce the immediate availability of Manjaro ARM 18.10.



This is mostly a “bugfix” release, to fix a serious issue with the 18.09 Raspberry Pi images.

And to introduce Raspberry Pi 3 (aarch64) images!

Download here!

Torrents are also available from the same location.

New images are available.

  • Raspberry Pi 2: Minimal and LXQT

  • Raspberry Pi 3: Minimal, LXQT and KDE

  • Odroid C1: Minimal

  • Odroid C2: Minimal, LXQT and KDE

User Password
root root
manjaro manjaro


  • Aarch64 based Raspberry Pi 3 images!
  • New kernels
  • Updated packages in general
  • Raspberry Pi images can now do kernel updates and still work afterwards
  • Small changes to LXQT edition. Using connman and firefox now, just to name a few.
  • Added KDE edition for select devices. Right now it’s oc2 and rpi3.
  • Torrents for all images also available

Updating from 18.09:

If you are updating from our 18.09 raspberry pi images, you probably noticed previously the image would stop working after the first kernel update.

If you still have a working 18.09 image, please follow these steps to correctly update to a working system 18.10 system:

  • Open /etc/fstab with sudo nano /etc/fstab.
  • Add a line containing /dev/mmcblk0p1 /boot vfat defaults 0 0.
  • Save it and reboot.
  • Perform the update: sudo pacman -Syyu.

Also, if you use the 18.09 LXQT image, you need to downgrade xorg-server and xorg-server-common when it says your local ones are newer than the repo. Xorg Server version 1.20.2 stops GUI from starting an ARM devices. Version 1.20.0 is in the repo until it gets fixed.

What about other devices?
I have not built XU4 images of 18.10. I can’t support all these images, so XU4 has become unmaintained.

We don’t support any armv6h devices, as that would require extra manpower and a bigger server hosting the repository.

I only built minimal edition of oc1 this time. I have no idea if it works. The lxqt edition I tried, did not work, so that’s not uploaded. Will probably drop oc1 for next release.

Please consider supporting us via Patreon or by our other options.

Which ARM device should i go for?

Thanks for the update! I am about to install it on my RP 3


Just as a quick note.

I see more and more people making bug reports on the 18.05 MATE version.
The MATE version is no longer supported and should therefore not be downloaded.
It will not get an updated version until someone volunteers to maintain it. I am not a MATE user, so I will not maintain it. :slight_smile:

Should I delete it from the downloads folder all together or is that overkill?


i noticed on the poll thread you mentioned xu4 should work but you havent been able to test yet, in terms of performance between pi3,xu4,oc2, which would you recommend


Raw performance, the XU4 by a large margin.
As the only device it has USB3 ports, octo-core CPU.
After that the C2. It has Gigabit ethernet and eMMC support.
Lastly the RPI3, with only USB2 and 100 MBit ethernet and no eMMC support, is is the weakest of the devices.

The RockPro64 also seems like a beast of a device, so if I can get my hands on one, we will try to get Manjaro ARM running on that too.


my bad, i posted the question here on the announcements thread by mistake , i meant to post it in “Which ARM device should i go for” , but thanks for the input, i’ll do some homework on those and see how it goes


Raspberries until RPi3 included have half 100 Bit ethernet, the RPi3 plus is something better


Are you using kernel 4.19? Any chance we could revisit the Pinebook?


18.10 does not use 4.19 on the image, although linux-aarch64 is updated to it.
But I do have plans to revisit the Pinebook, since I ordered one and waiting for it to arrive!


Wow; that’s awesome! Keep me posted!


That would be awesome to have Manjaro on the RockPro64. The OS is not the best and would love to run something a lot better on it. Wished with all my free time i had the knowledge to help with this.


I just tested the KDE image on a RPi3b and it works fine. Well done.

I am amazed how versatile KDE has become, being a valid choice for pretty much every platform.

Just one note: the display manager is very slow to appear and show the password prompt whether it is at first login or after screen blanking.


I’ve noticed this as well. It also happens on the Odroid. I really don’t know what is causing it, but if you find a solution I will do what I can to implement it in future releases. :slight_smile:


To be fair, I very much dislike “Connman” it’s overly complex and I’ve yet to even get it to work with my wireless usb card on my PI2 (which so far has worked with EVERY distro I’ve tried.). I’d prefer an alternative wireless daemon/tool. I don’t see what was wrong with NetworkManager or why it can’t be added as an option when first configuring/installing.


I will be using NetworkManager in the next release.

The reason why I couldn’t in 18.10 lxqt, was that I hadn’t found out a way to have working gtk apps (because of pixbuf errors at build time) at the time. This has since been solved, as seen in the Pinebook Preview3 image.


i am willing to buy a raspberry pi 3 a+.
so any support for that?


It should be using the same images as the Rpi3 B+. Since it’s the same chipset.

At first boot stuck on uboot on rp3-a+
closed #18

This topic was automatically closed 89 days after the last reply. New replies are no longer allowed.