Manjaro-ARM 18.07 released!

release
manjaroarm
raspberrypi
odroid

#41

But that was never the intent.
The intent is to be as similar to manjaro-tools as possible, including placement of files.

What would that accomplish, that the regular linux-aarch64 package would not?
I’m only gonna add devices, that we actually have the resources to support. And adding “random” devices is not the way to do it.

Well, we already have our own resize-sd script which is doing that. We just need to maintain and test it with the newer builds.


#42

Just got done installing this on my Raspberry Pi 3+. Works great, only problem I had was having a hard time finding user and password. I have tried all kinds of builds, and have tried compiling my own, for little success. Glad I tried this image, I was getting very tired of “emerging” on the Gentoo image.


#43

You can install a free one https://letsencrypt.org/, my hosting provider offers that with a click of a button.


#44

Well, it’s not that easy with our hosting. :slight_smile:

But I think we need to think about what we do with the website.


#45

I was checking your hosting looks pretty simple to set up for Nginx or Apache, you can always ask them to setup for you some hosts do.


#46

This will improve the development environment and can be applied to the main tool (manjaro-tools). :slight_smile:

The kernel 4.18 has a dtb part for some TV box models and there is no support for many hardware elements for this platform yet. The 3.14 kernel has a maximum dtb set (for almost all existing models). Also in 3.14 there is support for all elements of iron, which are used on the platform Amlogic S9xx (WiFi BT remote control, NAND, eMMC etc). For Odroid C2 you use a specialized kernel (3.14), why not use the most adapted kernel for a huge number of TV boxes ? The number of TV boxes on the AML platform for users is estimated in millions, this is the most mass platform, compared to which RPI has a significantly smaller release. :slight_smile:

Now you have to run the partition extension script manually. Manjaro is positioned as a distribution for easy use by regular users. Therefore, it is logical that the partition extension occurs automatically when the system is first started. I propose to use those developments that are already well tested and have been used for a long time without any errors in the work on any device. IMHO the use of proven and free solutions is not plagiarism, it is a normal practice not to waste energy on what is already in the public domain. It is better to spend time on really necessary for the development of Manjaro questions. :slight_smile:

PS I do not impose. What you do is up to you. :slight_smile:


#47

This is a good point. I’ve found the LibreElec script here but it seems “tailored” to the distribution.
But it’s kind of like what we are doing.

I guess they automate it with a service file and the script only runs if the file .please_resize_me exists. When it runs, it will remove that file, so it does not run again.
Quite clever really. :slight_smile:

I’ll see what I can do with the next release.


#48

In Armbian there is a similar option, but there is a one-time start of the service, which after execution is disabled.


#49

Hi @Strit i was wondering if there is any instructions on how you generate the Pi images?, since Manjaro tools are not supported.


#50

I use my own created manjaro-arm-tools.
It can only create the Minimal editions right now, but I plan on expanding them to support the arm-profiles I have been working on.


#51

Excellent, minimal is all i need for now, going to order a PI at some point, thanks :smile:


#52

You could just download the images already made. :slight_smile:


#53

I know, was thinking about doing an octoprint setup, and maybe share it with the community :smile: