Manjaro-ARM 18.07 released!

release
manjaroarm
raspberrypi
odroid

#21

Yes, I wrote about cross-compiling and building the image. Earlier I was collecting ArchLinux images for the Amlogic platform manually, I lacked the system of building the finished image (I already have all the components for this). I’ll go try make, if i’m have any questions, I’ll bother you with them … :slight_smile:


#22

This builds Manjaro-ARM images. Not Arch Linux ARM images. :slight_smile:


#23

Launched on Khadas VIM1 (S905X) in semi-manual mode image for Odroid C2. The console is available. What’s the “root” password ? And what steps should be taken next ? Sorry, not found in themes this information.

Password found " root \ root " :slight_smile:


#24

root password = root
manjaro password = manjaro


#25

Checked update (pacman -Syu) works.
What else do you need to check ? Can i’m install DE in this image of Manjaro ?


#26

Sure. You just need to install the GPU drivers, xorg etc. :slight_smile:


#27

Hi

I tried to install manjaro-ARM_Mate 18.07 on my raspi 3B+. I could not resize the SD card using “sudo resize-sd” script provided. The error message is:

“Error : The device /dev/autofs is so small that it cannot possibly store a file system or partition table. Perhaps you selected the wrong device?”

I am using a 32G sd card.

I could do it with the minimal Manjaro-ARM 18.07, but not on the Mate version.

Please advise how I could resize the sd card. Many thanks


#28

There is no 18.07 MATE edition. I guess you are on the 18.05 image.
@Grayjack should be able to tell you what to do to update it.


#29

Is there any documentation\description of how this tool can be used to build images ?
Where and how can i’m make edits in the image collected ?


#30

The tool’s documentation is the README on gitlab.manjaro.org/manjaro-arm/applications/manjaro-arm-tools/.

Current version of the tools does not support direct editing. It fetches the current profile from my repo.
But you could just edit the script directly (/usr/bin/buildarmimg) to use your package lists.

Be aware, the only profile that produces the official images right now, is the minimal ones.
The other profiles are still a work in progress.


#31

I found a list of devices and image options here.

how to clarify which versions can be collected ? Or is it an arbitrary number that I can ask myself ?

It would be good to add the ability to local copy GIT with the profile in the next version and use it to build. Then you can easily make your changes and then send them to the merge request in the main GIT.


#32

That’s true. I will work on that when I have some time.

The only ones that work is the Minimal one under editions.
All the ones in Devices work, since the tools need at least Device and Edition specified to build an image.


#33

I am interested in what number I can specify. Is this an arbitrary number 18.07 or 18.11 or 21.21.33 ?


#34

Yeah, the version number is just what the image filename is gonna have. So you can call it 0.10, 1.11rc1 or 8Beta10.
It just can’t contain spaces. :stuck_out_tongue:


#35

On behalf of which user can I run the Assembly ? I am now trying to build on behalf of a normal user and at the end (when the process of forming the image itself begins) I get an error that there is no access to the device loop1. Or can I run the Assembly as “root”?

Allocating group tables: done
Writing inode tables: done
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done

442+0 записей получено
442+0 записей отправлено
442 байта скопировано, 0,661427 s, 0,7 kB/s
96+0 записей получено
96+0 записей отправлено
49152 байт (49 kB, 48 KiB) скопирован, 0,195441 s, 251 kB/s
1248+0 записей получено
1248+0 записей отправлено
638976 байт (639 kB, 624 KiB) скопирован, 0,887124 s, 720 kB/s
Successfully wrote U-Boot to /dev/loop0
Warning: Ошибка синхронизации или закрытия файлов /dev/loop0p1: Ошибка ввода/вывода
Warning: Ошибка синхронизации или закрытия файлов /dev/loop0: Ошибка ввода/вывода


#36

buildarmimg should be run as regular user.
You will get prompted for sudo password along the way to manage packages, file changes and devices.


#37

Yes, I do, I run it through sudo. But in the end I get this error and there is no image on the output. Perhaps i’m need additional settings for the user, as in ArchLinux when building packages, add the user to the sudoers file ?

Warning: Error syncing or closing files / dev / loop0p1: I / O error
Warning: Error synchronizing or closing files / dev / loop0: I / O error


#38

Yeah. The user needs to be part of the wheel group or in the sudoers file directly.


#39

I checked, the user is in the group “wheel”. I found another solution. If you make this change in the buildarmimg script, the image is placed in the working directory of the user on whose behalf the build is running. You will not need to search for an image in /var/lib. I checked with myself, the image is normally going (although the error /dev/loop).

if [ ! -d /tmp/manjaro-arm-tools/tmp ] ; then
echo “Create dir TMP”
mkdir -p /tmp/manjaro-arm-tools/tmp
fi

if [ ! -d “$PWD/manjaro-arm-tools/img” ] ; then
echo “Create dir IMG”
mkdir -p “$PWD/manjaro-arm-tools/img”
fi

_ROOTFS="/var/lib/manjaro-arm-tools/img"
_TMPDIR="/tmp/manjaro-arm-tools/tmp"
_IMAGEDIR="$PWD/manjaro-arm-tools/img"
_LIBDIR="/usr/share/manjaro-arm-tools/lib"
_IMGNAME=“Manjaro-ARM-$2-$1-$3”


#40

You can add a device “s9xxx” with the kernel from this link

to the Assembly profiles, the image must consist of two sections (similar to “rpi”). The first FAT , the size of 128 MB , the second EXT4, fbset needed , u-boot is not needed. By the way, in the build system Libreelec and Armbian, there are scripts that automatically expand the second section on the entire device when you first start. They work great on all media (SD and USB). If you are interested, I can give links to the source code, as it is implemented there.