Manjaro-architect, testers wanted

manjaro-architect
zfs
#41

Or if you want the latest build, you can

git clone https://gitlab.manjaro.org/applications/manjaro-architect.git
cd manjaro-architect
makepkg -sric
sudo manjaro-architect
#42

When i use this on the live-iso-environment, i ended up with architect-version 9.14?

live_architect

EDIT: The Desktop-Icon gives me version 9.19.

EDIT2: Ok…when i close architect and terminal and run β€œsudo manjaro-architect” again, it starts version 9.19.

#43

Use newer mirror and run

 setup
#44

I now implemented the grub fix also in legacy boot. Not tested at all.

#45

I have stuck in update-grub during installation, but it finished (not sure without errors).
Hibernator failed without message. On first boot, there was no grub resume=UUID entry. I added manually to boot.

On the installed system (LxQt on MBR system), on the first pacman upgrade, update-grub is stuck (running indefinitely) and I think I have to stop it. Now, what about the remaining hooks? How can I run them?

#46

check in /etc

ls mkinitcpio.*
mkinitcpio.conf

mkinitcpio.d:
linux414.preset  linux419.preset  linux420.preset

file mkinitcpio.conf is empty for hooks

1 Like
#47

I should probably disable it. Hibernator does not work that well in chroot

1 Like
#48

The bug fix for legacy boot is not yet packaged, it’s only pushed to the git repo.

1 Like
#49

Attempting a VM EFI install from the 18.0.4 KDE ISO, using M-A 0.9.22, with unencrypted /boot and LUKS root.

There were a couple of issues, if these have been fixed in 0.9.23 then I guess this post is kinda pointless.

Such is life, but 0.9.22 is on all the current 18.0.4 installation ISOs, and this setup will result in a non booting system.

Prior to launching M-A use gparted to partition.

GPT
/dev/sda1 -> 512MB -> boot, esp Flags 
/dev/sda2 -> Rest of virtual disk (39.5GB)

Prepare Installation.

LUKS Encryption
Automatic LUKS Encryption
/dev/sda2 -> luks-root

Mount partitions.

/dev/mapper/luks-root -> / -> format ext4.
Create swapfile

UEFI Partition
/dev/sda1 -> /boot -> format fat32

Install Manjaro Desktop.

yay+base-devel
linux419
KERNEL-virtualbox-guest-modules
KDE Minimal
No additional packages

Install Display Driver.

Select Display Driver -> video-virtualbox

Following error.

error target not found: virtualbox-guest-utils
error target not found: linux419-virtualbox-guest-modules

Error: pacman failed
Error: script failed

Ignore error and contine, fix later.

Install UEFI Bootloader

grub
set bootloader as default

Configure Base.

Done.

Before rebooting chroot into installed system and fix mhwd.

mhwd -i pci video-virtualbox

Initially I tried chrooting from within M-A during the install to fix mhwd error, couldn't resume after running mhwd though, the following error was generated.

bash: fg: current: no such job

This left the installation in an inconsistent state, I had to start over, next time I fixed mhwd after installation completion.

Long story short ... this produced a non booting system.

Problem was no cryptdevice=UUID=luks-root and root=/dev/mapper/luks-root kernel parameters in /etc/default/grub. These are always required booting an encrypted root partition.

Manually added these in (removed quiet grub params also, be nice if this was optional) and voila, a booting system.

#50

The issue should be fixed for grub, but refind is broken with luks.

Making quiet grub optional might be a good idea, because it slows down the installation by an additional mkinitcpio.

1 Like
#51

Just did another test install using M-A 0.9.24 on unstable, same config as above with /boot esp partition, luks root partition with swapfile.

I don't think the grub config is quite right yet for LUKS root.

There is a cryptdevice=[UUID]:luks-root parameter, but no root=/dev/mapper/luks-root parameter. Both are needed.

https://wiki.archlinux.org/index.php/Dm-crypt/Encrypting_an_entire_system#Configuring_the_boot_loader

Same for LVM on LUKS installs, but the root= param would reference a logical volume device mapper instead of luks device mapper.

https://wiki.archlinux.org/index.php/Dm-crypt/Encrypting_an_entire_system#Configuring_the_boot_loader_2

Installing video-virtualbox via Select Display Driver is still failing too with same error as above.

EDIT:

Here is the full error text when trying to install video-virtualbox, for some reason it looks like it is trying to remove it instead.

> Removing video-virtualbox...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-virtualbox/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
error: target not found: virtualbox-guest-utils
error: target not found: linux414-virtualbox-guest-modules
error: target not found: linux419-virtualbox-guest-modules
error: target not found: linux49-virtualbox-guest-modules
Error: pacman failed!
Error: script failed!



press Enter to continue
2 Likes
#52

Thank you, I just fixed the same issue for refind last night. Should be possible to copy the solution for grub.

2 Likes
#53

In my tests, it seems that grub does not require setting the root parameter with luks+lvm. It seems to automatically detect it. The luks and lvm parts should now work.

I now added an option to keep fsck hook in the preparation menu. So far implemented only in git and only for normal desktop installation and uefi grub. But I will be adding it to other parts as well. I also made sure that systemd-fsck service is being used.

1 Like
#54

Did you test with a separate /boot partition?

#55

Not yet. That one still needs to be tested.

#56

Other users have also reported this issue, but I cannot replicate it. Was this in a tty and with bash? My tests have been conducted in st+tmux+zsh nvironment

#57

Konsole + bash shell.

The testing I did with LVM on LUKS had multiple logical volumes within a LUKS partition, without the root=UUID parameter the root file system was not found by grub. It was a virtualbox install.

Personally I think root=UUID should always be explicitly provided with LUKS systems, not assumed it will be implicitly deduced by grub.

#58

Tested now with separate /boot, luks+lvm(/ and /boot). Uefi, full disk encryption. Works on my end without specifying root parameter. Can I have more data on your setup to replicate the issue? I had

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ List Devices (optional) ─────────────────────────────────┐
β”‚ NAME              MODEL                  TYPE  FSTYPE        SIZE MOUNTPOINT            β”‚
β”‚ sda               WDC_WDS120G2G0B-00EPW0 disk              111.8G                       β”‚
β”‚ β”œβ”€sda1                                   part  ext4           63G                       β”‚
β”‚ β”œβ”€sda2                                   part  vfat          512M /boot                 β”‚
β”‚ └─sda3                                   part  btrfs        48.3G /home                 β”‚
β”‚ sdb               Ultra_Fit              disk              115.7G                       β”‚
β”‚ └─sdb1                                   part  exfat       115.7G /media/matti/DATA     β”‚
β”‚ mmcblk1                                  disk               29.1G                       β”‚
β”‚ β”œβ”€mmcblk1p1                              part  vfat          513M /mnt/boot/efi         β”‚
β”‚ β”œβ”€mmcblk1p2                              part  swap            4G [SWAP]                β”‚
β”‚ └─mmcblk1p3                              part  crypto_LUKS  24.6G                       β”‚
β”‚   └─cryptroot                            crypt LVM2_member  24.6G                       β”‚
β”‚     β”œβ”€lv-lvolboot                        lvm   ext4            2G /mnt/boot             β”‚
β”‚     └─lv-lvolroot                        lvm   ext4         22.7G /mnt                  β”‚
β”‚ mmcblk1boot0                             disk                  4M                       β”‚
β”‚ mmcblk1boot1                             disk                  4M                       β”‚
β”‚                                                                                         β”‚
β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€
β”‚                                       < Back >                                          β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜


#59

Difference between LVM on LUKS and LUKS on LVM.

My EFI and boot partitions are unencrypted (ie Fedora requires separate efi and boot partitions, Manjaro either single efi + boot or just efi), all logical volumes are created within a single luks partition.

sdc                                             8:32   0   50G  0 disk  
β”œβ”€sdc1                                          8:33   0  300M  0 part  
β”œβ”€sdc2                                          8:34   0  500M  0 part  
β”œβ”€sdc3                                          8:35   0  300M  0 part  
β”œβ”€sdc4                                          8:36   0  500M  0 part  
└─sdc5                                          8:37   0 48.4G  0 part  
  └─luks                                      254:2    0 48.4G  0 crypt 
    β”œβ”€vg--luks-lv--swap                       254:3    0    4G  0 lvm   
    β”œβ”€vg--luks-lv--root1                      254:4    0   22G  0 lvm   
    └─vg--luks-lv--root2                      254:5    0   22G  0 lvm   

The luks partition has to be decrypted by grub first (ie cryptdevice=UUID), the root=UUID is the logical volume the root file system resides in. Swap volume is shared.

1 Like
#60

Thanks! Testing with unencrypted /boot outside lvm now.

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ List Devices (optional) ────────────────────────────────┐
β”‚ NAME            MODEL                  TYPE  FSTYPE        SIZE MOUNTPOINT            β”‚
β”‚ sda             WDC_WDS120G2G0B-00EPW0 disk              111.8G                       β”‚
β”‚ β”œβ”€sda1                                 part  ext4           63G                       β”‚
β”‚ β”œβ”€sda2                                 part  vfat          512M /boot                 β”‚
β”‚ └─sda3                                 part  btrfs        48.3G /home                 β”‚
β”‚ sdb             Ultra_Fit              disk              115.7G                       β”‚
β”‚ └─sdb1                                 part  exfat       115.7G /media/matti/DATA     β”‚
β”‚ mmcblk1                                disk               29.1G                       β”‚
β”‚ β”œβ”€mmcblk1p1                            part  vfat          513M /mnt/boot/efi         β”‚
β”‚ β”œβ”€mmcblk1p2                            part  swap            4G [SWAP]                β”‚
β”‚ β”œβ”€mmcblk1p3                            part  ext4          2.3G /mnt/boot             β”‚
β”‚ └─mmcblk1p4                            part  crypto_LUKS  22.4G                       β”‚
β”‚   └─cryptroot                          crypt LVM2_member  22.4G                       β”‚
β”‚     └─lv-lvroot                        lvm   ext4         22.4G /mnt                  β”‚
β”‚ mmcblk1boot0                           disk                  4M                       β”‚
β”‚ mmcblk1boot1                           disk                  4M                       β”‚
β”‚                                                                                       β”‚
β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€
β”‚                                       < Back >                                        β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

1 Like