Manjaro Architect fails during package install [basepkgs 255 error]

i installed m-a on a vm to test drive jade but ended up with enlightenment [as i could nt find jade desktop install option]. as for m-a, any version is ok [if i understand right] as every install is always fresh as its net-install.
did you check pacman cache / pacman-mirrors to update?
just try to re-install and it should be through by removing the error


I’m using Manjaro Architect 20.0.3

Thanks for your reply.

I’ve tried the install several times with free and no n-free drivers, I’ve remade the liveusb from a freshly downloaded iso, and still the same error.

Pacman cache and mirrors: if you mean the options offered by m-a, then yes, I have tried both settings for the cache (transfer from live system and download fresh) and I’ve updated the mirror list and tried it with different mirrors, all with the same result. Is that what you meant?

Thank you for pointing me to the right log. I’ll post what I find there later today.

The nomal installation ISOs also include Architect. Just open a console and run setup
If you can, try the last ISO.

255 seems to result in this case from outdated signatures. In preparation menu, use the option to update keyring and then proceed to install as normal. Alternatively, use a newer iso that already has up to date keyring.

I’ve done this using a freshly downloaded iso. For some reason none of the desktop liveusbs are working for me, though they seem to be more recent.

I downloaded the xfce version and tried booting with both free and non-free drivers. With free, it gave me only a blank screen with an unresponsive cursor on login to xfce. With non-free, xfce started, but I was unable to launch the installer, architect program, or a terminal before it froze. I wasn’t able to get a terminal with ctrl+alt+f6/f7 either.

Unfortunately the dedicated manjaro-architect isos are not that fresh. But, that what refresh keys button is for in the preparation menu.

1 Like

try to install just cli [no desktop / wm]
you should get into tty login on the fresh install. after you boot into your installed system you can install / configure your xorg [i even tried just wayland and no xorg. i was able to get into sway as well as wayfirewith xwayland support. i opted this coz i could not get xorg up and running in first case so i tried wayland… now everything is fine with the same install running kde plasma and i3]
read the forum threads related to free / non-free drivers w r t your graphics
in most options, free drivers just works

i did just that ! i opted for enlightenment and lxdm and i was on enlightenment ! [test drove as a vm]

I have refreshed pacman-keys and gotten the same error.

Here is the end of the log retrieved from /var/log/m-a.log

mkfs.vfat -F32 /dev/nvme0n1p1
create /mnt/boot
mount /dev/nvme0n1p1 /mnt/boot
edit pacman.conf 1
edit pacman-mirrors.conf
pull-profiles repo
selected: "yay + base devel" linux-latest
package to install: nilfs-utils
ERROR [install basepkgs 255]
exit installer
unmount /mnt/boot umount: Symbol `__stack_chk_fail' causes overflow in R_X86_64PC32 relocation
unmount /mnt umount: Symbol `__stack_chk_fail' causes overflow in R_X86_64_PC32 relocation
1 Like

i used the architect installer option from the regular iso. i get options to either opt for the graphical calamares installer OR choose architect. i opted for architect and did fase the base pkg issue which after refresh resolved. perhaps @Chrysostomus will elaborate. i have used plain architect installer AS WELL as the options mentioned above and i could get throough [both on clean install as well as VM]

So you could not replicate the issue?

the issue vanished ! i was infact trying to test drive @codesardine manjaro-JADE iso. i could get to live but was unable to complete the install on a VM, which made me opt to go for the architect install. architect did return base pkg issue butafter keys / mirrors refresh, i could easily get to cli install then choose the gui of my choice.
so in a way i could install from architect [option available in the jade iso]

I’ve now tried live usbs of several distros. CLI works, but none of xfce, KDE, or GNOME work on Manjaro, Arcolinux, and Debian. I suspect it’s an issue with my video card. :frowning:

Thank you so much for your help!

its safe to use non-free drivers.
i would suggest you to try out with wayland protocols. install sway from the manjaro repo. and you can execute from tty with sway
you can get to a gui and find out to get the correct xorg driver.

my personal experience, whenever i found display crash in xorg, i try out wayland and it mostly works

It seems to me that the log doesn’t fully capture the error you are getting. Can you try looking at the terminal during the installation and see what error you are getting?

The errors are different depending on the image. For xfce, I get either a black screen with unresponsive cursor, or a successful login to xfce but no programs will launch and it freezes soon after. With m-a I get something like this:

EDIT: Just to be clear, this was after refreshing pacman keys.

FWIW I also tried to install Arch, and it failed while running pacstrap. It gave errors like “SQUASHFS failed to read block” and “zstd decompression failed”. A search of Arch forums indicated that I should check the device for bad blocks but none were found. The forum thread said that if the drive was good, then the problem would be with the CPU.

So as it stands I’m pretty sure it’s a hardware problem. I’ve removed the CPU and graphics card and will be returning them since they’re still under warranty, so I can’t run more tests at the moment.

Free and non-free drivers both boot to an unusable state, with either Manjaro or Debian (no X, no terminal, no Alt+Fn switching, nothing). And since I can’t even get yay+base-devel and a kernel to complete install, there’s no way I can install wayland. I can’t even get a CLI system installed (though it runs from liveusb up to a point during package installation).

I got that, but as manjaro-architect developer I’m not quite as interested in the graphics driver problems that you are getting on other isos. Thank you for providing the most relevant data! :slightly_smiling_face:

So, it’s definately a key issue like it seemed. The easiest option seems to be to boot one of the newer isos in single user mode. That let’s you get around the driver issues and boot into tty instead of the desktop. Then you can install and you shouldn’t get that key error anymore because you are using a newer iso.

1 Like